Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Cisco 877w Wireless help required

Hi All,

I've got my new Cisco 877w working EXCEPT for wireless. More specifically, wireless clients can join the wireless network, etc. but can't reach the Internet. My aim is to have Dot11Radio0 no different to one of the switch ports. It's as if I want Dot11Radio0 to be part of vlan 0, just like the switch ports, but I'm not sure how to achieve this. Note that I run my own dhcp server, and my subnet is 192.168.0.0/24

If anyone can help, it would be appreciated.

Here's my config:

hostname MyRouter
ip domain-name mydomain.com

username MyUsername secret MyPassword
enable secret MyPassword
line vty 0 4
access-class 2 in
login local
transport input telnet

access-list 2 permit host 192.168.0.2

interface FastEthernet0
switchport access Vlan 01
switchport mode access
no ip address
load-interval 30
no shutdown

interface FastEthernet1
switchport access Vlan 01
switchport mode access
no ip address
load-interval 30
no shutdown

interface FastEthernet2
switchport access Vlan 01
switchport mode access
no ip address
load-interval 30
no shutdown

interface FastEthernet3
switchport access Vlan 01
switchport mode access
no ip address
load-interval 30
no shutdown

interface Vlan01
description InternalSwitchPorts
ip address 192.168.0.1 255.255.255.0
ip nat inside
no shutdown

interface ATM0
no ip address
no atm ilmi-keepalive
bundle-enable
dsl operating-mode auto
bridge-group 1
hold-queue 224 in
pvc 8/35
pppoe-client dial-pool-number 1
no shutdown
!

!

interface Dialer1
ip address negotiated
ip nat outside
ip virtual-reassembly
encapsulation ppp
ip tcp adjust-mss 1452
no ip mroute-cache
dialer pool 1
dialer-group 1
no peer default ip address
no cdp enable
ppp authentication pap chap callin
ppp chap hostname MyUsername
ppp chap password MyPassword
ppp pap sent-username MyUsername password MyPassword
no shutdown
!

!Wireless Interface
!------------------
interface Dot11Radio0
description Codekidz wireless access point
no ip address
no ip redirects
encryption mode ciphers tkip
ssid Codekidz
authentication open
authentication key-management wpa
guest-mode
wpa-psk ascii MyPassword
max-associations 15
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
no cdp enable
ip nat inside
station-role root
no dot11 extension aironet
no shutdown

ip route 0.0.0.0 0.0.0.0 Dialer1
ip nat inside source list 102 interface Dialer1 overload
access-list 102 permit ip 192.168.0.0 0.0.0.255 any

Everyone's tags (2)
1 REPLY
Cisco Employee

Re: Cisco 877w Wireless help required

Are the clients getting the IP address?? i dont think so.. plz verify.. and there is no concept of vlan 0. we need to specify the vlan in the encryptiion so that the clients will ge the IP from the respective DHCP pool. it should be.. like below aasuming we are using vlan 1..

interface Dot11Radio0
description Codekidz wireless access point
no ip address
no ip redirects
encryption vlan 1 mode ciphers tkip
ssid Codekidz
authentication open

vlan 1
authentication key-management wpa
guest-mode
wpa-psk ascii MyPassword

I request you to have a glance into the below link which gives us the best practises and the design implementation and the configuration examples.

http://www.cisco.com/en/US/docs/routers/access/800/850/software/configuration/guide/wireless.html

Regards
Surendra

5299
Views
0
Helpful
1
Replies
CreatePlease to create content