Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Cisco Aironet 1200 wireless network very slow

I have a simple wireless network set up, 2 - Cisco Aironet 1200 AIR-AP1220B-A-K9 wireless access points with 2 dBi Diversity Omni directional Ceiling Mount Antennas. They are the only devices connected to a Multitech Routfinder router, the WAN side the router is connected to a dedicated DSL connection. They are powered by AIR-PWRINJ3 power injectors. The WAP get the IP address from the DHCP in the router.

When connecting to the wireless network it runs very very slow, the signal strength is excellent and the connection speed is 54 mbps. But when opening a web browser it takes for ever to load a simple page like msn.com. If I connect the notebook directly to the router it runs very fast. We have tested with several notebooks and have the same problem. When I view the available wireless networks in range the only two that show up are the two Cisco 1200 WAP.

I have done the following with no improvement:

Change the channels from auto to 6 on one and 11 on the other.

Reset to factory defaults.

Update the firmware to c1200-k9w7-tar.123-7.JA2.tar

Replace the 802.11b radios with 802.11g radios AIR-MP21G-A-K9.

Disable the Aironet extensions.

Following is the configuration from one of the access points (before the firmware update):

!

version 12.2

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname MMA1

!

aaa new-model

!

!

aaa group server radius rad_eap

!

aaa group server radius rad_mac

!

aaa group server radius rad_acct

!

aaa group server radius rad_admin

!

aaa group server tacacs+ tac_admin

!

aaa group server radius rad_pmip

!

aaa group server radius dummy

!

aaa authentication login default local

aaa authentication login eap_methods group rad_eap

aaa authentication login mac_methods local

aaa authorization exec default local

aaa authorization ipmobile default group rad_pmip

aaa accounting network acct_methods start-stop group rad_acct

aaa session-id common

!

username xxxx privilege 15 password xxxx

username xxx privilege 15 password xxxx

ip subnet-zero

!

!

bridge irb

!

!

interface Dot11Radio0

no ip address

no ip route-cache

!

ssid MMA1

authentication open

guest-mode

!

speed basic-1.0 basic-2.0 basic-5.5 basic-11.0

rts threshold 2312

station-role root

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface FastEthernet0

no ip address

no ip route-cache

duplex auto

speed auto

bridge-group 1

no bridge-group 1 source-learning

bridge-group 1 spanning-disabled

!

interface BVI1

ip address 192.168.10.100 255.255.255.0

no ip route-cache

!

ip default-gateway 192.168.10.1

ip http server

ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag/ivory/1100

ip http authentication aaa

bridge 1 route ip

!

!

line con 0

line vty 5 15

!

End

Any suggestions would be greatly appreciated.

Best regards,

Randy

5 REPLIES
Silver

Re: Cisco Aironet 1200 wireless network very slow

Around what time you feel this slow nwteork performance?. I mean is it persistent always or only at some specific times?. If at specific times, let me know the processes that usually occur during thsat time.

New Member

Re: Cisco Aironet 1200 wireless network very slow

All of the time.

Green

Re: Cisco Aironet 1200 wireless network very slow

It sounds like A) Duplex Mismatch or B) bad cables

Try forcing the APs to 10/half, then 10/full, 100/half .... and try auto.

Autospeed/duplex doesn't always work well between vendors.

First, try hard setting speed/duplex to the same values on both devices (APs & Routers).

Then start from slow and work your way up. If 10 works better, and / or half duplex works better, then you probably have a cabling problem (a split pair, pins 3&6 most likely).

Check it out and get back to us.

Good Luck

Scott

New Member

Re: Cisco Aironet 1200 wireless network very slow

Thanks for the info.

The documentation say not to switch from auto to full duplex or half duplex when using inline power, well I think it says the AP may reboot. I may have tried half duplex before I upgraded the firmware.

While upgrading I disconnected the AP, used a patch cord to connect it to the router and pluged the power directly into it to make sure the wiring to the AP was not the problem and it did the same thing.

However, when trying to upgrade the firmware it took ~ 45 minuets to upload the image and filed a couple of times retrying. I connected the AP to the notebook directly with a crossover cable and it uploaded in about 45 seconds.

That got me to thinking that there may be a problem with the router so I have replaced it with a Linksys.

In the mean time the DSL went down yesterday so I have not been able to test the new setup.

The cables are T568B

W/O

O/W

W/G

B/W

W/B

G/W

W/B

B/W

Best regards,

Randy

Green

Re: Cisco Aironet 1200 wireless network very slow

Assuming cabling, speed & duplex are ok, then the next most likely culprit would be a L2 loop & broadcast storm.

Do the other devices on the LAN also slow down?

Do the switch activity LEDs show high activity?

Any problems with console or telnet connections while things are running slow?

Can you plug in a computer runining Ethereal to the same segment?

Let us know

Scott

2432
Views
0
Helpful
5
Replies