Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Attention: The Community will be in read-only mode on 12/14/2017 from 12:00 am pacific to 11:30 am.

During this time you will only be able to see content. Other interactions such as posting, replying to questions, or marking content as helpful will be disabled for few hours.

We apologize for the inconvenience while we perform important updates to the Community.

New Member

Cisco Aironet 2600 Series DHCP Server Configuration NOT Serving Addresses?

Cisco Aironet 2600 Series DHCP Server Configuration NOT Serving Addresses?

I have (2) AIR-SAP2602I-A-K9 similarly configured,

on two different isolated LANs.

They don't appear to be handing out addresses via DHCP.

{If I connect them to a LAN with a different DHCP server,

   the wireless devices can get addresses

   from that other DHCP server on the LAN, through the AP.}

I followed 12.4.25d.JA.cg.pdf

Configuring the Access Point to Provide DHCP Service 5-22

---------|---------|---------|

e.g. 3444-RCS1-AN#show running-config                                                                 

Building configuration...

version 15.2                         

hostname 3444-RCS1-AN                

no ip routing

ip domain name USH-DM

ip dhcp excluded-address 192.168.29.89

ip dhcp pool RCS1

network 192.168.29.88 255.255.255.248

default-router 192.168.28.1

lease 0 1

interface BVI1

ip address 192.168.28.211 255.255.254.0

no ip route-cache

ip default-gateway 192.168.28.1

---------|---------|---------|

---------|---------|---------|

e.g. 3444-RCS2-AN#show running-config

Building configuration...

version 15.2

hostname 3444-RCS2-AN

no ip routing

ip domain name USH-DM

ip dhcp excluded-address 192.168.129.81

ip dhcp pool RCS2

network 192.168.129.80 255.255.255.248

default-router 192.168.128.1

lease 0 2

interface BVI1

ip address 192.168.128.171 255.255.254.0

no ip route-cache

ip default-gateway 192.168.128.1

---------|---------|---------|

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Gold

Re: Cisco Aironet 2600 Series DHCP Server Configuration NOT Serv

Thats the DHCP Pool range 192.168.29.88 through 192.168.28.95

Well that's going to confuse your clients.

And that's NOT how you configure your "range".   See below:

ip dhcp excluded-address 192.168.29.1 192.168.29.87

ip dhcp excluded-address 192.168.29.96 192.168.29.254

ip dhcp pool RCS1

network 192.168.28.211 255.255.254.0

default-router 192.168.28.1

lease 0 1

6 REPLIES
Hall of Fame Super Gold

Re: Cisco Aironet 2600 Series DHCP Server Configuration NOT Serv

ip dhcp pool RCS1

network 192.168.29.88 255.255.255.248

default-router 192.168.28.1

lease 0 1

The subnet is different. 

Your network is 192.168.29.88 up to 192.168.29.95 but your default router is way out. 

New Member

Re: Cisco Aironet 2600 Series DHCP Server Configuration NOT Serv

The LAN address range is 192.168.28.0 through 192.168.29.255 (/23)

The AP is assigned IP 192.168.28.211 with mask 255.255.254.0 (/23)

Thats the DHCP Pool range 192.168.29.88 through 192.168.28.95

{Unless I am misunderstanding the documentation 12.4.25d.JA.cg.pdf}

...

Step 3 ip dhcp pool pool_name Create a name for the pool of IP addresses that the wireless device assigns

in response to DHCP requests, and enter DHCP configuration mode.

Step 4 network subnet_number

[ mask | prefix-length ]

Assign the subnet number for the address pool. The wireless device

assigns IP addresses within this subnet.

Hall of Fame Super Gold

Re: Cisco Aironet 2600 Series DHCP Server Configuration NOT Serv

Thats the DHCP Pool range 192.168.29.88 through 192.168.28.95

Well that's going to confuse your clients.

And that's NOT how you configure your "range".   See below:

ip dhcp excluded-address 192.168.29.1 192.168.29.87

ip dhcp excluded-address 192.168.29.96 192.168.29.254

ip dhcp pool RCS1

network 192.168.28.211 255.255.254.0

default-router 192.168.28.1

lease 0 1

New Member

Cisco Aironet 2600 Series DHCP Server Configuration NOT Serving

Yes, of course, you're right.

However It doesn't appear to allow redefining the ip dhcp pool network,

  and I can't seem to find a command that willl clear / remove the pool?

refs:

<http://www.cisco.com/en/US/docs/wireless/access_point/12.4.25d.JA/Configuration/guide/scg12.4.25d.JA-chap5-admin.html#wp1090319>

<http://www.cisco.com/en/US/docs/ios/12_2/ip/configuration/guide/1cfdhcp.html>

New Member

Cisco Aironet 2600 Series DHCP Server Configuration NOT Serving

The answer is: default ip dhcp pool RCS2

(sigh)

Hall of Fame Super Gold

Cisco Aironet 2600 Series DHCP Server Configuration NOT Serving

However It doesn't appear to allow redefining the ip dhcp pool network, and I can't seem to find a command that willl clear / remove the pool?

Sorry, just saw your post. 

Try this: 

no ip dhcp pool RCS1

ip dhcp pool RCS1

network 192.168.28.211 255.255.254.0

default-router 192.168.28.1

lease 0 1

6261
Views
0
Helpful
6
Replies
CreatePlease to create content