Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

cisco autonomous 1242 bridge two switches

Hello,

We are trying to configure two Cisco autonomous to work in bridge mode to connect two switches with a trunk.

the configuration:

First AP:

!

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname Solel_10_AP

!

logging rate-limit console 9

enable secret 5 $1$4UyT$sd08naXSEAWXrAojCKs0f1

!

no aaa new-model

!

!

dot11 syslog

!

dot11 ssid ts25

   vlan 999

   authentication open

   authentication key-management wpa

   infrastructure-ssid

   wpa-psk ascii 7 0803604F2B3504351E2A

!

!

!

username Cisco password 7 096F471A1A0A

!

!

bridge irb

!

!

interface Dot11Radio0

no ip address

no ip route-cache

!

encryption vlan 999 mode ciphers tkip

!

ssid ts25

!

station-role root bridge

world-mode dot11d country-code IL outdoor

!

interface Dot11Radio0.10

encapsulation dot1Q 10

no ip route-cache

bridge-group 1

!

interface Dot11Radio0.101

encapsulation dot1Q 101

no ip route-cache

bridge-group 101

!

interface Dot11Radio0.104

encapsulation dot1Q 104

no ip route-cache

bridge-group 104

!

interface Dot11Radio0.108

encapsulation dot1Q 108

no ip route-cache

bridge-group 108

!

interface Dot11Radio0.109

encapsulation dot1Q 109

no ip route-cache

bridge-group 109

!        

interface Dot11Radio0.113

encapsulation dot1Q 113

no ip route-cache

bridge-group 113

!

interface Dot11Radio0.999

encapsulation dot1Q 999 native

no ip route-cache

bridge-group 255

!

interface Dot11Radio1

no ip address

no ip route-cache

shutdown

no dfs band block

channel dfs

station-role root

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface FastEthernet0

no ip address

no ip route-cache

duplex auto

speed auto

!

interface FastEthernet0.10

encapsulation dot1Q 10

no ip route-cache

bridge-group 1

!

interface FastEthernet0.101

encapsulation dot1Q 101

no ip route-cache

bridge-group 101

!

interface FastEthernet0.104

encapsulation dot1Q 104

no ip route-cache

bridge-group 104

!

interface FastEthernet0.108

encapsulation dot1Q 108

no ip route-cache

bridge-group 108

!

interface FastEthernet0.109

encapsulation dot1Q 109

no ip route-cache

bridge-group 109

!

interface FastEthernet0.113

encapsulation dot1Q 113

no ip route-cache

bridge-group 113

!

interface FastEthernet0.999

encapsulation dot1Q 999 native

no ip route-cache

bridge-group 255

!

interface BVI1

ip address 10.254.24.10 255.255.255.0

no ip route-cache

!        

ip default-gateway 10.254.24.254

ip http server

no ip http secure-server

ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag

bridge 1 route ip

!

!

!

line con 0

logging synchronous

line vty 0 4

logging synchronous

login local

!

end

second AP:

Current configuration : 2654 bytes

!

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname Handasa

!

logging rate-limit console 9

enable secret 5 $1$GDHp$n9MR5.72QzhxdV59PFp0/1

!

no aaa new-model

!

!

dot11 syslog

!

dot11 ssid ts25

   vlan 999

   authentication open

   authentication key-management wpa

   infrastructure-ssid

   wpa-psk ascii 7 0803604F2B3504351E2A

!

!

!

username Cisco password 7 032752180500

!

!

bridge irb

!

!

interface Dot11Radio0

no ip address

no ip route-cache

!

encryption vlan 999 mode ciphers tkip

!

ssid ts25

!

station-role non-root bridge

world-mode dot11d country-code IL outdoor

!

interface Dot11Radio0.10

encapsulation dot1Q 10

no ip route-cache

bridge-group 1

!

interface Dot11Radio0.101

encapsulation dot1Q 101

no ip route-cache

bridge-group 101

!

interface Dot11Radio0.104

encapsulation dot1Q 104

no ip route-cache

bridge-group 104

!

interface Dot11Radio0.108

encapsulation dot1Q 108

no ip route-cache

bridge-group 108

!

interface Dot11Radio0.109

encapsulation dot1Q 109

no ip route-cache

bridge-group 109

!

interface Dot11Radio0.113

encapsulation dot1Q 113

no ip route-cache

bridge-group 113

!

interface Dot11Radio0.999

encapsulation dot1Q 999 native

no ip route-cache

bridge-group 255

!

interface Dot11Radio1

no ip address

no ip route-cache

shutdown

no dfs band block

channel dfs

station-role root

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface FastEthernet0

no ip address

no ip route-cache

duplex auto

speed auto

!

interface FastEthernet0.10

encapsulation dot1Q 10

no ip route-cache

bridge-group 1

!

interface FastEthernet0.101

encapsulation dot1Q 101

no ip route-cache

bridge-group 101

!

interface FastEthernet0.104

encapsulation dot1Q 104

no ip route-cache

bridge-group 104

!

interface FastEthernet0.108

encapsulation dot1Q 108

no ip route-cache

bridge-group 108

!

interface FastEthernet0.109

encapsulation dot1Q 109

no ip route-cache

bridge-group 109

!

interface FastEthernet0.113

encapsulation dot1Q 113

no ip route-cache

bridge-group 113

!

interface FastEthernet0.999

encapsulation dot1Q 999 native

no ip route-cache

bridge-group 255

!

interface BVI1

ip address 10.254.24.9 255.255.255.0

no ip route-cache

!

ip default-gateway 10.254.24.254

ip http server

no ip http secure-server

ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag

bridge 1 route ip

!

!

!

line con 0

line vty 0 4

login local

!

end

The client assocation table:

Handasa#show dot11 associations 

802.11 Client Stations on Dot11Radio0:

SSID [ts25] :

MAC Address    IP address      Device        Name            Parent         State    

0024.989a.ff10 10.254.24.10    11g-bridge    Solel_10_AP     -              Assoc   

When we connect a computer to the switch in vlan 10 we manage to ping the local AP.

The APs can't ping each other, and there is no network connectivity between the APs.

Is there any debug/show command that can help me trobuleshoot the issue?

Best regards,

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Silver

Re: cisco autonomous 1242 bridge two switches

On autonomous ap, the ap has to be the native vlan. There is no way around this.

Sent from Cisco Technical Support iPhone App

-Scott
*** Please rate helpful posts ***
8 REPLIES
Hall of Fame Super Silver

Re: cisco autonomous 1242 bridge two switches

Here is a good guide regarding configuration. I guess the question also is if the bridge can form a link first between each other. That is the first thing that needs to be done before testing the other vlans.

https://supportforums.cisco.com/docs/DOC-16087

Sent from Cisco Technical Support iPhone App

-Scott
*** Please rate helpful posts ***

cisco autonomous 1242 bridge two switches

Hello,

interface Dot11Radio0.10

encapsulation dot1Q 10

no ip route-cache

bridge-group 1

interface Dot11Radio0.999

encapsulation dot1Q 999 native

no ip route-cache

bridge-group 255

Bridge group number must be same as sub-interface. So, the above two are not correct.

(I advise to use subinterface, VLAN tag and bridge group numbers all the same).

HTH

Amjad

Rating useful replies is more useful than saying "Thank you"

Rating useful replies is more useful than saying "Thank you"
Hall of Fame Super Silver

Re: cisco autonomous 1242 bridge two switches

I believe that you can make them different due to the max bridge-group number you can use and the high vlan id's that some define. You just need to make sure bridge-group 1 is defined for your native vlan.

Sent from Cisco Technical Support iPhone App

-Scott
*** Please rate helpful posts ***

Re: cisco autonomous 1242 bridge two switches

Yes. Scott. I remember that two of them must match, so after I refer to the doc I found that the VLAN and the Sub-Interface numbers need to match (except native vlan):

'''snip'''

Native VLAN is always mapped to Bridge Group 1 by default. For other VLANs, Bridge Group

number matches VLAN number; for example, for VLAN 46, Bridge Group is 46.

'''snip'''

This is from the mesh 7.0 guide.

I never had the time to test in practice and I am not sure if the "by default" above includes other VLANs other than the native one (which makes the meaning that this is the default only but can be changed).

soon I'll be testing all those options. If I have the time, hopefully.

Thanks Scott.

Regards,

Amjad

Rating useful replies is more useful than saying "Thank you"

Rating useful replies is more useful than saying "Thank you"

Re: cisco autonomous 1242 bridge two switches

The bridge ids aren't a requirement to match .. I have bridges that don't .. Native yes .. Vlan/trunk and interface yes ..

Sent from Cisco Technical Support iPad App

__________________________________________________________________________________________ "Satisfaction does not come from knowing the solution, it comes from knowing why." - Rosalind Franklin ___________________________________________________________
New Member

cisco autonomous 1242 bridge two switches

Hi Scott,

Thank you for the answer.

When we configure the bridge-group 1 in other vlan that isn't the NATIVE it's works but only until the next reboot.

The problem is that we want the management IP to be in a diffrent vlan then the NATIVE vlan.

Do you know of a way to configure it?

Thanks alot,

Omer Shtivi

Hall of Fame Super Silver

Re: cisco autonomous 1242 bridge two switches

On autonomous ap, the ap has to be the native vlan. There is no way around this.

Sent from Cisco Technical Support iPhone App

-Scott
*** Please rate helpful posts ***
New Member

Re: cisco autonomous 1242 bridge two switches

Hello to all,

We removed the configuration of the bridge-group 1 from dot11radio0.10 and fa0.10 and we reconfigure it again and it's start working again (maybe some kind of bug? we are not sure).

Thanks everyone for all the help

Omer Shtivi

414
Views
5
Helpful
8
Replies