Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Client can't get IP from external DHCP via WiM

WiSM 5.2.178.0

6509 12.2(33)SXH2a

WiSM is up, 1231 & 1131 APs joined, radios up, client associated but no IP address.

Virtual interface with vlan# & IP on the destination vlan.

WLAN with same vlan# as above.

Tried Open, PSK, WPA. Client cannot get an IP adress.

What did I miss???

1 ACCEPTED SOLUTION

Accepted Solutions
Silver

Re: Client can't get IP from external DHCP via WiM

Do you have the virtual address set to 1.1.1.1?

Also, have you configured the DHCP server address on your VLAN interfaces? This is important because the controller basically uses an ip helper-address to properly forward DHCP requests.

If you have these configured, try using the internal DHCP server to make a test. Using the web GUI, go to Controller -> Internal DHCP Server. Configure a DHCP scope and enable it (don't worry, this is only used for wireless clients. It doesn't respond to DHCP requests on your network).

Now go back to Controller -> Interfaces and configure the DHCP server for the controller's management interface. See if your clients are able to get addresses from the internal scope.

4 REPLIES
Silver

Re: Client can't get IP from external DHCP via WiM

The Virtual interface should be configured with an unused externally-routed address. 99% of the time, this should be 1.1.1.1.

Other than that, make sure that your interfaces have the proper default gateways assigned. You can check this using the web GUI under Controller -> Interfaces.

Finally, check to make sure routing is working on these VLANs. Assign a switchport to your wireless VLAN and plug your client in. If you don't get an address through the wire, it's likely that your WiSM is configured correctly and you have a routing issue.

Jeff

New Member

Re: Client can't get IP from external DHCP via WiM

My mistake. That should read Dynamic Interface.

Routing is done by the host 6509, gateway is correct.

Destination vlan is currently in use without issue by clients on autonomous APs.

Silver

Re: Client can't get IP from external DHCP via WiM

Do you have the virtual address set to 1.1.1.1?

Also, have you configured the DHCP server address on your VLAN interfaces? This is important because the controller basically uses an ip helper-address to properly forward DHCP requests.

If you have these configured, try using the internal DHCP server to make a test. Using the web GUI, go to Controller -> Internal DHCP Server. Configure a DHCP scope and enable it (don't worry, this is only used for wireless clients. It doesn't respond to DHCP requests on your network).

Now go back to Controller -> Interfaces and configure the DHCP server for the controller's management interface. See if your clients are able to get addresses from the internal scope.

New Member

Re: Client can't get IP from external DHCP via WiM

I missed something simple. See attached screenshot.

Thanks for your help!

210
Views
0
Helpful
4
Replies