Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Configure 1141n with 802.11n

Hello Community,

I am currently trying to configure a 1141n (AIR-AP1141N-E-K9) autonomous access point with 802.11n. When i configure the access point for no encryption or aes-ccm encryption i am not able to set up the speed settings for dot11n (max. 54 mb/s).Furthermore the documentation (datasheet, IOS conf guide, getting started) says that the ap has two interface for 2.4 GHz (dot11radio0) and 5 GHz (dot11radio1) radio. I am not able to configure the dot11radio1 interface. I already tried to reset the ap to default configuration but this makes no difference. Even with default conf i can not setup dot11n. My question is: what am i doing wrong? Can somebody help me?

Regards

Bastian

---------------------------------------------------------------------------------------------------------------------

Cisco IOS Software, C1140 Software (C1140-K9W7-M), Version 12.4(21a)JA1, RELEASE SOFTWARE (fc1)

cisco AIR-AP1141N-E-K9     (PowerPC405ex) processor (revision B0) with 98294K/32
768K bytes of memory.
Processor board ID FCZ1419W0LN
PowerPC405ex CPU at 586Mhz, revision number 0x147E
Last reset from power-on
1 Gigabit Ethernet interface
1 802.11 Radio(s) <---- correct????????

---------------------------------------------------------------------------------------------------------------------

---------------------------------------------------------------------------------------------------------------------
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname jug5128
!
enable secret 5 <...>
!
aaa new-model
!
!
aaa group server radius rad_mac
server 10.1.111.33 auth-port 1812 acct-port 1813
!
aaa authentication login default group radius
aaa authentication login auth_mac group rad_mac
aaa authorization exec default group radius
!
aaa session-id common
ip domain name zentral-de.jug.de
!
!
dot11 syslog
dot11 vlan-name ADMIN vlan 119
dot11 vlan-name WLAN vlan 130
!
dot11 ssid junghans119
   vlan 119
   authentication open
   authentication key-management wpa version 2
   wpa-psk ascii 7 <...>
!
dot11 ssid junghans130
   vlan 130
   authentication open
   authentication key-management wpa version 2
   wpa-psk ascii 7 <...>
!
!
crypto pki trustpoint TP-self-signed-3181710497
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-3181710497
revocation-check none
rsakeypair TP-self-signed-3181710497
!
!
crypto pki certificate chain TP-self-signed-3181710497
certificate self-signed 01
<...>
  quit
!
!
bridge irb
!
!
interface Dot11Radio0
no ip address
no ip route-cache
!
encryption vlan 130 mode ciphers aes-ccm
!
encryption vlan 119 mode ciphers aes-ccm

!
ssid junghans119
!
ssid junghans130
!
antenna gain 0
speed  basic-1.0 2.0 5.5 11.0 6.0 9.0 12.0 18.0 24.0 36.0 48.0 54.0 m0. m1. m2. m3. m4. m8. m9. m10. m11. m12. m13. m14. m15.
station-role root
!
interface Dot11Radio0.119
encapsulation dot1Q 119 native
no ip route-cache
bridge-group 1
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
bridge-group 1 spanning-disabled
!
interface Dot11Radio0.130
encapsulation dot1Q 130
no ip route-cache
bridge-group 3
bridge-group 3 subscriber-loop-control
bridge-group 3 block-unknown-source
no bridge-group 3 source-learning
no bridge-group 3 unicast-flooding
bridge-group 3 spanning-disabled
!
interface GigabitEthernet0
no ip address
no ip route-cache
duplex auto
speed auto
no keepalive
!
interface GigabitEthernet0.119
encapsulation dot1Q 119 native
no ip route-cache
bridge-group 1
no bridge-group 1 source-learning
bridge-group 1 spanning-disabled
!
interface GigabitEthernet0.130
encapsulation dot1Q 130
no ip route-cache
bridge-group 3
no bridge-group 3 source-learning
bridge-group 3 spanning-disabled
!
interface BVI1
ip address 10.1.119.92 255.255.255.0
no ip route-cache
!
ip default-gateway 10.1.119.1
no ip http server
ip http secure-server
ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
ip radius source-interface BVI1
snmp-server community test RO
no cdp run
radius-server local
!
radius-server attribute 32 include-in-access-req format %h
radius-server host 10.1.111.33 auth-port 1812 acct-port 1813 key 7 <...>
radius-server vsa send accounting
bridge 1 route ip
!
!
!
line con 0
line vty 0 4
!
end

---------------------------------------------------------------------------------------------------------------------

---------------------------------------------------------------------------------------------------------------------

jug5128(config)#interface dot11Radio ?
  <0-0>  Dot11Radio interface number

---------------------------------------------------------------------------------------------------------------------

1 ACCEPTED SOLUTION

Accepted Solutions
Gold

Re: Configure 1141n with 802.11n

According to the output you are associating at MCS rates

"Current Rate: m15"

You will not be able to achieve the full 300Mbps data rate until you enable channel bonding but this is not recommended for the b/g networks because it would effectivly leave you with only one non-overlapping channel.

4 REPLIES
Gold

Re: Configure 1141n with 802.11n

It looks like you have an 1141 which only has one radio.  The 1142 has dual radios.

As far as not connecting at MCS rates, I don't see anything jumping out in the config.  What model of client card are you using to test with?  Could you post the output of "show dot11 assoc all" when the client is associated?

Community Member

Re: Configure 1141n with 802.11n

Oops thats right, 1141 is single-band. Therefore one interface :-) Thanks

I tested with a "ThinkPad 11a/b/g/n WLAN Mini PCI Express  Adapter"

Here is the output:

jug5128#show dot11 associations all
Address           : 0019.7e57.28e7     Name             : NONE
IP Address        : 10.1.130.3         Interface        : Dot11Radio 0
Device            : ccx-client         Software Version : NONE
CCX Version       : 4                  Client MFP       : Off

State             : Assoc              Parent           : self
SSID              : junghans130
VLAN              : 130
Hops to Infra     : 1                  Association Id   : 1
Clients Associated: 0                  Repeaters associated: 0
Tunnel Address    : 0.0.0.0
Key Mgmt type     : WPAv2 PSK          Encryption       : AES-CCMP
Current Rate      : m15.               Capability       : WMM ShortHdr ShortSlot
Supported Rates   : 1.0 2.0 5.5 11.0 6.0 9.0 12.0 18.0 24.0 36.0 48.0 54.0 m0. m                                                                              1. m2. m3. m4. m8. m9. m10. m11. m12. m13. m14. m15.
Voice Rates       : disabled           Bandwidth        : 20 MHz
Signal Strength   : -48  dBm           Connected for    : 592 seconds
Signal to Noise   : 42  dB            Activity Timeout : 20 seconds
Power-save        : Off                Last Activity    : 0 seconds ago
Apsd DE AC(s)     : NONE

Packets Input     : 1820               Packets Output   : 524
Bytes Input       : 260447             Bytes Output     : 161168
Duplicates Rcvd   : 0                  Data Retries     : 8
Decrypt Failed    : 0                  RTS Retries      : 0
MIC Failed        : 0                  MIC Missing      : 0
Packets Redirected: 0                  Redirect Filtered: 0
Session timeout   : 0 seconds
Reauthenticate in : never

jug5128(config)#interface dot11Radio 0
jug5128(config-if)#speed ?
  1.0         Allow 1.0 Mb/s rate
  11.0        Allow 11.0 Mb/s rate
  12.0        Allow 12.0 Mb/s rate
  18.0        Allow 18.0 Mb/s rate
  2.0         Allow 2.0 Mb/s rate
  24.0        Allow 24.0 Mb/s rate
  36.0        Allow 36.0 Mb/s rate
  48.0        Allow 48.0 Mb/s rate
  5.5         Allow 5.5 Mb/s rate
  54.0        Allow 54.0 Mb/s rate
  6.0         Allow 6.0 Mb/s rate
  9.0         Allow 9.0 Mb/s rate
  basic-1.0   Require 1.0 Mb/s rate
  basic-11.0  Require 11.0 Mb/s rate
  basic-12.0  Require 12.0 Mb/s rate
  basic-18.0  Require 18.0 Mb/s rate
  basic-2.0   Require 2.0 Mb/s rate
  basic-24.0  Require 24.0 Mb/s rate
  basic-36.0  Require 36.0 Mb/s rate
  basic-48.0  Require 48.0 Mb/s rate
  basic-5.5   Require 5.5 Mb/s rate
  basic-54.0  Require 54.0 Mb/s rate
  basic-6.0   Require 6.0 Mb/s rate
  basic-9.0   Require 9.0 Mb/s rate
  default     Set default rates
  m0-7        Allow MCS rate indices 0-7
  m0.         Allow MCS rate index 0
  m1.         Allow MCS rate index 1
  m10.        Allow MCS rate index 10
  m11.        Allow MCS rate index 11
  m12.        Allow MCS rate index 12
  m13.        Allow MCS rate index 13
  m14.        Allow MCS rate index 14
  m15.        Allow MCS rate index 15
  m2.         Allow MCS rate index 2
  m3.         Allow MCS rate index 3
  m4.         Allow MCS rate index 4
  m5.         Allow MCS rate index 5
  m6.         Allow MCS rate index 6
  m7.         Allow MCS rate index 7
  m8-15       Allow MCS rate indices 8-15
  m8.         Allow MCS rate index 8
  m9.         Allow MCS rate index 9
  ofdm        How to place OFDM rates in rates elements
  only-ofdm   Set rates for best OFDM throughput (no ERP protection will be used)
  range       Set rates for best range
  throughput  Set rates for best throughput (includes non-OFDM rates and may cause ERP protection to be used)

Gold

Re: Configure 1141n with 802.11n

According to the output you are associating at MCS rates

"Current Rate: m15"

You will not be able to achieve the full 300Mbps data rate until you enable channel bonding but this is not recommended for the b/g networks because it would effectivly leave you with only one non-overlapping channel.

Community Member

Re: Configure 1141n with 802.11n

Just found the "802.11n Design and Deployment Guidelines". I will check if we have to support legacy devices. If yes g must be enough for now.

Thank you

Bastian

3260
Views
0
Helpful
4
Replies
CreatePlease to create content