Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Configuring 881W wireless

I'm having trouble configuring my router for wireless. I have followed guides but with no luck. Right now my issue is below with the radio. I cannot figure out why this is stuck in reset. I have reloaded the AP with no luck. Any suggestions? Config is posted below.

Interface                  IP-Address      OK? Method Status                Protocol

BVI1                       10.20.50.35     YES DHCP   up                    up 

Dot11Radio0                unassigned      YES NVRAM  reset                 down

GigabitEthernet0           unassigned      YES NVRAM  up                    up 

GigabitEthernet0.2         unassigned      YES unset  up                    up 

CONFIG

########################ROUTER#######################

Current configuration : 5422 bytes

!

! Last configuration change at 18:55:56 PCTime Wed Feb 29 2012 by msetnes

! NVRAM config last updated at 18:37:40 PCTime Wed Feb 29 2012 by msetnes

!

version 15.1

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname XXXXXX

!

boot-start-marker

boot-end-marker

!

!

!

aaa new-model

!

!

aaa authentication login ciscocp_vpn_xauth_ml_1 local

aaa authorization network ciscocp_vpn_group_ml_1 local

!

!

!

!

!

aaa session-id common

memory-size iomem 10

clock timezone PCTime -6 0

clock summer-time PCTime date Apr 6 2003 2:00 Oct 26 2003 2:00

ip source-route

!

!

!

ip dhcp excluded-address 10.20.30.1 10.20.30.99

ip dhcp excluded-address 10.20.50.1 10.20.50.31

!

ip dhcp pool LOCAL

   import all

   network 10.20.30.0 255.255.255.0

   default-router 10.20.30.1

   dns-server 8.8.8.8 8.8.4.4

!

ip dhcp pool WIFI

   import all

   network 10.20.50.0 255.255.255.0

   default-router 10.20.30.1

   dns-server 8.8.8.8 8.8.4.4

!

!

ip cef

ip name-server 8.8.8.8

ip name-server 8.8.4.4

no ipv6 cef

!

!

!

username XXXXXX privilege 15 secret 5 XXXXXXXX

!

!

!

!

ip ssh time-out 60

ip ssh authentication-retries 2

ip ssh version 1

!

bridge irb

!

!

!

!

interface FastEthernet0

no ip address

!

interface FastEthernet1

no ip address

!

interface FastEthernet2

no ip address

!

interface FastEthernet3

no ip address

!

interface FastEthernet4

description "Connection to internet"

ip address dhcp client-id FastEthernet4

ip flow ingress

ip nat outside

ip virtual-reassembly in

duplex auto

speed auto

!

interface wlan-ap0

description "Service module interface connecting to embedded AP"

ip unnumbered Vlan2

arp timeout 0

!

interface Wlan-GigabitEthernet0

description "Internal switch interface connecting to AP"

switchport trunk native vlan 2

switchport mode trunk

!

interface Vlan1

description "Local"

ip address 10.20.30.1 255.255.255.0

ip flow ingress

ip nat inside

ip virtual-reassembly in

!

interface Vlan2

description "Wireless"

ip address 10.20.50.1 255.255.255.0

ip flow ingress

ip nat inside

ip virtual-reassembly in

!

ip forward-protocol nd

ip http server

ip http access-class 23

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

!

ip nat inside source list 23 interface FastEthernet4 overload

ip route 0.0.0.0 0.0.0.0 dhcp

!

logging esm config

access-list 22 remark

access-list 23 permit 10.20.30.0 0.0.0.255

access-list 23 permit 10.20.50.0 0.0.0.255

!

!

!

!

!

!

control-plane

!

bridge 1 protocol ieee

bridge 1 route ip

!

line con 0

no modem enable

line aux 0

line 2

no activation-character

no exec

transport preferred none

transport input all

line vty 0 4

exec-timeout 5 0

transport input all

transport output all

!

end

#########################AP##########################

dot11 ssid XXXXXX

   authentication open

   guest-mode

!

!

!

username XXXXXX privilege 15 secret 5 XXXXXX

!

bridge irb

!

!

interface Dot11Radio0

no ip address

no ip route-cache

!

ssid SkyNET

!

speed  basic-1.0 2.0 5.5 11.0 6.0 9.0 12.0 18.0 24.0 36.0 48.0 54.0 m0. m1. m2. m3. m4. m5. m6. m7. m8. m9. m10. m11. m12. m13. m14. m15.

station-role root

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface GigabitEthernet0

description the embedded AP GigabitEthernet 0 is an internal interface connecting AP with the host router

no ip address

no ip route-cache

bridge-group 1

no bridge-group 1 source-learning

bridge-group 1 spanning-disabled

!

interface BVI1

ip address dhcp

no ip route-cache

!

ip default-gateway 10.20.30.1

ip http server

no ip http secure-server

ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag

bridge 1 route ip

!

!

!

line con 0

privilege level 15

login local

no activation-character

line vty 0 4

login local

!

end

Everyone's tags (3)
1 ACCEPTED SOLUTION

Accepted Solutions

Re: Configuring 881W wireless

not the AP, but that one too. The GW in your dhcp scope is showing the wrong IP

Sent from Cisco Technical Support iPad App

HTH, Steve ------------------------------------------------------------------------------------------------ Please remember to rate useful posts, and mark questions as answered
8 REPLIES

Re: Configuring 881W wireless

when you define the VLAN under the SSID you need ti create the sub interface under the radio as well.

If your only going to have the one SSID the you can remove the VLAN from under the said and encryption statement.

Steve

Sent from Cisco Technical Support iPhone App

HTH, Steve ------------------------------------------------------------------------------------------------ Please remember to rate useful posts, and mark questions as answered
Community Member

Re: Configuring 881W wireless

Thanks, this brought the radio back up. I seem to be connecting and disconnecting consistently. Is there something I'm missing in my config?

EDIT--

I removed encryption just to resolve this issue for now. My issue now is I am not able to talk outside of the wifi network. I can only ping within the 10.20.50.0 network.

Re: Configuring 881W wireless

nothing I'm noticing of the top of my head. Can you be more specific with the issue? Do you get an up address the drop or do you not get that far?

Sent from Cisco Technical Support iPhone App

HTH, Steve ------------------------------------------------------------------------------------------------ Please remember to rate useful posts, and mark questions as answered
Community Member

Re: Configuring 881W wireless

I receive an IP address (10.20.50.36) I can only ping this wireless IP within the AP and router, nowhere else.

Re: Configuring 881W wireless

check your GW address according to your scope it's 10.20.30.1 which is VLAN 1. It should be 10.20.50.1 the VLAN 2 address.

Steve

Sent from Cisco Technical Support iPad App

HTH, Steve ------------------------------------------------------------------------------------------------ Please remember to rate useful posts, and mark questions as answered
Community Member

Configuring 881W wireless

I've corrected the default gateway on the AP to no avail. I still cannot talk between wireless and wired clients, as well as not being able to reach outside the network with WiFi.

Re: Configuring 881W wireless

not the AP, but that one too. The GW in your dhcp scope is showing the wrong IP

Sent from Cisco Technical Support iPad App

HTH, Steve ------------------------------------------------------------------------------------------------ Please remember to rate useful posts, and mark questions as answered
Community Member

Configuring 881W wireless

Removing the VLAN and encryption statements under dot11 ssid resolved the connecting issue

Changing the DHCP scope default router to 10.20.501 resolved the communication issue.

Both networks can talk now and both and reach externally.

Thanks Stephen, much appreciated.

1580
Views
0
Helpful
8
Replies
CreatePlease to create content