Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Configuring access point vlan

greetings, I have a question in the configuration of an access point I have 2 vlan one for AP monitoring data and one for an application. and I have my switch port configured as a trunk.

The vlan that has the AP for monitoring is the 7

The data vlan is 6

but my native vlan is 1 LAN

If I remove the native vlan on the switch, I lose the access point management

It affects it has on the access point you have configured as native vlan 1?

FastEthernet0.1 interface

  encapsulation dot1q 1 native

  no ip route-cache

  bridge-group 1

  no bridge-group 1 source-learning

  bridge-group 1 spanning-disabled

!

FastEthernet0.6 interface

  encapsulation dot1q 6

  no ip route-cache

  bridge-group 6

  no bridge-group 6 source-learning

  bridge-group 6 spanning-disabled

!

FastEthernet0.7 interface

  encapsulation dot1q 7

  no ip route-cache

  bridge-group 7

  no bridge-group 7 source-learning

  7 bridge-group spanning-disabled

Configuration of the switch

GigabitEthernet1/0/14 interface

  switchport trunk encapsulation dot1q

  switchport trunk native vlan 7

  switchport mode trunk

  speed 100

  full duplex

6 REPLIES
Hall of Fame Super Silver

Re: Configuring access point vlan

What do you have for the ap bvi interface?

Here is a good link to look at:

http://www.cisco.com/en/US/products/hw/wireless/ps4570/products_configuration_example09186a00801d0815.shtml

-Scott
*** Please rate helpful posts ***
New Member

Configuring access point vlan

if it is configured with an IP that belongs to the vlan7

Re: Configuring access point vlan

then on the AP you would call the .7 subinterfaces as native, and set the switchport to be switchport trunk native VLAN 7 as well.

Sent from Cisco Technical Support iPad App

HTH, Steve ------------------------------------------------------------------------------------------------ Please remember to rate useful posts, and mark questions as answered

Re: Configuring access point vlan

piggy backing Scott

The 'native' VLAN on the AP is where it will get its IP address, and the AP sends untagged traffic out of this interface, while all others will be tagged.

If you could post the config of the AP we can review and recommend the proper config changes.

Steve

Sent from Cisco Technical Support iPad App

HTH, Steve ------------------------------------------------------------------------------------------------ Please remember to rate useful posts, and mark questions as answered
New Member

Configuring access point vlan

the ip that is in the BVI corresponds to vlan 7, but not if it's correct to put the ethernet native vlan is 7 and that the switch port has the native vlan

++++++++++++++++++++++++++++++

interface Dot11Radio0.7

encapsulation dot1Q 7

if I put the native is 7 management of the device is lost

++++++++++++++++++++++++++++++

dot11 vlan-name date vlan 6

!

dot11 ssid the web

   vlan 6

   authentication open

!

!

!

bridge irb

!

!

interface Dot11Radio0

no ip address

no ip route-cache

!

encryption key 1 size 128bit 7 F254535767934F3765123EF719C5 transmit-key

encryption mode wep mandatory

!

encryption vlan 6 key 1 size 128bit 7 2A254B39703F441F2F5D423D0623 transmit-key

encryption vlan 6 mode wep mandatory

!

ssid the web

!

speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0

station-role root access-point

bridge-group 1

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface Dot11Radio0.6

encapsulation dot1Q 6

no ip route-cache

bridge-group 6

bridge-group 6 subscriber-loop-control

bridge-group 6 block-unknown-source

no bridge-group 6 source-learning

no bridge-group 6 unicast-flooding

bridge-group 6 spanning-disabled

!

interface Dot11Radio0.7

encapsulation dot1Q 7

no ip route-cache

bridge-group 7

bridge-group 7 subscriber-loop-control

bridge-group 7 block-unknown-source

no bridge-group 7 source-learning

no bridge-group 7 unicast-flooding

bridge-group 7 spanning-disabled

!

interface FastEthernet0

no ip address

no ip route-cache

bridge-group 1

no bridge-group 1 source-learning

bridge-group 1 spanning-disabled

hold-queue 80 in

!

interface FastEthernet0.6

encapsulation dot1Q 6

no ip route-cache

bridge-group 6

no bridge-group 6 source-learning

bridge-group 6 spanning-disabled

!

interface FastEthernet0.7

encapsulation dot1Q 7

no ip route-cache

bridge-group 7

no bridge-group 7 source-learning

bridge-group 7 spanning-disabled

!

interface BVI1

ip address 10.10.10.2 255.255.255.224

no ip route-cache

!

ip default-gateway 10.10.10.1

ip http server

Hall of Fame Super Silver

Re: Configuring access point vlan

Both the ap and trunk needs to be either tagged or untagged (native). So if you don't want to set vlan 7 as the native on the switch, then leave it as it. If you want to set the native vlan on the trunk, then you need to set vlan 7 on the ap as native.

Thanks,

Scott Fella

Sent from my iPhone

-Scott
*** Please rate helpful posts ***
379
Views
12
Helpful
6
Replies
CreatePlease to create content