Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Connecting WLC 2504 and AP1242

Dear All

Greetings

I am new guy in Cisco Wireless and i want to connect Ap1242 and WLC 2504.ON WLC under Wireless it is not showing Connected AP.

Please share some Network diagram or Example regarding this

Inititally i Made some some CLI in AP

version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname GPC-PLANT
!
enable secret 5 $1$6GdJ$TuYeZxYvymPL03a46JWtQ0
!
no aaa new-model
!
!
!
dot11 ssid GPC-PLANT
   authentication open
   guest-mode
!
power inline negotiation prestandard source
!
!
username Cisco password 7 00271A150754
!
bridge irb
!
!
interface Dot11Radio0
no ip address
no ip route-cache
!
ssid GPC-PLANT
!
channel least-congested 2412 2437 2462
station-role root
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
bridge-group 1 spanning-disabled
!
interface Dot11Radio1
no ip address
no ip route-cache
no dfs band block
channel dfs
station-role root
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
bridge-group 1 spanning-disabled
!
interface FastEthernet0
no ip address
no ip route-cache
duplex auto
speed auto
bridge-group 1
no bridge-group 1 source-learning
bridge-group 1 spanning-disabled
!
interface BVI1
ip address 192.168.3.48 255.255.255.0
no ip route-cache
!
ip http server
no ip http secure-server
ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
bridge 1 route ip
!
!
!
line con 0
line vty 0 4
login local
!
end

and ON WLC2504

Enter Administrative User Name (24 characters max):
Invalid response

Enter Administrative User Name (24 characters max): admin
Enter Administrative Password (3 to 24 characters): ********
Re-enter Administrative Password                 : ********

Management Interface IP Address: 192.168.3.49
Management Interface Netmask: 255.255.255.0
Management Interface Default Router: 192.168.3.1
Management Interface VLAN Identifier (0 = untagged):
Management Interface Port Num [1 to 4]: 1
Management Interface DHCP Server IP Address: 192.168.3.1

Virtual Gateway IP Address:
Invalid response


Virtual Gateway IP Address: 1.1.1.1

Mobility/RF Group Name: GPC-PLANT

Network Name (SSID): GPC-PLANT

Configure DHCP Bridging Mode [yes][NO]: N
Invalid response


Configure DHCP Bridging Mode [yes][NO]: N
Invalid response


Configure DHCP Bridging Mode [yes][NO]: no

Allow Static IP Addresses [YES][no]: no

Configure a RADIUS Server now? [YES][no]: no
Warning! The default WLAN security policy requires a RADIUS server.
Please see documentation for more details.

Enter Country Code list (enter 'help' for a list of countries) [US]: KSA
Invalid Country Code - enter 'help' for list

Enter Country Code list (enter 'help' for a list of countries) [US]: help
Enter the country code list (e.g. US,CA,MX) max=20.
Supported Country Codes:
AE, AL, AR, AT, AU, BA, BE, BG, BH, BO, BR, BY, CA,
CA2, CH, CL, CM, CN, CO, CR, CY, CZ, DE, DK, DO, DZ,
EC, EE, EG, ES, FI, FR, GB, GI, GR, HK, HR, HU, ID,
IE, IL, ILO, IN, IQ, IS, IT, J2, J3, J4, JO, JP, KE,
KR, KN, KW, KZ, LB, LI, LK, LT, LU, LV, MO, MC, ME,
MK, MT, MX, MY, NL, NO, NZ, OM, PA, PE, PH, PH2, PK,
PL, PR, PT, PY, QA, RO, RS, RU, SA, SE, SG, SI, SK,
TH, TN, TR, TW, UA, US, US2, USL, USX, UY, VE, VN,
ZA

Enter Country Code list (enter 'help' for a list of countries) [US]: SA

Enable 802.11b Network [YES][no]: yes
Enable 802.11a Network [YES][no]: yes
Enable 802.11g Network [YES][no]: yes
Enable Auto-RF [YES][no]: yes

2 ACCEPTED SOLUTIONS

Accepted Solutions
Hall of Fame Super Gold

Re: Connecting WLC 2504 and AP1242

C1240 Software (C1240-K9W7-M), Version 12.4(10b)JDA3,

1.  The IOS your 1240 is running is an autonomous image.  You need to copy the controller-based image ("RCV") into the AP and boot that image.

(Cisco Controller) >show time

Time............................................. Thu Jul  4 02:37:49 2013

Timezone delta................................... 0:0

Timezone location................................

NTP Servers

NTP Polling Interval.........................     86400

Index     NTP Key Index     NTP Server      NTP Msg Auth Status

-------  ---------------------------------------------------------------

Highly recommended that you configure NTP on your WLC.  In case the WLC reboots and NTP is not configured, your APs will not join until the correct time and date is configured.

Hall of Fame Super Silver

Re: Connecting WLC 2504 and AP1242

Just to add.... You need to be able to download the recovery image from CCO. If you don't have a valid support contract that allows you to download the rcv image for the 1242, then you are out if luck, as that AP will never join the WLC 2504. Of you are able to download the rcv image, here are some links to show you have to convert your autonomous ap to a lightweight ap.

Using a TFTP Server to Return to a Previous Release

https://supportforums.cisco.com/docs/DOC-18268

http://www.cisco.com/en/US/docs/wireless/access_point/conversion/lwapp/upgrade/guide/lwapnote.html#wp160918

http://www.youtube.com/watch?v=QQ_NuxdRhQ4

https://supportforums.cisco.com/docs/DOC-14960

Sent from Cisco Technical Support iPhone App

-Scott
*** Please rate helpful posts ***
9 REPLIES
Gold

Connecting WLC 2504 and AP1242

Hi Muhammed,

It looks like you have got a an autonomous access point. These access point will not get register to WLC. You need a Light Weight access (LWAP) point to see them on WLC.

You can convert this autonomous AP to LWAP by following the process below.

Download the LWAPP image for your AP from the Cisco website and get the console access the AP and just issue the command..

archive download-sw/overwrite/force-reload tftp:////

For example the command would look like as below

AP#archive download-sw /force-reload /overwrite tftp://10.0.0.5/c1140-rcvk9w8-tar.124-23c.JA.tar

You should TFTPd32 downloaded from Google and in the TFTPd32 pointing to the image

Hope that helps.

Regards

Najaf

Please rate when applicable or helpful !!!

Hall of Fame Super Gold

Connecting WLC 2504 and AP1242

Post the output to the following commands:

1.  WLC:  sh sysinfo;

2.  WLC:  sh time;

3.  AP:  sh version;

4.  AP:  sh inventory; and

5.  AP:  sh ip interface brief

New Member

Connecting WLC 2504 and AP1242

Cisco IOS Software, C1240 Software (C1240-K9W7-M), Version 12.4(10b)JDA3, RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2009 by Cisco Systems, Inc.
Compiled Sun 07-Jun-09 04:13 by prod_rel_team

ROM: Bootstrap program is C1240 boot loader
BOOTLDR: C1240 Boot Loader (C1240-BOOT-M) Version 12.4(13d)JA, RELEASE SOFTWARE (fc2)

GPC-PLANT uptime is 3 hours, 11 minutes
System returned to ROM by power-on
System image file is "flash:/c1240-k9w7-mx.124-10b.JDA3/c1240-k9w7-mx.124-10b.JDA3"


This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to
export@cisco.com.

cisco AIR-AP1242AG-E-K9    (PowerPCElvis) processor (revision A0) with 24566K/8192K bytes of memory.
Processor board ID FCZ1705807R
PowerPCElvis CPU at 262Mhz, revision number 0x0950
Last reset from power-on
1 FastEthernet interface
2 802.11 Radio(s)

32K bytes of flash-simulated non-volatile configuration memory.
Base ethernet MAC Address: 00:06:F6:70:84:0C
Part Number                          : 73-13786-01
PCA Assembly Number                  : 800-37049-01
PCA Revision Number                  : A0
PCB Serial Number                    : FOC17023DMR
Top Assembly Part Number             : 800-29233-03
Top Assembly Serial Number           : FCZ1705807R
Top Revision Number                  : A0
Product/Model Number                 : AIR-AP1242AG-E-K9

Configuration register is 0xF

NAME: "AP1240", DESCR: "Cisco Aironet 1240 Series (IEEE 802.11a/g) Access Point"
PID: AIR-AP1242AG-E-K9 , VID: V05, SN: FCZ1705807R


Interface                  IP-Address      OK? Method Status                Prot   ocol
BVI1                       192.168.3.48    YES other  up                    up    
Dot11Radio0                unassigned      YES unset  up                    up    
Dot11Radio1                unassigned      YES unset  reset                 down  
FastEthernet0              unassigned      YES other  up                    up 

Manufacturer's Name.............................. Cisco Systems Inc.
Product Name..................................... Cisco Controller
Product Version.................................. 7.0.220.0
Bootloader Version............................... 1.0.16
Field Recovery Image Version..................... 1.0.0
Firmware Version................................. PIC 16.0


Build Type....................................... DATA + WPS

System Name...................................... Cisco_b3:ad:04
System Location..................................
System Contact...................................
System ObjectID.................................. 1.3.6.1.4.1.9.1.1279
IP Address....................................... 192.168.3.49
Last Reset....................................... Power on reset
System Up Time................................... 0 days 3 hrs 6 mins 9 secs
System Timezone Location.........................
Current Boot License Level....................... base
Current Boot License Type........................ Permanent
Next Boot License Level.......................... base

--More-- or (q)uit
Next Boot License Type........................... Permanent

Configured Country............................... SA  - Saudi Arabia
Operating Environment............................ Commercial (0 to 40 C)
Internal Temp Alarm Limits....................... 0 to 65 C
Internal Temperature............................. +28 C
External Temperature............................. +34 C
Fan Status....................................... 3900 rpm

State of 802.11b Network......................... Enabled
State of 802.11a Network......................... Enabled
Number of WLANs.................................. 1
Number of Active Clients......................... 0

Burned-in MAC Address............................ 84:78:AC:B3:AD:00
Maximum number of APs supported.................. 5


(Cisco Controller) >show time

Time............................................. Thu Jul  4 02:37:49 2013

Timezone delta................................... 0:0
Timezone location................................

NTP Servers
    NTP Polling Interval.........................     86400

     Index     NTP Key Index     NTP Server      NTP Msg Auth Status
    -------  ---------------------------------------------------------------

Hall of Fame Super Gold

Re: Connecting WLC 2504 and AP1242

C1240 Software (C1240-K9W7-M), Version 12.4(10b)JDA3,

1.  The IOS your 1240 is running is an autonomous image.  You need to copy the controller-based image ("RCV") into the AP and boot that image.

(Cisco Controller) >show time

Time............................................. Thu Jul  4 02:37:49 2013

Timezone delta................................... 0:0

Timezone location................................

NTP Servers

NTP Polling Interval.........................     86400

Index     NTP Key Index     NTP Server      NTP Msg Auth Status

-------  ---------------------------------------------------------------

Highly recommended that you configure NTP on your WLC.  In case the WLC reboots and NTP is not configured, your APs will not join until the correct time and date is configured.

Hall of Fame Super Silver

Re: Connecting WLC 2504 and AP1242

Just to add.... You need to be able to download the recovery image from CCO. If you don't have a valid support contract that allows you to download the rcv image for the 1242, then you are out if luck, as that AP will never join the WLC 2504. Of you are able to download the rcv image, here are some links to show you have to convert your autonomous ap to a lightweight ap.

Using a TFTP Server to Return to a Previous Release

https://supportforums.cisco.com/docs/DOC-18268

http://www.cisco.com/en/US/docs/wireless/access_point/conversion/lwapp/upgrade/guide/lwapnote.html#wp160918

http://www.youtube.com/watch?v=QQ_NuxdRhQ4

https://supportforums.cisco.com/docs/DOC-14960

Sent from Cisco Technical Support iPhone App

-Scott
*** Please rate helpful posts ***
New Member

Re: Connecting WLC 2504 and AP1242

Thanks all.

It is working fine,Really awesome Repy from your side

.

but I need to install One AP to Switch with Switch having VLAN30 .

and One should Connected to a Normal switch ,

CORE Swtich---Distribution Switch--gig1/0/2--> Switch with VLAN 30

Core Switch-----Distrubition Switch(gig1/0/1 with IP 192.168.30.1) ----Access Switch----WLC and AP

Should I connect all AP to WLC or Connect to AP to some where else ?

Hall of Fame Super Gold

Connecting WLC 2504 and AP1242

Connect all your APs to your switch.  Your switch connects to your WLC.

New Member

Re: Connecting WLC 2504 and AP1242

Dear Leo Laohoo and Scott Fella

I am not getting Ip address from the AP or WLC or Switch although Switch has DHCP pool and if I connects machine to Port of Switch,I am getting IP.

Please guide me what i need to change from AP/WLC

AP 192.168.3.49 /24 GW: 192.168.3.1

WLC 192.168.3.48/24 GW 192.168.3.1

ip dhcp excluded-address 192.168.3.1 192.168.3.50

ip dhcp excluded-address 192.168.3.201 192.168.3.254

!

ip dhcp pool STORE1-192.168.3.0

   network 192.168.3.0 255.255.255.0

   default-router 192.168.3.1

   dns-server 192.168.1.1 192.168.1.5

Hall of Fame Super Gold

Connecting WLC 2504 and AP1242

That's not right.

Your DHCP pool "STORE1", subnet 192.168.30/24, only gives an IP Address to your APs.

If you want to a DHCP pool for your wireless clients, then you need to create a new pool.

Switch:

ip dhcp  exclude 192.168.4.1 192.168.4.50

ip dhcp pool client

network 192.168.4.0 /24

default-route 192.168.4.1

dns-server BLAH

vlan 100

name Client

interface vlan 100

no shutdown

ip address 192.168.4.1 255.255.255.0

Ok, now you need to create a new dynamic interface (VLAN 100) with the following subnet.  Tie your client SSID to that Dynamic Interface.  And don't forget to allow the client VLAN (VLAN 100) in your allowed-vlan from the switch. 

2869
Views
0
Helpful
9
Replies
CreatePlease to create content