Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Converting to Autonomous AP, starts then fails at ould not discover WLC

Hi all,

im just trying to convert an AP to autonmous mode, following the guide here https://supportforums.cisco.com/document/71501/installing-autonomous-ios-aios-lightweight-ap-cli 

 

i have issued the "debug capwap client no-reload" command but the ap is still failing about half way through and does this

%CAPWAP-3-DHCP_RENEW: Could not discover WLC using DHCP IP. Renewing DHCP IP.OOO
*Mar  1 00:06:34.255: %CAPWAP-3-ERRORLOG: Invalid event 38 & state 2 combination.

anyone know how to stop it?

i have also tried the holding mode button method, this fails and i have also tried the rommon set IP_ADDR... method, this also fails

Thanks for any advice

 

8 REPLIES
Hall of Fame Super Gold

Using a TFTP Server to Return

Community Member

as stated above, this method

as stated above, this method fails :(

it looks like it cant reach 10.0.0.2 but when i try the debug mode (which i cant stop the dhcp release even though ive done what the guide says) it can tftp half of the file before being cut off, so it should work! the tftp server is on 10.0.0.2

 

Base Ethernet MAC address: 10:f3:11:e3:d9:e2
Ethernet speed is 100 Mb - FULL Duplex
button is pressed, wait for button to be released...
button pressed for 23 seconds
process_config_recovery: set IP address and config to default 10.0.0.1
process_config_recovery: image recovery
image_recovery: Download default IOS tar image tftp://255.255.255.255/ap3g2-k9w7-tar.default

examining image...
DPAA Set for Independent Mode
DPAA_INIT = 0x0

%Error opening tftp://255.255.255.255/ap3g2-k9w7-tar.default (connection timed out)ap:

Hall of Fame Super Gold

%Error opening tftp://255.255

%Error opening tftp://255.255.255.255/ap3g2-k9w7-tar.default (connection timed out)

Forgive me for asking, but this looks like you've got a firewall issue.

Community Member

its plugged directly into my

its plugged directly into my machine with windows firewall turned off.

as above, whats odd is, that if i use the debug mode method i can download half the os from tftp (before the controller resets even though ive give it an dhcp address), which shows me its not a firewall issue, as the addresses are the same too...

 

Thanks

Hall of Fame Super Gold

Try another client.  Do you

Try another client.  


Do you have a TFTP server enabled?

Community Member

i finally did it using the

i finally did it using the method in the link i first posted. when it keeps trying to renew dhcp, it looks like its break the transfer, it isnt, just leave it going and it will keep getting cut off, but it will eventually finish and work, finally!!!

 

 

Community Member

If you don't have a dhcp

If you don't have a dhcp server to get an IP,  following the next console message
<%CAPWAP-3-DHCP_RENEW: Could not discover WLC using DHCP IP. Renewing DHCP IP>

#configure a static IP#
config t
int bvi1
ip address 10.0.0.1 255.0.0.0
end

#ftp/tftp the image# 
#this takes less time than the archive download-sw /overwrite#

copy tftp flash:
   address or name of remote host []? 10.0.0.2
   Source filename []? c1140-k9w7-tar.124-25d.JA2.tar
   Destination filename [c1140-k9w7-tar.124-25d.JA2.tar]? 
   Accessing ftp://10.0.0.2/c1140-k9w7-tar.124-25d.JA2.tar...
   Loading c1140-k9w7-tar.124-25d.JA2.tar !!!!!!!!!!!!!!!!!!!!!!!
   [OK - 5765120/4096 bytes]

   5765120 bytes copied in 77.437 secs (74449 bytes/sec)

#now run the archive from flash#
archive download-sw /overwrite /reload flash:c1140-k9w7-tar.124-25d.JA2.tar

#Note: you may need to reload manually#
#Requested system reload skipped due to unsaved config changes#

#remember to delete the image tar.file from flash#
ap#del flash:c1140-k9w7-tar.124-25d.JA2.tar

 

 

Please have a look in to the

Please have a look in to the Cisco Wireless LAN Controller Configuration Guide, Release 8.0

http://www.cisco.com/c/en/us/td/docs/wireless/controller/8-0/configuration-guide/b_cg80/b_cg80_chapter_01101010.html#wp160918

507
Views
0
Helpful
8
Replies
CreatePlease to create content