Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

DHCP problem on AP with H-REAP enabled

Scenario: I have several APs connected in remote offices, switch ports, connecting to APs, are setup as trunk, and only allowed two wireless VLANs, and AP MGT IPs Vlan.  H-REAP is setup, Vlan Support and VLAN Mappings are all setup.  I can see MAC of users using different SSID are put into different VLAN correctly. 

The Problem is: when user connected on a SSID, although the user wifi card's MAC was put into correct VLAN, DHCP requests were set duplexly to all three allowed VLANs through the switch trunk port conneting to the AP.  As a reslult, user randomly got an IP from one of three different DHCP scopes that setup for thress different purposes, two wireless SSIDs and AP MGT IPs.  The DHCP server got thress requests from three different VLANs, first come first serve...

Any way I can stop the duplexed DHCP requests sending through all allowed VLANs from APs?  Experts?  Cisco Supermen..?

P.S. my APs are LAP1142N.

Thanks a lot.

Everyone's tags (4)
5 REPLIES
Hall of Fame Super Silver

Re: DHCP problem on AP with H-REAP enabled

Well you have a good one here. So let me ask... Does this happen everywhere or can you segment it to a particular AP or even switch?

Can you capture some of the packets from the access point also and maybe just post your interface config just for kicks)

Sent from Cisco Technical Support iPhone App

-Scott
*** Please rate helpful posts ***
New Member

DHCP problem on AP with H-REAP enabled

it happend on all our recently deployed 1142s, on different switchs.  Don't think it switch realted, because on the same switch, PC users from different VLANs can get IP address no drama.

switch port config is simple

description AP

switchport trunk allowed vlan 1,3,4

switchport mode trunk description AP
switchport trunk allowed vlan 1,3,4
switchport mode trunk

vlan 1 is AP MGT, vlan 3 and 4 are for two different SSIDs.

P.S. 'VLAN Transparent' under Mesh settings on the Controller is NOT enabled.

Thanks a lot.

Cisco Employee

DHCP problem on AP with H-REAP enabled

VLAN transparent config for Mesh doesn't affect HREAP.

On wireless client run wireshark selecting the wireless adapter on non-promiscuous mode and check the captures.

please share svi of AP connected switch

Hall of Fame Super Silver

Re: DHCP problem on AP with H-REAP enabled

Can you post your show run-config on the wlc.

Sent from Cisco Technical Support iPhone App

-Scott
*** Please rate helpful posts ***
New Member

Re: DHCP problem on AP with H-REAP enabled

Experts below is the radio and interface config on one of our APs.  Can you spot anything?

interface Dot11Radio0

no ip route-cache

!

interface Dot11Radio0.1

encapsulation dot1Q 1

no ip route-cache

bridge-group 5

bridge-group 5 subscriber-loop-control

bridge-group 5 block-unknown-source

no bridge-group 5 source-learning

no bridge-group 5 unicast-flooding

bridge-group 5 spanning-disabled

!

interface Dot11Radio0.2

encapsulation dot1Q 2

no ip route-cache

bridge-group 4

bridge-group 4 subscriber-loop-control

bridge-group 4 block-unknown-source

no bridge-group 4 source-learning

no bridge-group 4 unicast-flooding

bridge-group 4 spanning-disabled

!

interface Dot11Radio0.17

encapsulation dot1Q 17 native

no ip route-cache

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface Dot11Radio1

no ip route-cache

!

interface Dot11Radio1.1

encapsulation dot1Q 1

no ip route-cache

bridge-group 5

bridge-group 5 subscriber-loop-control

bridge-group 5 block-unknown-source

no bridge-group 5 source-learning

no bridge-group 5 unicast-flooding

bridge-group 5 spanning-disabled

!

interface Dot11Radio1.2

encapsulation dot1Q 2

no ip route-cache

bridge-group 4

bridge-group 4 subscriber-loop-control

bridge-group 4 block-unknown-source

no bridge-group 4 source-learning

no bridge-group 4 unicast-flooding

bridge-group 4 spanning-disabled

!

interface Dot11Radio1.17

encapsulation dot1Q 17 native

no ip route-cache

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface GigabitEthernet0

no ip address

no ip route-cache

duplex auto

speed auto

no keepalive

!

interface GigabitEthernet0.1

encapsulation dot1Q 1 native

ip address dhcp client-id GigabitEthernet0

no ip route-cache

bridge-group 1

no bridge-group 1 source-learning

bridge-group 1 spanning-disabled

!

interface GigabitEthernet0.4

encapsulation dot1Q 4

no ip route-cache

bridge-group 4

no bridge-group 4 source-learning

bridge-group 4 spanning-disabled

!

interface GigabitEthernet0.5

encapsulation dot1Q 5

no ip route-cache

bridge-group 5

no bridge-group 5 source-learning

bridge-group 5 spanning-disabled

!

671
Views
0
Helpful
5
Replies
CreatePlease login to create content