Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Google ChromeCast with WLAN Controller 2504

I assume that I am not the first person to run in to this and know I won't be the last person but I can't seem to get a Google ChromeCast to work on a WLAN that I set up. The WLAN Consists of an AIR-CT2504-K9 Controller and two AIR-LAP1024N-A-K9 Access Points.

I have 2 different SSIDs one private and one public, they are going through their own VLAN and don't have any issues with any other clients accessing the Internet or other resources on the networks. I verified that P2P is "Disabled" in the Public SSID which is the one we are trying to use.

When I go through the Setup Process the ChromeCast was able to join the Public Network the very first time but was not able to be seen by a client. Since then I did a factory reset the ChromeCast and tried many times to join both the Public and Private Networks with no luck.

I don't have any special security set up on the Public Network other than a Pre-Shared Key which I am positive I am imputting in properly. The ChromeCast just hangs when trying to join the network.

With this in mind I took the ChromeCast to another location with a simple, single access point WLAN Setup and was able to get it to join the network and be seen on the network without any issues.

Just as an FYI - The way that this process works is as follows: When you power up the ChromeCast it sets itself up as a Wireless Device with its own unique SSID. When you set it up your device (laptop in this case) connects to that network so you can configure it. This is where you will set up the new Wireless Network it will join with the credentials you provided. Once your submitted it your device will connect back to the network it was on originally and try to connect to the ChromeCast. As I said the ChoromeCast for whatever reason is not fully connecting to / joining the network and isn't found by the setup app and fails.

Any thoughts / suggestions would be greatly appreciated.

1 ACCEPTED SOLUTION

Accepted Solutions
New Member

Google ChromeCast with WLAN Controller 2504

I fixed this in at least one non-controller setup with: "no ip igmp snooping" and "no bridge-group 1 port-protected"  on the AP.

The problem is actually with multicast and wirelessdevice-to-wirelessdevice communication. They just chose the worst possible error message to communicate that.

31 REPLIES
New Member

Google ChromeCast with WLAN Controller 2504

apparently chromecast requires upnp to be enabled at the router. If you  keep your eye open during the installation, you will see an error when  joining the network, that leads to a web page that makes this clear. I  am attempting to open a ticket w/google to find a resolution, but so  far, no look

New Member

Google ChromeCast with WLAN Controller 2504

Thanks for the information - I didn't notice anything about UPNP needed to be available for the install to complete. How about if I would set up the ChromeCast using a simple Wireless Network using the same credentials as the network it will ultimately be on? I would assume it would authenticate one it powers up. Does it still need UPNP to be avilable once it joins the network? I will give it a shot as a workaround and let you know.

Good luck with Google Support - So far they have been very slow to respond and believe me the responses I've gotten has been anything but helpful.

New Member

Google ChromeCast with WLAN Controller 2504

Just as an FYI / Continuation of this issue / troubleshooting, I set up the ChromeCast with a simple Access Point using the same credentials as the network it will be joining at the original location. The ChromeCast is able to connect to the network but nothing can see it / talk to it even though I have P2P communication set up (I can ping between two laptops on the same WLAN / SSID). I am at a loss now.

I've e-mailed Google a few times and haven't received anything back from them. I guess they assume everyone has a simple network set up / configuration. Of course my customer is getting very unhappy =(

New Member

Google ChromeCast with WLAN Controller 2504

I too am having the same issue. I've managed to get it to connect to my wireless SSID using my phone to initially fake the SSID then switching my cisco back on and it successfully connects to my wireless & I can ping the Chromecast but it doesn't seem to be functional.

I'm guessing it needs to utilise upnp to do some network trickery that isn't working with Cisco. I've tried speaking to Google & lodged a ticket but haven't had any response from them regarding the problem.

Cheers

New Member

Google ChromeCast with WLAN Controller 2504

I fixed this in at least one non-controller setup with: "no ip igmp snooping" and "no bridge-group 1 port-protected"  on the AP.

The problem is actually with multicast and wirelessdevice-to-wirelessdevice communication. They just chose the worst possible error message to communicate that.

New Member

Google ChromeCast with WLAN Controller 2504

You sir are a champion.

I've now got it working with my 887VA-W I did have the no ip igmp snooping but not the port-protected bit.

New Member

Google ChromeCast with WLAN Controller 2504

llathrop, "no ip igmp snooping" on an autonomous 1142 worked for me. Thanks!

New Member

Thank you so much; that

Thank you so much; that solved my problem with the Cisco Aironet 1130.

It explains why my Nexus 5 was not able to reach the Chromecast; the communication between those devices.

Daniel.

 

New Member

This was amazing. Perfect

This was amazing. Perfect white paper that answered all my questions and helped me create a new WLAN/SSID in minutes to get my multiple chromecasts up and running!

 

 

Cisco WLC2504 & 2x AIR-CAP2602E-A-K9

New Member

This has worked really well

This has worked really well for me, however I have issues with the Chromecasts staying connected for an extended period of time. I try to cast tabs to show information in my office, but after 30-60mins they always drop. This never happens when I'm showing a movie or youtube videos on Chromecasts on my network at home. It has something to do with the setup of the LWAPs and Controller.

 

Using: AIR-CT2504-K9 + AIR-CAP2602E-A-K9 (x4)

 

New Member

Same here, just now, fixed an

Same here, just now, fixed an issue with ChromeCast. Had to turn off IGMP snooping. Worked right away after that. 

New Member

Google ChromeCast with WLAN Controller 2504

https://docs.google.com/file/d/0B3wAyr2LZ1NXcTZrQWpXdjBnZ2c/edit?usp=sharing

CCNP - Wireless
CWNA and CWAP

CCNP - Wireless CWNA and CWAP
New Member

Google ChromeCast with WLAN Controller 2504

I got this working on my 2106 controller after talking to buddy at Google

http://www.cisco.com/en/US/tech/tk722/tk809/technologies_configuration_example09186a00807cc3b8.shtml

Change the AP mode from local to H-REAP/Flexconnect and then enable local switching in the advanced options of the WLAN. Something in the local mode tunneling prevents client to client communication. Dumping the traffic on the wire seems to get around this

New Member

Google ChromeCast with WLAN Controller 2504

In addition to "no ip igmp snooping" on a 1250 (Which I already set for enabling Bonjur for printing to the network printer from a Mac), I also had to set "no bridge-group 1 port-protected" on  "interface Dot11Radio0.1"

I can now see the chromecast and stream, but it regularly "disappears" in the apps. I am new to configuring Cisco routers and need some advice. Is there a good way to debug this issue? I'm thinking the multicast is not quite working as intended because even when the chromecast disappears and reappears, my continuous ping stream to the chromecast from a laptop never skips a beat.

Thanks,

Brandon

New Member

Thanks Jason!Changing my AP

Thanks Jason!

Changing my AP to FlexConnect then allowing local switching on this SSID did the trick!   Now our IT group can stream whatever they want to the new TV in our meeting room. 

 

Muchos Gracias!

Guys Take a look at this

Guys

 

Take a look at this whitepaper we created:

http://www.cisco.com/c/en/us/td/docs/wireless/controller/technotes/7-6/chromecastDG76/ChromecastDG76.html

It more or less a matter of setting the multicast properly on your WLC.

 

You will see more refine support for Chromecast comming in the future (I'm a big fan of it... helps getting the feature in the roadmap :-) ).

 

Jean-Francois Vincent

Product Line Manager

Wireless Business Unit

New Member

I've been banging my head for

I've been banging my head for months trying to get Chromecast working with an 881W.  The whitepaper is very nice with a lot of technical detail, but some of it doesn't translate to the 881 product line.  Does anyone have any suggestions for the 881W?  I've tried everything in this thread.

New Member

Hi,

Hi,

I followed this guide but still it doesnt work for me.

I have 1 2504 controller with 2 1702I ap's.

The strange thing is that i can cast from my PC when its connected wired but it doesnt work when my pc is on the wireless network.

New Member

Jesse, follow step by step

Jesse, follow step by step from this guide:

http://www.cisco.com/c/en/us/support/docs/wireless-mobility/wireless-mobility/119017-config-chromecast-mdns-wlc-00.html

To me, worked fine.

New Member

Hi, thanks a lot for your

Hi, thanks a lot for your reply and sorry for the delay on my side.

I tried this guide but it didnt work for me. Now i've noticed that there is no multicast traffic in the capwap while mirroring with RSPAN (from the chromecast mac).

To be continued...

Kind regards,

Jesse

New Member

i had the same problem too ,,

i had the same problem too ,, 

and solved for me by enabling the multicast globally on my wireless controller 

go to controller tab -> multicast menu -> check the enable global multicast mode 

 

thanks 

louis 

 

New Member

This worked for me too -

This worked for me too - using Cisco 2504 WLC with 2602/2702 APs

 

Thanks

Pratik

New Member

I had a problem with WLC and

I had a problem with WLC and AP on the different subnet.

The ChromeCast do not work and only run when WLC and AP are in same subnet.

Hope help someone.

New Member

To bump this topic back to

To bump this topic back to the foreground.

I've got a 2504 running 8.1 w/two 2702E APs having the same issue where the clients can't find the chromecast unit on the network.

I actually had the chromecast units already set up with another brand of simpler AP and they worked fine. When I switched out for the 2504/2702 gear is when things stopped working.

I followed these 2 sources:

http://www.cisco.com/c/en/us/td/docs/wireless/controller/technotes/7-6/chromecastDG76/ChromecastDG76.html (which is old being for 7.6)

and this

http://www.cisco.com/c/en/us/support/docs/wireless-mobility/wireless-mobility/119017-config-chromecast-mdns-wlc-00.html

Which is for 8.0 (which I've installed also and have seen differences)

neither of these suggested links work.

Since I'm not running my APs in auto mode -- the suggections below also seem to be of limited use.

I've also tried setting the WLAN > Advanced > P2P blocking action to "Forward-Upstream" to no avail.

When I check the Monitor > Multicast, I see the 239.255.255.250 group from the Chromecast (and my switched set to snoop also show the switchport the WLC is on in that group too)

But nothing happens when I fire up the chromecast client itself. It can't find any ChromeCasts.

As a sidenote, my desktop (windows 7 64b) which is wired into the network can find the chromecast just fine. It's only the wireless clients with issues.

Also, all clients are on same untagged VLAN/subnet using same SSID through same AP (while testing) hooked into the 2504 (except for Win7 workstation which is out off another switch)


Cheers,

 -Ben

UPDATE: I powered up my laptop and associated into the system. Chrome browser with ChromeCast extension also fails to find Chromecast unit on same AP. NOW when I look at the 2504's Monitor > Multicast and the group that is the chromecast, I do see both the chromecast and the laptop in the same mcast group. wireshark on the laptop shows the bcast "M-Search" going out and the IGMP join to 239.255.255.250 -- but nothing coming back from the chromecast (scratching head) Just thought I'd mention it.

UPDATE 2: I tried the FlexConnect suggestion below. For testing -- I first set the WLAN profile to Flex Connect Local Switching (and Learn IP Addresses) ONLY -- and suddenly my laptop could now see the Chromecast via Chrome Browser plugin. The Android clients (phone, tablets) could not. From there I went and set the modes on the AP to "FlexConnect" -- and that now allowed the Android clients to work as expected.

So for fun, I tried shutting off FlexConnect Local Switching back in the WLAN profile and that STILL seems to work.

The final result seems to be fixed by just setting the AP from "local" to "FlexConnect".


UPDATE 3: After letting the system sit for a bit - the Chromecast operation dropped out. So disabling "FlexConnect Local Switching" in the WLAN profile was a mistake. It's needed.

UPDATE 4 (a few days later. lol): Wanting to understand this -- I realized the management port (my egress port for the APs when not in Flex mode) wasn't set to use the mDNS profile I had set for the WLANs. (*duh*) -- setting this back and then everything to non-FlexConnect mode DOES indeed now work as it should. So -- for those who tried the mDNS method with Multicast turned on, MAKE SURE both the WLAN and the INTERFACE are both set to use the same mDNS profile that has the added chromecast addition (per the appNote).


Hi Benjamin,

Hi Benjamin,

I will give a try to your suggestion. thanks

New Member

Ben,

Ben,

One of my customers has a 2504 WLC with 5 1602i APs, and we initially have the same problem getting the Chromecast to connect to the WLAN.  Your detailed explanation was extremely helpful in resolving our initial connectivity issues.

Unfortunately, we continue to have a problem with casting sessions being interrupted approximately once every 30 minutes or so.  

We have one Chromecast wired to the corporate LAN and another connected on the Guest WLAN, and users report the same behavior on both.  I've tried toggling Global Multicast Mode and IGMP Snooping on the controller as well as IGMP snooping on our Cisco switches (2960s, I believe).  

Have you (or anyone else here) encountered this behavior, or have any suggestions based on the troubleshooting you've done so far?  

New Member

So far, I've had no

So far, I've had no disconnect issues with the ChromeCast.

It's been running fine.

I will say that "30 minutes" is suspicious though like an ARP entry or some other timer.

I know with some firewalls, a session expiration timer is set to a factory default of 30minutes....

Check your WLC.... I don't think there's anything in there -- but are there any firewalls/routers in the way of the chromecast and clients?

 -Ben

New Member

I made some changes and asked

I made some changes and asked a few of my coworkers to comment on some timeout values I found configured on their ASA 5510.  In the off chance that you or anyone else on this forum can comment, I'll include the lines I was curious about here as well:

timeout xlate 3:00:00
timeout pat-xlate 0:00:30
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00

Even though this could not

Even though this could not apply to your case. Have you checked the session and idle timeout configured on your WLC?

Try to collect a debug on the WLC for the Chromecast when the failure happens so we can take a look on it. Are you using MAB to connect the Chromecast to the wireless or something else?

30327
Views
50
Helpful
31
Replies
CreatePlease to create content