Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Attention: The Community will be in read-only mode on 12/14/2017 from 12:00 am pacific to 11:30 am.

During this time you will only be able to see content. Other interactions such as posting, replying to questions, or marking content as helpful will be disabled for few hours.

We apologize for the inconvenience while we perform important updates to the Community.

New Member

Help with WLAN on 871W

Hi! I am having troubles with configuring wlan on my 871w. I like to use vlan and a routing table, and no BVI1 or irb. I want to use ACLs later on, and by using irb I could stay with my former linksys wrt54...

This is my config so far: (with 12.4(9)T)

version 12.4

!

hostname Bxxxxxo

!

logging buffered 52000 debugging

logging console critical

enable secret 5 $xxxxx0

!

no ip source-route

ip cef

!

no ip dhcp use vrf connected

ip dhcp binding cleanup interval 10

ip dhcp excluded-address 192.168.0.1 192.168.0.19

ip dhcp excluded-address 192.168.0.51 192.168.0.254

ip dhcp excluded-address 192.168.1.1 192.168.1.9

ip dhcp excluded-address 192.168.1.20 192.168.1.254

ip dhcp excluded-address 192.168.2.1 192.168.2.19

ip dhcp excluded-address 192.168.2.51 192.168.2.254

!

ip dhcp pool dhcp-vlan-private

import all

network 192.168.0.0 255.255.255.0

default-router 192.168.0.1

!

ip dhcp pool dhcp-vlan-guest

import all

network 192.168.1.0 255.255.255.0

default-router 192.168.1.1

!

ip dhcp pool dhcp-gxxxxxn

import all

host 192.168.0.10 255.255.255.0

client-identifier 01xx.xxxx.xxxx.1a

client-name gxxxxxn

!

ip dhcp pool dhcp-wlan

import all

network 192.168.2.0 255.255.255.0

default-router 192.168.2.1

!

ip tcp synwait-time 10

no ip bootp server

ip dhcp-client update dns server both

!

username Axxxxxn privilege 15 secret 5 $xxxxx1

!

interface Null0

no ip unreachables

!

interface FastEthernet0

switchport access vlan 10

!

interface FastEthernet1

switchport access vlan 10

!

interface FastEthernet2

switchport access vlan 10

!

interface FastEthernet3

switchport access vlan 20

!

interface FastEthernet4

mac-address 00xx.xxxx.xxda //I get all IP-information by ISP-DHCP, I just have to spoof my MAC-address.

ip address dhcp hostname Bxxxxxe

ip nat outside

ip virtual-reassembly

ip route-cache flow

duplex auto

speed auto

!

interface Dot11Radio0

no ip address

!

encryption vlan 30 key 1 size 128bit 7 0xxxxxF transmit-key

encryption vlan 30 mode wep mandatory //WEP, because my Palm TungstenC doesn't have WPA.

!

ssid bxxxxxn

vlan 30

max-associations 5

guest-mode

!

speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0

station-role root

!

interface Dot11Radio0.30

encapsulation dot1Q 30 native

no ip route-cache

!

interface Vlan1

no ip address

!

interface Vlan10

ip address 192.168.0.1 255.255.255.0

ip helper-address 192.168.0.1

ip nat inside

ip virtual-reassembly

!

interface Vlan20

ip address 192.168.1.1 255.255.255.0

ip helper-address 192.168.0.1

ip nat inside

ip virtual-reassembly

!

interface Vlan30

ip address 192.168.2.1 255.255.255.0

ip helper-address 192.168.0.1

ip nat inside

ip virtual-reassembly

!

ip route 192.168.0.0 255.255.255.0 Vlan10 permanent

ip route 192.168.1.0 255.255.255.0 Vlan20 permanent

ip route 192.168.2.0 255.255.255.0 Vlan30 permanent

ip route 0.0.0.0 0.0.0.0 dhcp

!

ip nat inside source list 1 interface FastEthernet4 overload

!

access-list 1 remark nat-pool

access-list 1 permit 192.168.0.0 0.0.0.255

access-list 1 permit 192.168.1.0 0.0.0.255

access-list 1 permit 192.168.2.0 0.0.0.255

!

end

At the moment I see my wlan on my palm (using http://www.bitsnbolts.com/), but it doesn't connect...

Thanx in advance!

1 REPLY
New Member

Re: Help with WLAN on 871W

145
Views
0
Helpful
1
Replies
CreatePlease to create content