Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

How to configure Aironet 1240 as a WGB

Hello everyone,

I have an AP Aironet 1240 running autonomous IOS.

I want to use it as a workgroup bridge, to connect an industrial computer with Ethernet but no wireless network card to our LAN, but I can't make it work.

The wireless LAN ssid is brats and it has no password.

I tried to configure it using CLI.

This is the configuration:

Current configuration : 1418 bytes

!

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname WGB

!

enable secret 5 $1$l8L0$vvBHEgXF/9Uj0e5xoht8/1

!

no aaa new-model

!

!

!

dot11 ssid brats

   vlan 1

   authentication open

!

power inline negotiation prestandard source

!

!

username Cisco password 7 0802455D0A16

!

bridge irb

!

!

interface Dot11Radio0

no ip address

no ip route-cache

shutdown

!

ssid brats

!

station-role root

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface Dot11Radio1

no ip address

no ip route-cache

!

ssid brats

!

station-role workgroup-bridge

mobile station period 20 threshold 70

infrastructure-client

!

interface Dot11Radio1.1

encapsulation dot1Q 1 native

no ip route-cache

bridge-group 1

!

interface FastEthernet0

no ip address

no ip route-cache

duplex auto

speed auto

!

interface FastEthernet0.1

encapsulation dot1Q 1 native

no ip route-cache

bridge-group 1

!

interface BVI1

ip address dhcp client-id FastEthernet0

no ip route-cache

!

ip http server

no ip http secure-server

ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag

bridge 1 route ip

!

!

!

line con 0

line vty 0 4

login local

!

workgroup-bridge client-vlan 1

end

What did I do wrong?

I am available to answer any questions, and I will realli apreciate any help.

Thank you.

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Silver

How to configure Aironet 1240 as a WGB

What is this 1240 connecting to?  I know if its connecting to another Cisco ap, either autonomous or lightweight, you need to have passive mode enabled on the wireless in order for the bridge to connect.

http://www.cisco.com/en/US/tech/tk722/tk809/technologies_q_and_a_item09186a008015502c.shtml#new2

http://www.cisco.com/en/US/products/ps6366/products_configuration_example09186a0080905cea.shtml

http://www.cisco.com/en/US/products/hw/wireless/ps430/products_configuration_example09186a00805b9b87.shtml

-Scott
*** Please rate helpful posts ***
6 REPLIES
Community Member

How to configure Aironet 1240 as a WGB

this is the error message:

*Mar  1 04:15:00.365: %DOT11-4-CANT_ASSOC: Interface Dot11Radio1, cannot associate: No Response

Hall of Fame Super Silver

How to configure Aironet 1240 as a WGB

What is this 1240 connecting to?  I know if its connecting to another Cisco ap, either autonomous or lightweight, you need to have passive mode enabled on the wireless in order for the bridge to connect.

http://www.cisco.com/en/US/tech/tk722/tk809/technologies_q_and_a_item09186a008015502c.shtml#new2

http://www.cisco.com/en/US/products/ps6366/products_configuration_example09186a0080905cea.shtml

http://www.cisco.com/en/US/products/hw/wireless/ps430/products_configuration_example09186a00805b9b87.shtml

-Scott
*** Please rate helpful posts ***
Community Member

How to configure Aironet 1240 as a WGB

thank you for the answer scott,

the thing is that i think it connects to an lightweight ap, but i don't have access to configure the WLC.

but can't i configure it to work just like a regular client? like a wireless adapter for the computer? i know that it knows to do much more than that but for the moment this are my needs.

i think i already read most of those links. i'm gonna take my time to dig further..

thank you.

Hall of Fame Super Silver

Re: How to configure Aironet 1240 as a WGB

Well you need to have passive client enabled in order to get that WGB working.

Thanks,

Scott Fella

Sent from my iPhone

-Scott
*** Please rate helpful posts ***
Community Member

Re: How to configure Aironet 1240 as a WGB

i got it now.

the "Workgroup Bridges in a Cisco Unified Wireless Network Configuration Example" link is gold!

still i have to gain acces to the WLC first.

thank you again!

Hall of Fame Super Silver

Re: How to configure Aironet 1240 as a WGB

No problem.., hope you get it working.

Thanks,

Scott Fella

Sent from my iPhone

-Scott
*** Please rate helpful posts ***
937
Views
0
Helpful
6
Replies
CreatePlease to create content