Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

How to configure AP of 887VA-W-E-K9?

OK. I have this C887VA-W-E-K9... It's up and running as a router on VDSL no problems. That was a doddle.. But how the heck do you configure the AP side of it? I've configured an 850W before. That was easy. I've configured all sorts of cisco devices. But for the life of me I can't figure out the integrated AP802 module in this router.

And i can't find any docs that seem to relate to this AP... I have docs for Aironet 1100's... 1200's... And others. And they're all configured just slightly differently...  The biggest problems i have at the moment is trying to configure WPA... But the docs I can find just don't match what the AP is obviously expecting... Some AP's seem to have the SSID and SSID parameters configured under the interface itself... Some have it defined separately... The closest I got is a doc called 'Cisco Wireless ISR and HWIC Access Point Configuration Guide' but when following this I get as far as

dot11 ssid hurricane
   authentication open
   authentication key-management wpa
   wpa-psk ascii 0 allyouneedislove

And it works as far as 'authentication open' and then won't take 'authentication key-management wpa' because it says there's no cipher... But I have

encryption mode ciphers tkip

specified already... e.g.

ap-887vaw(config-ssid)#authentication key-management wpa

Dot11Radio0 Error: Encryption mode cipher is not configured

ap-887vaw(config-ssid)#

I'm obviously missing something... is there a doc that actually targets the AP802 in the 887VAW? Rather than one of the other AP's that cisco make?

sh inv & sh ver below

ap-887vaw#sh inventory

NAME: "AP802", DESCR: "Cisco AP802 Access Point with single IEEE 802.11g/n radio port"

PID: AP802GN-E-K9      , VID: V01, SN: xxxxxxxxxx

ap-887vaw#sh ver

Cisco IOS Software, AP802 Software (AP802-K9W7-M), Version 12.4(25d)JAX, RELEASE SOFTWARE (fc1)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2011 by Cisco Systems, Inc.

Compiled Mon 25-Jul-11 22:10 by prod_rel_team

ROM: Bootstrap program is AP802 boot loader

BOOTLDR: AP802 Boot Loader (AP802-BOOT-M), Version 12.4 [vnanduri-MC2_WEEKLY_10242011 100]

ap-887vaw uptime is 40 minutes

System returned to ROM by power loss

System image file is "flash:/ap802-k9w7-mx.124-25d.JAX/ap802-k9w7-mx.124-25d.JAX"

TIA

  H


1 ACCEPTED SOLUTION

Accepted Solutions

Re: How to configure AP of 887VA-W-E-K9?

ok you need to create GigEthernat0.10 as well then add bridge-group 10 under the gig and radio sub-interfaces.

This configures just like any other stand alone AP. remember to put the gig interface on the router into a trunk port as well, since you are sending tagged traffic out.

Steve

Sent from Cisco Technical Support iPhone App

HTH, Steve ------------------------------------------------------------------------------------------------ Please remember to rate useful posts, and mark questions as answered
8 REPLIES

Re: How to configure AP of 887VA-W-E-K9?

under the radio interface you need to specify the cipher this before you can add the WPA under the SSID, if the SSID is already defined under the radio.

So if you go under the radio and do a no SSID hurricane You should then be able to do the key management in the SSID config. Then add the cipher under the radio and then add the SSID. If that doesn't work, please post a show run from the AP.

Steve

Sent from Cisco Technical Support iPhone App

HTH, Steve ------------------------------------------------------------------------------------------------ Please remember to rate useful posts, and mark questions as answered
New Member

How to configure AP of 887VA-W-E-K9?

Hi. Thanks for that..

I found the problem with the radio... It wanted the encryption for the specific vlan specified in my config.. So because the dot11 ssid was on vlan 10, it wanted

interface Dot11Radio0

no ip address

no ip route-cache

!

encryption vlan 10 mode ciphers aes-ccm tkip

!

encryption mode ciphers tkip

instead of just

interface Dot11Radio0

no ip address

no ip route-cache

!

encryption mode ciphers tkip

... So now the radio comes up... But traffic doesn't seem to be bridged from the AP network to VLAN 10 on the router itself... The config looks like this (Possibly there's bits in there that are wrong/not required I still haven't found a cisco AP guide that actually matches the IOS on the AP itself).

sh run

Building configuration...

Current configuration : 1915 bytes

!

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname ap-887vaw

!

logging rate-limit console 9

enable secret 5 **********

!

aaa new-model

!

!

!

aaa session-id common

!

!

dot11 syslog

!

dot11 ssid tks-887

   vlan 10

   authentication open

   authentication key-management wpa

   guest-mode

   wpa-psk ascii 7 wpa-shared-key

!

!

!

username Cisco password 7 password

!

!

bridge irb

!

!

interface Dot11Radio0

no ip address

no ip route-cache

!

encryption vlan 10 mode ciphers aes-ccm tkip

!

encryption mode ciphers tkip

!       

broadcast-key vlan 10 change 300

!

!

ssid tks-887

!

antenna gain 0

speed  basic-1.0 basic-2.0 basic-5.5 basic-11.0 basic-6.0 basic-9.0 basic-12.0 basic-18.0 basic-24.0 basic-36.0 basic-48.0 basic-54.0 m0. m1. m2. m3. m4. m5. m6. m7. m8. m9. m10. m11. m12. m13. m14. m15.

station-role root

world-mode dot11d country-code GB indoor

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface Dot11Radio0.10

encapsulation dot1Q 10

no ip route-cache

logging event subif-link-status

!        

interface GigabitEthernet0

description the embedded AP GigabitEthernet 0 is an internal interface connecting AP with the host router

no ip address

no ip route-cache

bridge-group 1

no bridge-group 1 source-learning

bridge-group 1 spanning-disabled

!

interface BVI1

ip address dhcp client-id GigabitEthernet0

no ip route-cache

!

ip http server

ip http port 8080

no ip http secure-server

ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag

snmp-server community bandaid RO

bridge 1 route ip

!

!

!

line con 0

line vty 0 4

!

end

The Gigabit interface (And the wlan-ap0 interface for managing it) on the router to the AP is configured as

interface Wlan-GigabitEthernet0

description Internal switch interface connecting to the embedded AP

switchport trunk native vlan 1000

switchport trunk allowed vlan 1,2,10,1002-1005

switchport mode trunk

no ip address

!

interface wlan-ap0

description Embedded Service module interface to manage the embedded AP

ip unnumbered Vlan10

!

Main problem is I don't have any docs that describe how this thing actually hangs together... Or an IOS guide that actually matches the commands supported on the router/AP.

H

New Member

Solved;Change interface BVI1

Solved;

Change interface BVI1 to read,

interface BVI1
 description --- Wireless and Customer LAN Bridge ---
 ip address dhcp client-id GigabitEthernet0
 no ip route-cache

Thankyou.

 

Re: How to configure AP of 887VA-W-E-K9?

ok you need to create GigEthernat0.10 as well then add bridge-group 10 under the gig and radio sub-interfaces.

This configures just like any other stand alone AP. remember to put the gig interface on the router into a trunk port as well, since you are sending tagged traffic out.

Steve

Sent from Cisco Technical Support iPhone App

HTH, Steve ------------------------------------------------------------------------------------------------ Please remember to rate useful posts, and mark questions as answered
New Member

How to configure AP of 887VA-W-E-K9?

Yeah... I found that... Love the way it differes between devices.. Anyway. I did

interface GigabitEthernet0

description the embedded AP GigabitEthernet 0 is an internal interface connecting AP with the host router

no ip address

no ip route-cache

!

interface GigabitEthernet0.10

encapsulation dot1Q 10 native

no ip route-cache

bridge-group 10

no bridge-group 10 source-learning

bridge-group 10 spanning-disabled

!

interface BVI1

no ip address

no ip route-cache

!

interface BVI10

ip address 192.168.254.22 255.255.255.0

no ip route-cache

!        

And the Gig interface on the router is

interface Wlan-GigabitEthernet0

description Internal switch interface connecting to the embedded AP

switchport trunk native vlan 1000

switchport trunk allowed vlan 1,2,10,1002-1005

switchport mode trunk

no ip address

But I don't seem to be able to talk to the AP on any 192.168.254.0/24 address... e.g. Attempting to ping the BVI address (192.168.254.22) gives no response from a PC connected to VLAN10 on the router via fe0 (But the PC can communicate with the SVI vlan10 on the router fine).

I can't ping from the router to the AP either... But I can get from the router to the AP's console OK... Is that BVI config on the AP correct? (I"m not real sure about BVI's).

H

New Member

How to configure AP of 887VA-W-E-K9?

Doh!

Last one is a  Copy & Paste error (Or more accurately blindly following an exmaple elsewhere without reading it properly and understanding what it was doing)... The example I was following had 'native' on the vlan config... I removed it and I think it's working...

At least my iPad just got an IP from the DHCP server on the router...

H

New Member

How to configure AP of 887VA-W-E-K9?

And the AP is now working... Thanks Steve.

One last issue is why the BVI doesn't respond to IP... Shouldn't I be able to ping the BVI 10  from the LAN? (One of the AP docs says I should be able to access the web interface for the AP via that IP... But I get no repsonse to ping or http...

H

Re: How to configure AP of 887VA-W-E-K9?

Since you are calling the .10 sub interface. Active you need to set the rink native VLAN to be 10 on the router as well.

Steve

Sent from Cisco Technical Support iPhone App

HTH, Steve ------------------------------------------------------------------------------------------------ Please remember to rate useful posts, and mark questions as answered
9648
Views
0
Helpful
8
Replies
CreatePlease to create content