Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

HWIC AP and HWIC 4ESW Bridging ?? Problem

Hi,

I wonder if anyone can help - I'm trying to setup both a HWIC-4ESW Switch and a HWIC-AP Access Point to work together in the same 1841 router chassis.

What I want to achieve is that clients on both the wired and wireless interfaces are on the same subnet and LAN and can therefore communicate together. At the moment I can only get one or the other to work (Internet Connectivity is fine):

!

interface Dot11Radio0/0/0

no ip address

ip virtual-reassembly

!

encryption mode ciphers tkip

!

encryption vlan 1 mode ciphers tkip

!

ssid aspremont

authentication open

authentication key-management wpa

guest-mode

wpa-psk ascii 7 ***************

!

speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0

channel 2437

station-role root

no cdp enable

end

interface Vlan1

ip address 192.168.1.1 255.255.255.0

ip nat inside

ip virtual-reassembly

end

!

no ip dhcp use vrf connected

no ip dhcp conflict logging

ip dhcp excluded-address 192.168.1.1 192.168.1.99

!

ip dhcp pool DHCP_ADDRESS_POOL

network 192.168.1.0 255.255.255.0

dns-server ********* ************

default-router 192.168.1.1

Unfortunately the IOS version I'm using: 12.4(11)T has some bugs with SDM, so I can see the config in the GUI but not modify it (I don't have access to later version).

I've tried bridging to another interface, adding a vlan to the ssid and a few other things, to no avail.

It must be possible though, as this basically what Home Wireless Routers are doing.

Any help is appreciated.

1 REPLY
New Member

Re: HWIC AP and HWIC 4ESW Bridging ?? Problem

No replies but the fix was fairly simple (after a few hours of fiddling).

Create a bridged virtual interface, place both interfaces in the bridge group of this interface, then treat this interface as a normal internal interface (as the inside NAT i/f for example.

A lot of the bridge commands are added automatically after placing the interface in a bridge group:

A Bridged interfaced and bridge irb:

ip dhcp pool DHCP_ADDRESS_POOL

network 192.168.1.0 255.255.255.0

dns-server *********** ***********

default-router 192.168.1.1

!

bridge irb

!

interface Dot11Radio0/0/0

no ip address

ip virtual-reassembly

!

encryption mode ciphers tkip

!

ssid aspremont

authentication open

authentication key-management wpa

guest-mode

wpa-psk ascii 7 *******************

!

speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0

channel 2437

station-role root

no cdp enable

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 spanning-disabled

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

!

interface Vlan1

no ip address

ip virtual-reassembly

bridge-group 1

bridge-group 1 spanning-disabled

!

interface BVI1

ip address 192.168.1.1 255.255.255.0

ip nat inside

ip virtual-reassembly

!

!

bridge 1 route ip

!

306
Views
0
Helpful
1
Replies