Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

I can not get dhcp to hand out address over the wireless

I can not get dhcp to hand out address over the wireless.  the LAN works just fine.

hear is the config for the AP and the router. This is a 881w router with the integrated AP

  • Getting Started with Wireless
3 REPLIES
Cisco Employee

Re: I can not get dhcp to hand out address over the wireless

Hi,

I have attached the perfectly working configuration on my LAB device.. check it out and see whats the mis-configurations tha we have on your device..

lemme know if this answered your question..

Regards
Surendra
====
Please dont forget to rate the posts which answered your question and mark it as answered or was helpfull

New Member

Re: I can not get dhcp to hand out address over the wireless

The biggest problem I see with your config is that you only have a vlan 1 interface with an ip and ip-helpers.

Your radios consist of the following:

!
interface Dot11Radio0.100
encapsulation dot1Q 100
ip helper-address 10.10.2.1
no ip route-cache
bridge-group 100
bridge-group 100 subscriber-loop-control
bridge-group 100 block-unknown-source
no bridge-group 100 source-learning
no bridge-group 100 unicast-flooding
bridge-group 100 spanning-disabled
!
interface Dot11Radio0.104
encapsulation dot1Q 104
no ip route-cache
bridge-group 104
bridge-group 104 subscriber-loop-control
bridge-group 104 block-unknown-source
no bridge-group 104 source-learning
no bridge-group 104 unicast-flooding
bridge-group 104 spanning-disabled

That means you need to add vlan interface 100 and vlan interface 104 to your router and setup ip helper-addresses for both.

If you need any other assistance, let us know.

Tony

New Member

Re: I can not get dhcp to hand out address over the wireless

Sorry... I forgot to give you an example, which you may not need.

!
interface Vlan1
ip address 10.15.4.1 255.255.254.0

ip helper-address 10.10.2.1
ip helper-address 10.10.2.2
!

!
interface Vlan100
ip address 10.?.?.? 255.255.254.0
ip helper-address 10.10.2.1
ip helper-address 10.10.2.2
!

!
interface Vlan104
ip address 10.?.?.? 255.255.254.0
ip helper-address 10.10.2.1
ip helper-address 10.10.2.2
!

Basically, you need a layer 3 interface for every vlan you create on the AP.  Hope this helps!

Tony

989
Views
0
Helpful
3
Replies
This widget could not be displayed.