Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Users might experience few discrepancies in Search results. We are working on this on our side. We apologize for the inconvenience it may have caused.
New Member

Issue with AP1231 and VLANS

Hello,

I'm trying to setup 2 VLAN's 1 for Native Traffic on my Corp network and another VLAN for Guest Wireless traffic.  I have attached the Config from my Cisco AP1231 and my Cisco 3750.  I have the AP plugged into port 24 on my switch.  I seem to have the VLAN's working fine.  I can get the AP1231 to broadcast both SSID's and the very first time i can connect everything seems to work fine.  after i power down my switch and AP i cannot connect to either SSID.  I get the message Not Connected.    Any info would be greatly appreciated.  Thanks                

Everyone's tags (2)
1 ACCEPTED SOLUTION

Accepted Solutions

Re: Issue with AP1231 and VLANS

Hi Joe,

I am no CLI expert.

But looking at switch port 24, which is connected to the AP,  why is port 23 and 24 part of a channel group?

interface FastEthernet2/0/23

switchport trunk encapsulation dot1q

switchport mode trunk

channel-protocol lacp

channel-group 1 mode active

!

interface FastEthernet2/0/24

switchport trunk encapsulation dot1q

switchport mode trunk

switchport nonegotiate

channel-protocol lacp

channel-group 1 mode active

What are you aggregating, try removing the following from switchport 24, probably left over from an old configuration.

no channel-protocol lacp

no channel-group 1

What's the purpose of the "switchport nonegotiate"  command on switch port 24, when you configure nonegotiate, you're disabling dynamic truncking protocol, is there really a need for this command?

lets see how far this gets you.

regards Dave

2 REPLIES

Re: Issue with AP1231 and VLANS

Hi Joe,

I am no CLI expert.

But looking at switch port 24, which is connected to the AP,  why is port 23 and 24 part of a channel group?

interface FastEthernet2/0/23

switchport trunk encapsulation dot1q

switchport mode trunk

channel-protocol lacp

channel-group 1 mode active

!

interface FastEthernet2/0/24

switchport trunk encapsulation dot1q

switchport mode trunk

switchport nonegotiate

channel-protocol lacp

channel-group 1 mode active

What are you aggregating, try removing the following from switchport 24, probably left over from an old configuration.

no channel-protocol lacp

no channel-group 1

What's the purpose of the "switchport nonegotiate"  command on switch port 24, when you configure nonegotiate, you're disabling dynamic truncking protocol, is there really a need for this command?

lets see how far this gets you.

regards Dave

New Member

Issue with AP1231 and VLANS

Hello Dave,

  Well i think that may have been it.  I removed the channel-group and channel-protocol and the nonegotiate commands.  Tried it and it didn't seem to work.  So i then wr erased the AP and setup again using the same config as above and it seems to work fine now.   I think those commands might have been left in there from a previous configuration and i didn't think anythink of it since my VLANs seem to work fine.   I've been stumped on this one for over a week now.  Thanks again,  Joe

353
Views
0
Helpful
2
Replies
CreatePlease to create content