Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Issues with the upgrade of a 887 router to Cisco Unified Software

Hi!, everyone!.  I'm trying to upgrade a C887VA-W-A-K9 router that is running c800-universalk9-mz.SPA.152-3.T.bin to the Cisco Unified Software.  I'm following the procedure presented by Cisco (http://www.cisco.com/en/US/docs/routers/access/800/880/software/configuration/guide/880_basic_device_wireless_config.html#wp1065622

), but I cannot find the command "service-module wlan-ap 0 bootimage unified" anywhere, I have tried in EXEC mode and Global configuration Mode without luck, these were the CLI outputs for each mode:

RTR_1#service-module wlan-ap0 bootimage unified

                                          ^

% Invalid input detected at '^' marker.

RTR_1#service-module wlan-ap0 ?                

  heartbeat-reset  Enable/disable Heartbeat failure to reset Service Module

  reload           Reload service module

  reset            Hardware reset of Service Module

  session          Service module session

  statistics       Service Module Statistics

  status           Service Module Information

  upgrade          Service Module Upgrade

RTR_1#service-module wlan-ap0 upgrade ?

  bootloader  Upgrade bootloader

=======================================================================

When I run the same command from global configuration mode I get this:

RTR_1(config)#service-module wlan-ap 0 bootimage unified

                                 ^

% Invalid input detected at '^' marker.

RTR_1(config)#service?                                 

service

=======================================================================

After a couple of tests I managed to "convert" the AP to lightweight forcing the AP module into rommon and booting the image manually.  After that the AP can register with the WLC and download the new firmware, but after that I started receiving the following log messages in the CLI of the AP module:

*Apr  9 10:40:29.103: %SM_LICENSE-6-BOOTIMAGE_CHANGE_TO_AUTO: Boot image has been changed to autonomous image

Please use router EXEC CLI service-module wlan-ap 0 reload

to bootup autonomous image on AP

** I read on another post, that this output is generated in consequence on an incomplete conversion to lightweight, in that post it is suggested to use the command that I cannot found (service-module wlan-ap 0 bootimage unified) to solve the issue.

Another issue is that everytime that I turn on the router I lost the configuration on my SVI and the boot line for the AP module.  After researching a little bit this issue.  I discover that the WLAN-AP 0 interface is taking the IP address of the SVI, before the SVI at the startup, so when the SVI tries to use that IP address it founds that it is in use by another interface (in this case the WLAN-AP interface).  For the boot line I really dont know where to start, I assume that this problem will be solved when I can perform a complete conversion through applying the missing command

Can you help me?? I don't know where I messed up.  I attached a copy of my running config and sho version.

Regards.

Isauro

4 REPLIES

Issues with the upgrade of a 887 router to Cisco Unified Softwar

Isauro,

     Does it act differently if you do:

conf t

interface wlan-ap0

ip unnumbered vlan 1

exit

!

Steve

HTH, Steve ------------------------------------------------------------------------------------------------ Please remember to rate useful posts, and mark questions as answered
New Member

Issues with the upgrade of a 887 router to Cisco Unified Softwar

Hi, Steve!.  Thanks for your response.

Actually, yes after I changed the way in which Wlan-Ap0 gets its IP address to the one that you suggested.  My SVI after reloading the router maintained its IP address.  Do you know why, the AP module keeps going to rommon?

Regards.

Isauro

Issues with the upgrade of a 887 router to Cisco Unified Softwar

I woudl think it might have to do with the confreg that the AP got put into.

But now that hte SVI is holding, you coudl try to use the service-module commands to tell teh AP to be unified and see if it stops doing that.

Steve

HTH, Steve ------------------------------------------------------------------------------------------------ Please remember to rate useful posts, and mark questions as answered
New Member

Isauro,The reason you don't

Isauro,

The reason you don't see the command "service-module wlan-ap 0 boot image unified" is because you need the advanced IP Services License on your router.  Once you purchase (or trial) the license and install it on the router, the command becomes visible.  Do a show version from the CLI to see your current license as in example below.

 

881_router#sh version
Cisco IOS Software, C800 Software (C800-UNIVERSALK9-M), Version 15.3(3)M5, RELEASE SOFTWARE (fc3)

<lines removed for readability>
License Info:

License UDI:

-------------------------------------------------
Device#   PID                   SN
-------------------------------------------------
*0        C881W-A-CVO-K9        FTXXXXXXXXXX    

 

License Information for 'c800'
    License Level: advipservices   Type: Permanent
    Next reboot license Level: advipservices


Configuration register is 0x2102

715
Views
0
Helpful
4
Replies