Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

LAG doesn't work - wlc 5508

Hi gurus,

I am using the startup utility to configure LAG on a 5508 to connect to 3560G switch. i have tried to use 7.0, 7.4, 7.5 but I just can't get it up, however I can get it connected using access port. I notice the light on the first port is always off, i can't find an option to configure the STP on the wlc 5508, i tried to follow the documentation but to no avail, I would really appreciate help here. Thanks a lot.

I have the below on the switch :

interface Port-channel32

description LAG port connected to BA-C-WLC03

switchport trunk encapsulation dot1q

switchport trunk native vlan 30

switchport mode trunk

spanning-tree portfast

!

interface GigabitEthernet0/1
switchport trunk encapsulation dot1q
switchport trunk native vlan 30
switchport mode trunk
channel-group 32 mode on
spanning-tree portfast

and the WLC 5508:

Port Summary
           STP   Admin   Physical   Physical   Link   Link
Pr  Type   Stat   Mode     Mode      Status   Status  Trap     POE    SFPType

-- ------- ---- ------- ---------- ---------- ------ ------- ------- ----------
1  Normal  Disa Enable  Auto       Auto       Down   Enable  N/A     1000BaseTX

2  Normal  Forw Enable  Auto       1000 Full  Up     Enable  N/A     1000BaseTX

3  Normal  Forw Enable  Auto       1000 Full  Up     Enable  N/A     1000BaseTX

4  Normal  Forw Enable  Auto       1000 Full  Up     Enable  N/A     1000BaseTX

Interface Name................................... management

MAC Address...................................... a4:93:4c:b0:93:2f

IP Address....................................... 10.200.130.11

IP Netmask....................................... 255.255.255.224

IP Gateway....................................... 10.200.130.1

External NAT IP State............................ Disabled

External NAT IP Address.......................... 0.0.0.0

VLAN............................................. untagged

Quarantine-vlan.................................. 0

Active Physical Port............................. LAG (13)

Primary Physical Port............................ LAG (13)

Backup Physical Port............................. Unconfigured

DHCP Proxy Mode.................................. Global

Primary DHCP Server.............................. 10.200.102.21

Secondary DHCP Server............................ Unconfigured

DHCP Option 82................................... Disabled

IPv4 ACL......................................... Unconfigured

IPv6 ACL......................................... Unconfigured

mDNS Profile Name................................ Unconfigured

AP Manager....................................... Yes

Guest Interface.................................. No
Interface Name................................... management
MAC Address...................................... a4:93:4c:b0:93:2f
IP Address....................................... 10.200.130.11
IP Netmask....................................... 255.255.255.224
IP Gateway....................................... 10.200.130.1
External NAT IP State............................ Disabled
External NAT IP Address.......................... 0.0.0.0
VLAN............................................. untagged
Quarantine-vlan.................................. 0
Active Physical Port............................. LAG (13)
Primary Physical Port............................ LAG (13)
Backup Physical Port............................. Unconfigured
DHCP Proxy Mode.................................. Global
Primary DHCP Server.............................. 10.200.102.21
Secondary DHCP Server............................ Unconfigured
DHCP Option 82................................... Disabled
IPv4 ACL......................................... Unconfigured
IPv6 ACL......................................... Unconfigured
mDNS Profile Name................................ Unconfigured
AP Manager....................................... Yes
Guest Interface.................................. No

4 ACCEPTED SOLUTIONS

Accepted Solutions
Bronze

Re: LAG doesn't work - wlc 5508

Hi,

Disable LAG, and connect to a single trunk switch port, would port 1 go up?

also, you can check the switch port statistics if there are any packets from the WLC port 1.

Hall of Fame Super Silver

Re: LAG doesn't work - wlc 5508

Are you making changes which makes the WLC loose connectivity? Try putting the WLC in a new vlan or a different vlan to test. You already found a bad switchport so I would test on a different switch also.

Sent from Cisco Technical Support iPhone App

-Scott
*** Please rate helpful posts ***
Hall of Fame Super Silver

Re: LAG doesn't work - wlc 5508

Your sfp's working fine?  I would just connect one port at a time and test... so for example... connect only wlc port 1 to i'm guessing GE0/2 and see if that works.  Then disconnect that and only connect wlc port 2 to GE0/3 and so on.  Just doesn't seem right unless it something wrong with the switch.

Thanks,

Scott

Help out other by using the rating system and marking answered questions as "Answered"

-Scott
*** Please rate helpful posts ***
Hall of Fame Super Silver

Re: LAG doesn't work - wlc 5508

Okay... as long as you can test everything out on the switch side it would be easier... as I have to assume things are all working.  The thing is, you can setup the switch ports all in a etherchannel and connect only one port on the WLC and it should work.  Now if you connect two and it fails, then we hav an issue somewhere. 

Can you post your show run-config no ap

Thanks,


Scott

Help out other by using the rating system and marking answered questions as "Answered"

-Scott
*** Please rate helpful posts ***
22 REPLIES
Hall of Fame Super Silver

Re: LAG doesn't work - wlc 5508

Just to be sure, this IP 10.200.130.11 is on vlan 30?

Sent from Cisco Technical Support iPhone App

-Scott
*** Please rate helpful posts ***
New Member

Re: LAG doesn't work - wlc 5508

Hi Scott,

Yes, 10.200.130.11 is on vlan 30.

Hall of Fame Super Silver

Re: LAG doesn't work - wlc 5508

Also issue this

config port adminmode 1 enable

Sent from Cisco Technical Support iPhone App

-Scott
*** Please rate helpful posts ***
New Member

Re: LAG doesn't work - wlc 5508

Hi Scott,

Adminmode is enabled, but the port is still down despite rebooted, actually I have 3 units of 5508 all having port 1 down, and LAG won't formed, i have tried to connect to a 4500 switch as well.

Product Name..................................... Cisco Controller
Product Version.................................. 7.5.102.0
Bootloader Version............................... 1.0.1
Field Recovery Image Version..................... 6.0.182.0
Firmware Version................................. FPGA 1.3, Env 1.6, USB console
1.27
Build Type....................................... DATA + WPS

System Name...................................... Cisco_b0:93:24
System Location..................................
System Contact...................................
System ObjectID.................................. 1.3.6.1.4.1.9.1.1069
Redundancy Mode.................................. Disabled
IP Address....................................... 10.200.130.11
Last Reset....................................... Software reset
System Up Time................................... 0 days 0 hrs 5 mins 11 secs
System Timezone Location.........................
System Stats Realtime Interval................... 5
System Stats Normal Interval..................... 180

Hall of Fame Super Silver

Re: LAG doesn't work - wlc 5508

Remove the native vlan and tag the vlan in the WLC.

Sent from Cisco Technical Support iPhone App

-Scott
*** Please rate helpful posts ***
New Member

Re: LAG doesn't work - wlc 5508

Hi Scott,

It is the same.

Interface Name                   Port Vlan Id  IP Address      Type    Ap Mgr Gu
est
-------------------------------- ---- -------- --------------- ------- ------ --
---
management                       LAG  30       10.200.130.11   Static  Yes    No

redundancy-management            LAG  30       0.0.0.0         Static  No     No

redundancy-port                  -    untagged 0.0.0.0         Static  No     No

service-port                     N/A  N/A      192.168.130.1   Static  No     No

virtual                          N/A  N/A      1.6.6.6         Static  No     No

BA-1F-C-CS01(config)#int port-c32

BA-1F-C-CS01(config-if)#no switchport trunk native vlan 30

(Cisco Controller) >ping 10.200.130.1

Send count=3, Receive count=0 from 10.200.130.1

Hall of Fame Super Silver

Re: LAG doesn't work - wlc 5508

That's weird because if its all 3 WLC's. your saying if you set the port to an access port the WLC port comes up? Or is the port always down.

Since this seems like a new install, can you factory reset the WLC and then tag the vlan and leave lag as default. Also the service port isn't connected to the network correct. Don't enable HA also when you are in the startup wizard.

Sent from Cisco Technical Support iPhone App

-Scott
*** Please rate helpful posts ***
Hall of Fame Super Silver

Re: LAG doesn't work - wlc 5508

Can you also capture your input when your going thought the wizard.

Sent from Cisco Technical Support iPhone App

-Scott
*** Please rate helpful posts ***
New Member

Re: LAG doesn't work - wlc 5508

Hi Scott,

Attached is the log after resetting to factory default. I didn't enable HA, the service port is not physically connected.

As with port 1, I found out that the error is from the switch, the interface is lid and fowarding, but doesn't work, it works after i swap the port.

However, the LAG still doesn't work.

(Cisco Controller) >show port sum

           STP   Admin   Physical   Physical   Link   Link
Pr  Type   Stat   Mode     Mode      Status   Status  Trap     POE    SFPType

-- ------- ---- ------- ---------- ---------- ------ ------- ------- ----------
1  Normal  Forw Enable  Auto       1000 Full  Up     Enable  N/A     1000BaseTX

2  Normal  Forw Enable  Auto       1000 Full  Up     Enable  N/A     1000BaseTX

3  Normal  Forw Enable  Auto       1000 Full  Up     Enable  N/A     1000BaseTX

4  Normal  Forw Enable  Auto       1000 Full  Up     Enable  N/A     1000BaseTX

5  Normal  Forw Enable  Auto       1000 Full  Up     Enable  N/A     1000BaseTX


Interface Name................................... management
MAC Address...................................... a4:93:4c:b0:93:2f
IP Address....................................... 10.200.130.11
IP Netmask....................................... 255.255.255.224
IP Gateway....................................... 10.200.130.1
External NAT IP State............................ Disabled
External NAT IP Address.......................... 0.0.0.0
VLAN............................................. untagged
Quarantine-vlan.................................. 0
Active Physical Port............................. LAG (13)
Primary Physical Port............................ LAG (13)
Backup Physical Port............................. Unconfigured
DHCP Proxy Mode.................................. Global
Primary DHCP Server.............................. 10.200.102.21
Secondary DHCP Server............................ Unconfigured
DHCP Option 82................................... Disabled
IPv4 ACL......................................... Unconfigured
IPv6 ACL......................................... Unconfigured
mDNS Profile Name................................ Unconfigured
AP Manager....................................... Yes
Guest Interface.................................. No

--More-- or (q)uit
L2 Multicast..................................... Enabled

New Member

Re: LAG doesn't work - wlc 5508

Hi Scott,

There is also a very strange behaviour that each time when the WLC is reset to factory default, it will stay connected to the switch for a period of time, after that the connectivity is gone.

I added a static mac to the switch, and I was able to ping for a while so far so good..

I am able to ping from the switch to the WLC, however not from WLC to switch or from the connected notebook to the WLC.

BA-1F-C-CS01#ping 10.200.130.11

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.200.130.11, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/4/9 ms

(Cisco Controller) >ping 10.200.130.1

Send count=3, Receive count=0 from 10.200.130.1

this is an initial setup, so both devices are connected directly, no firewall or anything in between.

regards,

Paul

Hall of Fame Super Silver

Re: LAG doesn't work - wlc 5508

Are you making changes which makes the WLC loose connectivity? Try putting the WLC in a new vlan or a different vlan to test. You already found a bad switchport so I would test on a different switch also.

Sent from Cisco Technical Support iPhone App

-Scott
*** Please rate helpful posts ***
New Member

Re: LAG doesn't work - wlc 5508

Hi Scott,

The switch is a second one I used, it is a blank switch to test this out. i change the vlan anyway but no go. i will look for another one to try....

Why it gets connected only when i factory reset it? but only for a while.

append below the only config on the switch:

no aaa new-model
system mtu routing 1500
vtp domain xxxx
vtp mode transparent
!

port-channel load-balance src-dst-ip
!
spanning-tree mode rapid-pvst
spanning-tree extend system-id
spanning-tree backbonefast
spanning-tree vlan 30 priority 8192
!
vlan internal allocation policy ascending
!
vlan 30
name testing
!
!
!
interface Port-channel32
description LAG port connected to BA-C-WLC03
switchport trunk encapsulation dot1q
switchport trunk native vlan 30
switchport mode trunk
spanning-tree portfast
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
switchport trunk encapsulation dot1q
switchport trunk native vlan 30
switchport mode trunk
channel-group 32 mode on
spanning-tree portfast
!
interface GigabitEthernet0/3
switchport trunk encapsulation dot1q
switchport trunk native vlan 30
switchport mode trunk
channel-group 32 mode on
spanning-tree portfast
!
interface GigabitEthernet0/4
switchport trunk encapsulation dot1q
switchport trunk native vlan 30
switchport mode trunk
channel-group 32 mode on
spanning-tree portfast

!

interface GigabitEthernet0/5

switchport trunk encapsulation dot1q

switchport trunk native vlan 30

switchport mode trunk

channel-group 32 mode on

spanning-tree portfast

!

interface GigabitEthernet0/6

switchport trunk encapsulation dot1q

switchport trunk native vlan 30

switchport mode trunk

channel-group 32 mode on

spanning-tree portfast

interface Vlan30

description ## Wireless Management VLAN ##

ip address 10.200.130.2 255.255.255.224

no ip redirects

no ip unreachables

standby 30 ip 10.200.130.1

standby 30 timers 1 3

standby 30 priority 150

standby 30 preempt

!

ip http server

ip http secure-server

!

Hall of Fame Super Silver

LAG doesn't work - wlc 5508

interface GigabitEthernet0/1

This is the interface that the wlc connects to correct?  Any you only have one port on the WLC connected to that port?  You must also have the WLC managment interface set to vlan tag of 0 which is untagged for this to work, correct?

Thanks,

Scott

Help out other by using the rating system and marking answered questions as "Answered"

-Scott
*** Please rate helpful posts ***
New Member

Re: LAG doesn't work - wlc 5508

Hi Scott,

interface gi0/1 is not in use after I detected a problem in it. the management interface has been set to tagged 30 or 0 alternating with the switch, it will only works after a factory reset.

The WLC has 5 physically connected ports ranging from port 1 - 5 connecting with the 3560 switchport ranging gi0/2-6.

Port-channel: Po32
------------

Age of the Port-channel   = 0d:01h:43m:06s
Logical slot/port   = 2/32          Number of ports = 5
GC                  = 0x00000000      HotStandBy port = null
Port state          = Port-channel Ag-Inuse
Protocol            =    -
Port security       = Disabled

Ports in the Port-channel:

Index   Load   Port     EC state        No of bits
------+------+------+------------------+-----------
  0     00     Gi0/2    On                 0
  0     00     Gi0/3    On                 0
  0     00     Gi0/4    On                 0
  0     00     Gi0/5    On                 0
  0     00     Gi0/6    On                 0

Time since last port bundled:    0d:00h:04m:40s    Gi0/2
Time since last port Un-bundled: 0d:00h:05m:02s    Gi0/2

but i can see CDP neighbour from 2 ports only, why?

Switch#sh cdp nei
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone,
                  D - Remote, C - CVTA, M - Two-port Mac Relay

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
BA-1F-D-WLC03    Gig 0/5           171               H    AIR-CT550 Gig 0/0/1
BA-1F-D-WLC03    Gig 0/6           171               H    AIR-CT550 Gig 0/0/5
BA-1F-D-WLC03    Gig 0/5           171               H    AIR-CT550 LAGInterface
0/3/1

Hall of Fame Super Silver

Re: LAG doesn't work - wlc 5508

Your sfp's working fine?  I would just connect one port at a time and test... so for example... connect only wlc port 1 to i'm guessing GE0/2 and see if that works.  Then disconnect that and only connect wlc port 2 to GE0/3 and so on.  Just doesn't seem right unless it something wrong with the switch.

Thanks,

Scott

Help out other by using the rating system and marking answered questions as "Answered"

-Scott
*** Please rate helpful posts ***
New Member

Re: LAG doesn't work - wlc 5508

Hi Scott,

Thanks much for painstakingly trying to help me, I really appreciate it.

You are right, your answer " unless it is something wrong with the switch" help me, I get a 2960, channel up the 2 gig port, trunk to a 1841. it works!!

I just can't believe i have 2 production switch - 4500 & 3560 having problem!

thanks a lot.

Hall of Fame Super Silver

Re: LAG doesn't work - wlc 5508

Okay... as long as you can test everything out on the switch side it would be easier... as I have to assume things are all working.  The thing is, you can setup the switch ports all in a etherchannel and connect only one port on the WLC and it should work.  Now if you connect two and it fails, then we hav an issue somewhere. 

Can you post your show run-config no ap

Thanks,


Scott

Help out other by using the rating system and marking answered questions as "Answered"

-Scott
*** Please rate helpful posts ***
New Member

Re: LAG doesn't work - wlc 5508

Hi Scott,

attached the 2960 & 1841 config.

Thanks again!

Hall of Fame Super Silver

Re: LAG doesn't work - wlc 5508

Is this vlan 30 new?  Can you put the WLC in an existing vlan that has been working and test from there.

Thanks,

Scott

Help out other by using the rating system and marking answered questions as "Answered"

-Scott
*** Please rate helpful posts ***
Bronze

Re: LAG doesn't work - wlc 5508

Hi,

Disable LAG, and connect to a single trunk switch port, would port 1 go up?

also, you can check the switch port statistics if there are any packets from the WLC port 1.

New Member

Re: LAG doesn't work - wlc 5508

Hi Yahya,

Yes, the port comes up using trunk or access.


           STP   Admin   Physical   Physical   Link   Link
Pr  Type   Stat   Mode     Mode      Status   Status  Trap     POE    SFPType

-- ------- ---- ------- ---------- ---------- ------ ------- ------- ----------
1  Normal  Forw Enable  Auto       1000 Full  Up     Enable  N/A     1000BaseTX


(Cisco Controller) >ping 10.200.130.1

Send count=3, Receive count=3 from 10.200.130.1

BA-1F-C-CS01(config-if)#BA-1F-C-CS01(config-if)#switchport trunk encap dot1
BA-1F-C-CS01(config-if)#switchport mode trunk
BA-1F-C-CS01(config-if)#switch trunk nativ vlan 30

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.200.130.11, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
BA-1F-C-CS01(config-if)#

New Member

Re: LAG doesn't work - wlc 5508

Hi Yahya,

Thanks for helping. the problem with port1 is coming from the switch.

Thanks a lot.

1860
Views
0
Helpful
22
Replies
CreatePlease to create content