Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

LAN Network and AP network can be same- Cisco 1941 Router

I have my Lan user users conned to interface Gigabitethernet 0/0(network 192.168.10.0). DHCP is configured on the server. Now i want to configure WLAN and wants user should also get the ip address from the same network. Otherwise user getting connected with WLAN would have different network add.

so, i cannot give the same ip range to my vlan interface as i have already given to interface Gigabitethernet 0/0. Any chance that Wired and Wireless users should get the same IP range (192.168.10.0) so that they can communicate to each other. I hope you got my point.

Everyone's tags (4)
8 REPLIES
New Member

Re: LAN Network and AP network can be same- Cisco 1941 Router

Anyone please....

Cisco Employee

Re: LAN Network and AP network can be same- Cisco 1941 Router

ok..

lemme think!!!

assuming we have mapped gig 0/0 for vlan 1.. then..if we have interface vlan 1 on the router..

then under the wlap ap 0 interface, issue the command "ip unnumbered vlan 1"

that is..

if..

int vlan 1

ip add 192.168.10.X 255.255.255.0

then..

int wlan-ap 0

ip unnumbered vlan 1

no shut

session into the AP module and assing the IP address to the BVI in the same subnet of vlan 1..

then open up the GUI of the AP and configure for the desired configurations..

This will give the wired and wireless to be in the same subnet.

Regards
Surendra

New Member

Re: LAN Network and AP network can be same- Cisco 1941 Router

First of all, thnx for ur reply.

int vlan 1

ip add 192.168.10.X 255.255.255.0

The above ip range can not be given to LAN interface on same router also. How is it possible from GUI??? why not from CLI???

We need to think logic that On a router we can not give same ip subnet (in our case 192.168.10.x / 24) to vlan 1 (default gateway of my Wireless users) and int gigabitethernet 0/X ( default gateway of my wired users). Is ther any other way to meet my requirement. Thanks

Cisco Employee

Re: LAN Network and AP network can be same- Cisco 1941 Router

ok.. if we move all the configurations which is der inside the gig to vlan 1 then map the vlan to the gig.. so there will be only one interface vlan in the network.

I hope the above was clear.. if not i request you to paste the config..

Regards

Surendra

New Member

Re: LAN Network and AP network can be same- Cisco 1941 Router

ip dhcp pool WLAN

   network 192.168.10.X 255.255.255.0

   default-router 192.168.10.X

   dns-server X.X.X.X

!

interface Wlan-GigabitEthernet0/0

description Internal switch interface connecting to the embedded AP

switchport mode trunk

!

!

interface GigabitEthernet0/0 (You are saying to remove config from here?)

description Connected to LAN

ip address 192.168.10.x 255.255.255.0

ip nat inside

ip virtual-reassembly

duplex auto

speed auto

!

!

interface wlan-ap0

description Service module interface to manage the embedded AP

ip unnumbered Vlan1

arp timeout 0

no mop enabled

no mop sysid

!

!

interface GigabitEthernet0/1

description Connected to WAN

ip address dhcp

ip nat outside

ip virtual-reassembly

duplex auto

speed auto

!

!

interface Vlan1 (We will use only this interface for both wired and wireless users?)

description User coming from AP

ip address 192.168.1.1 255.255.255.0

ip nat inside

ip virtual-reassembly

!

On AP Side

interface BVI1

ip address 192.168.1.3 255.255.255.0

no ip route-cache

Can you give me config after modification you are suggesting ????

Cisco Employee

Re: LAN Network and AP network can be same- Cisco 1941 Router

it will be really great if you could open up a TAC case for this issue.. and the commands are der in the config guide which i provided before.

Regards

Surendra

New Member

Re: LAN Network and AP network can be same- Cisco 1941 Router

how to open TAC case for this issue ??? I am new to this community. Can you help me in this regard???

Cisco Employee

Re: LAN Network and AP network can be same- Cisco 1941 Router

is the device under contract or under warranty?? if so, then contact the Cisco TAC toll free number.. telling wireless config assistance

http://www.cisco.com/en/US/support/tsd_cisco_worldwide_contacts.html

Regards

Surendra

1800
Views
0
Helpful
8
Replies