Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Laptop not getting an address

Hi guys,

I am trying to get my access point to pass through DHCP requests from my router, but it just keeps giving out 169 address. When I connect my laptop directly to the router it works fine, and the access point is getting an address from the router. But there seems to be a problem when something connects to the access point. I know I am doing something wrong, but i don't know what it is!  Any help would be much appreciated.

 

Access Point Config


hostname ap
!
no aaa new-model
!
dot11 syslog
!
dot11 ssid Ross
   vlan 10
   authentication open
   authentication key-management wpa version 2
   mbssid guest-mode
   wpa-psk ascii 7 ****
!
bridge irb
!
interface Dot11Radio0
 no ip address
 no ip route-cache
 !
 encryption vlan 10 mode ciphers tkip
 !
 ssid Ross
 !
 mbssid
 station-role root
 bridge-group 1
 bridge-group 1 block-unknown-source
 no bridge-group 1 source-learning
 no bridge-group 1 unicast-flooding
 bridge-group 1 spanning-disabled
!
interface Dot11Radio0.10
 encapsulation dot1Q 10
 no ip route-cache
 bridge-group 10
 bridge-group 10 subscriber-loop-control
 bridge-group 10 block-unknown-source
 no bridge-group 10 source-learning
 no bridge-group 10 unicast-flooding
 bridge-group 10 spanning-disabled
!
interface FastEthernet0
 no ip address
 no ip route-cache
 duplex auto
 speed auto
 bridge-group 1
 no bridge-group 1 source-learning
 bridge-group 1 spanning-disabled
!
interface BVI1
 ip address dhcp client-id FastEthernet0
 no ip route-cache
!
ip http server
no ip http secure-server
ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
bridge 1 route ip
!
line con 0
line vty 0 4
 login local
!
end

 

Router Config


hostname R1
!
boot-start-marker
boot-end-marker
!
no aaa new-model
!
memory-size iomem 10
!
no ip source-route
!
ip dhcp excluded-address 192.168.1.1
!
ip dhcp pool LAN_POOL
   network 192.168.1.0 255.255.255.0
   default-router 192.168.1.1
!
ip cef
ip name-server 8.8.8.8
no ipv6 cef
!
multilink bundle-name authenticated
!
vtp mode transparent
!
vlan 10
 name Ross
!
vlan 99
 name MY_DATA
!
interface FastEthernet0
 switchport access vlan 99
!
interface FastEthernet1
 switchport access vlan 10
!
interface FastEthernet2
 switchport access vlan 10
!
interface FastEthernet3
 switchport access vlan 10
!
interface Vlan1
 no ip address
!
interface Vlan10
 description INSIDE_VLAN
 ip address 192.168.1.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
!
interface Vlan99
 description OUTSIDE_VLAN
 ip address dhcp client-id Vlan99
 ip nat outside
 ip virtual-reassembly
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip nat inside source list 1 interface Vlan99 overload
ip route 0.0.0.0 0.0.0.0 dhcp
!
access-list 1 permit 192.168.1.0 0.0.0.255
!
!
control-plane
!
!
line con 0
 no modem enable
line aux 0
line vty 0 4
 login
 transport input all
!
end

 

Thanks,

Ross

1 ACCEPTED SOLUTION

Accepted Solutions
VIP Purple

Hi Ross,Keep a backup of your

Hi Ross,

Keep a backup of your AP config (if needed) & try below. Let us know if that works

 

1. Erase the configuration & reload the AP

ap#erase startup-config

Erasing the nvram filesystem will remove all configuration files! Continue? [confirm]

[OK]

Erase of nvram: complete

AP#reload

2. Apply the below configuration. Make sure you add the correct password  instead of <SSID_PASSWORD> section below.

conf t
hostname AP01
!
dot11 ssid Ross
   authentication open
   authentication key-management wpa version 2
   guest-mode
   wpa-psk ascii <SSID_PASSWORD>
!
interface Dot11Radio0
 encryption mode ciphers aes-ccm
 ssid Ross
 no shutdown
!
interface BVI1
 ip address dhcp
!
end
write memory

HTH

Rasika

**** Pls rate all useful responses ****

3 REPLIES
VIP Purple

Hi Ross,Keep a backup of your

Hi Ross,

Keep a backup of your AP config (if needed) & try below. Let us know if that works

 

1. Erase the configuration & reload the AP

ap#erase startup-config

Erasing the nvram filesystem will remove all configuration files! Continue? [confirm]

[OK]

Erase of nvram: complete

AP#reload

2. Apply the below configuration. Make sure you add the correct password  instead of <SSID_PASSWORD> section below.

conf t
hostname AP01
!
dot11 ssid Ross
   authentication open
   authentication key-management wpa version 2
   guest-mode
   wpa-psk ascii <SSID_PASSWORD>
!
interface Dot11Radio0
 encryption mode ciphers aes-ccm
 ssid Ross
 no shutdown
!
interface BVI1
 ip address dhcp
!
end
write memory

HTH

Rasika

**** Pls rate all useful responses ****

New Member

Yes that worked! I just

Yes that worked! I just assumed that because the DHCP pool was on VLAN 10 and needed the set that up on the access point, (First time touching an AP).

Thanks Rasika.

VIP Purple

Glad to see that worked.In

Glad to see that worked.

In your AP config you tried to config vlans,but port you connected in router configured it as access port. Also there were some incompatible encryption settings. That's why suggested you to have very basic & simple configuration to get it working.

HTH

Rasika

54
Views
0
Helpful
3
Replies
CreatePlease login to create content