Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Layer 2 connectivity problem AP 2602, empty mac-address table.

Hi!

I'm having some trouble configuring an

Cisco Aironet 2602 (Cisco AIR-SAP2602I-E-K9) in autonomous mode.

My setup looks like this.

AP is connected via Gigabitethernet 0 to a cisco switch (POE injector) and the switchport on the switch is a trunk which allows vlan 1,22,666.

Layer 3 seems to be working since I can ping the default gateway on all vlans, but when I issue the command

"show bridge 22" for example, I get nothing.

Putting the radio-part aside for now since that was working, I got so far that I was granted full access in our radius server (NPS) but after that I didn't get anywhere on our "Wlan_Employee" network which uses EAP to authenticate.

We also have a "Wlan_Guest" (666) which actually worked for some time, although only on my phone, not PC recieved an IP address.

But back to the main issue.

This is what I've tried so far.

*Used a power brick instead of POE injector, didn't do anything.

*Switched cables and patch panels

*Tried another switch port

Tried another switch

*Tried another AP

*Tried 3 different firmware versions

*Probably a lot of other stuff I can't remember right now.

Here's what the config looks like (no radio config in this right now since I redid the AP from scratch)

When I issue the command

"show bridge" is totally empty.

The thing is that we have an Aironet 1140 and the config is almost identical and when I issue show bridge there I see a lot of mac addresses on all vlans, mainly 22.

I had a colleague look into this as well and we can't find out what's wrong, any ideas?

I'm know I'm missing a lot of information, but just ask away and I'll  try to answer if that's the case.

version 15.2

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname AP-K023-2

!

logging rate-limit console 9

enable secret 5 $1$kYi.$a/huSdHpHygjaWt4uSAfB1

!

aaa new-model

!

!

aaa group server radius rad_eap

server 192.168.187.253

!

aaa authentication login default local

aaa authorization exec default local

!

!

!

!

!

aaa session-id common

no ip routing

ip domain name grycksbo.local

!

!

ip dhcp-server 192.168.186.129

ip dhcp-server 192.168.187.196

dot11 syslog

crypto pki token default removal timeout 0

!

crypto pki trustpoint TP-self-signed-2456856181

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-2456856181

revocation-check none

rsakeypair TP-self-signed-2456856181

!

!

crypto pki certificate chain TP-self-signed-2456856181

certificate self-signed 01

  3082022B 30820194 A0030201 02020101 300D0609 2A864886 F70D0101 05050030

  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274

  69666963 6174652D 32343536 38353631 3831301E 170D3134 30313136 31303133

  31345A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649

  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D32 34353638

  35363138 3130819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281

  81009F4D 234F521D 161F00D7 05757DF1 DEC8F9D3 1C7488BC 36AD3014 6E8EFDB0

  AE60B0D6 E66F4643 DC129172 1FE4D850 CBC16898 21A0B756 4F949A10 C6518B77

  B8C25F4C 36778CB3 76303EE9 64918678 4576B2CD F3C1901B 9670E39A 370D5C23

  D09A75A5 625426D6 50DFFEC7 E6226AC1 A63D80AA 89479151 8A076983 3F598CB0

  098F0203 010001A3 53305130 0F060355 1D130101 FF040530 030101FF 301F0603

  551D2304 18301680 14335D97 F56C1617 6F838EFE 36CA8178 1C0A4318 6D301D06

  03551D0E 04160414 335D97F5 6C16176F 838EFE36 CA81781C 0A43186D 300D0609

  2A864886 F70D0101 05050003 81810088 D9F3FAD4 D20580D8 9A71AE69 B6597224

  724F130B 1BD73079 379DFD7E BE0B4100 1F873714 A046F004 6F76A9D9 1F67A591

  D6011908 7D41B281 2CB71E96 80011F10 31881886 88D9D529 905A92E7 134CA4E1

  F2F3E240 C137E8A7 7493F640 6A51923E BD73F70F 289A63E9 78A89270 595DB3C0

  E3E20BE0 26A0E5E4 31E707BB F0898B

        quit

!

!

bridge irb

!

!

interface Dot11Radio0

no ip address

no ip route-cache

shutdown

antenna gain 0

station-role root

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 spanning-disabled

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

!

interface Dot11Radio1

no ip address

no ip route-cache

shutdown

antenna gain 0

no dfs band block

channel dfs

station-role root

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 spanning-disabled

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

!

interface GigabitEthernet0

no ip address

no ip route-cache

duplex auto

speed auto

!

interface GigabitEthernet0.1

encapsulation dot1Q 1 native

no ip route-cache

bridge-group 1

bridge-group 1 spanning-disabled

no bridge-group 1 source-learning

!

interface GigabitEthernet0.22

encapsulation dot1Q 22

no ip route-cache

bridge-group 22

bridge-group 22 spanning-disabled

no bridge-group 22 source-learning

!        

interface GigabitEthernet0.666

encapsulation dot1Q 666

no ip route-cache

bridge-group 255

bridge-group 255 spanning-disabled

no bridge-group 255 source-learning

!

interface BVI1

ip address 192.168.99.181 255.255.255.0

no ip route-cache

!

ip default-gateway 192.168.99.1

ip http server

ip http authentication local

ip http secure-server

ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag

logging 192.168.187.233

!

radius server rad_eap

!

bridge 1 route ip

!

!

line con 0

line vty 0 4

transport input all

!

sntp server 192.168.187.252

end

11 REPLIES
VIP Purple

Re: Layer 2 connectivity problem AP 2602, empty mac-address tabl

HI Martin,

which IOS u r running on AP 2602 ?

and which IOS on Aironet 1140 AP ?

Reagrds

New Member

Layer 2 connectivity problem AP 2602, empty mac-address table.

The 1140 is currently on

Cisco IOS Software, C1140 Software (C1140-K9W7-M), Version 12.4(21a)JA1, RELEASE SOFTWARE (fc1)

and the 2602 is running

Cisco IOS Software, C3600 Software (AP3G2-K9W7-M), Version 15.2(2)JA1, RELEASE SOFTWARE (fc1)

I've tried these as well

ap3g2-k9w7-tar.152-4.JA1

ap3g2-k9w7-tar.152-4.JB3a

/Martin

VIP Purple

Re: Layer 2 connectivity problem AP 2602, empty mac-address tabl

HI Martin,

I feel the command is : show bridge-group 22

Show dot11 associations all --> to check details of associated clients.

what exactly you want to see on Access Point ?

Regards

New Member

Re: Layer 2 connectivity problem AP 2602, empty mac-address tabl

No, the command is show bridge (bridge group number).

Here's an output from the 1140.

AP-K023-1#show bridge

Total of 300 station blocks, 190 free

Codes: P - permanent, S - self

Bridge Group 1:

    Address       Action   Interface       Age   RX count   TX count

24b6.57c7.ca17   forward   Gi0.1           148       9484          0

Bridge Group 22:

fc28.000d.0000   forward   Gi0.22          146        168          0

0021.5a1c.5d5d   forward   Gi0.22          146         25          0

24be.051f.c5c1   forward   Gi0.22            2         34          0

e411.5b4b.0305   forward   Gi0.22          148        687          0

0021.5a8a.eae5   forward   Gi0.22          148        116          0

80c1.6ee9.fee7   forward   Gi0.22          146         60          0

e839.3558.fae6   forward   Gi0.22          139         45          0

0025.b311.bd9d   forward   Gi0.22          117         27          0

0016.35a3.6a4a   forward   Gi0.22          148         28          0

000e.7ff7.3f1e   forward   Gi0.22          139         30          0

0023.240b.e8cb   forward   Gi0.22           70         23          0

88ae.1daa.436a   forward   Gi0.22          141         36          0

78e3.b5a1.b59e   forward   Gi0.22          145         62          0

2c41.389d.c4ea   forward   Gi0.22          145         45          0

000e.7ff7.4070   forward   Gi0.22          148         35          0

000f.fe98.4978   forward   Gi0.22          139         25          0

0008.9bbb.5667   forward   Gi0.22          147        306          0

0016.35a3.9ba9   forward   Gi0.22          142         35          0

0021.6a39.0432   forward   Do0.22           P         306        302

80c1.6ee0.91af   forward   Gi0.22          123         18          0

80c1.6eeb.6527   forward   Gi0.22          146         55          0

0016.d49d.f5b3   forward   Gi0.22          144         67          0

0016.35a3.b0f6   forward   Gi0.22          148         28          0

0021.5ac1.410e   forward   Gi0.22          146         48          0

00c0.ee28.e2b2   forward   Gi0.22          148        453          0

0011.0af9.4415   forward   Gi0.22          134          7          0

0024.8107.3064   forward   Gi0.22           74         16          0

2c41.389c.88df   forward   Gi0.22          147         69          0

e411.5b4b.6039   forward   Gi0.22          124        403          0

0023.240b.e8b4   forward   Gi0.22          142         60          0

2c41.3898.6538   forward   Gi0.22          148         60          0

78e3.b592.b4ea   forward   Gi0.22          138         15          0

2c41.3898.653a   forward   Gi0.22          148        459          0

000f.fefb.4524   forward   Gi0.22          111         35          0

0011.85fb.b2d3   forward   Gi0.22          146          7          0

001c.c427.7f12   forward   Gi0.22          147         31          0

0008.9bbb.5639   forward   Gi0.22          139         26          0

0021.5a87.2847   forward   Gi0.22          145        116          0

0008.9bbb.5627   forward   Gi0.22          142       2547          0

18a9.052e.6d19   forward   Gi0.22          116         22          0

001c.c426.e99c   forward   Gi0.22          142         24          0

b499.baf3.2a56   forward   Gi0.22          145        384          0

0023.240e.1f61   forward   Gi0.22          129         36          0

e411.5bf8.f574   forward   Gi0.22          145        670          0

000f.fef4.b735   forward   Gi0.22          147         70          0

1060.4b63.5ad2   forward   Gi0.22           79         20          0

0016.35a5.1281   forward   Gi0.22          148        137          0

1060.4b63.5acd   forward   Gi0.22           80         16          0

1060.4b64.9e3f   forward   Gi0.22          145         80          0

0023.240b.eb4d   forward   Gi0.22          146         66          0

    Address       Action   Interface       Age   RX count   TX count

0025.b312.c16a   forward   Gi0.22          102         78          0

0016.d44b.de75   forward   Gi0.22          148         50          0

0003.2d07.44ea   forward   Gi0.22          142       2666          0

0023.240b.eb59   forward   Gi0.22           64         45          0

6c62.6dd6.03b0   forward   Gi0.22          117         11          0

0017.a4f2.e152   forward   Gi0.22          139         30          0

0021.5a1c.5ce5   forward   Gi0.22          144         27          0

0023.240a.be05   forward   Gi0.22           66        103          0

0023.240b.eb50   forward   Gi0.22          124         17          0

0016.35a3.59e2   forward   Gi0.22          140         16          0

0023.240b.e855   forward   Gi0.22          111         38          0

a0b3.cc26.e05f   forward   Gi0.22          146        339          0

6c62.6dd6.03c0   forward   Gi0.22           73          8          0

2c41.389c.8645   forward   Gi0.22          146         60          0

0025.b314.814b   forward   Gi0.22          142         24          0

0023.240b.eb26   forward   Gi0.22          147         58          0

001e.ec84.da0a   forward   Gi0.22          145        475          0

0023.240b.eb39   forward   Gi0.22          144         70          0

1060.4b64.9e4d   forward   Gi0.22           64          7          0

001e.0bab.f625   forward   Gi0.22          137         42          0

1060.4b64.9e4a   forward   Gi0.22          141         47          0

1060.4b64.9e46   forward   Gi0.22          141         21          0

1060.4b64.9e44   forward   Gi0.22          148         63          0

0024.81a0.06dd   forward   Gi0.22          148         64          0

18a9.0549.2ff3   forward   Gi0.22          148        732          0

24b6.57c7.ca17   forward   Gi0.22          146       4692        302

0008.9bbb.56b5   forward   Gi0.22          142       2546          0

0021.5ac0.c122   forward   Gi0.22          147         30          0

2c59.e500.1afe   forward   Gi0.22          141        448          0

80c1.6ef1.8660   forward   Gi0.22          147         46          0

24be.051c.10fb   forward   Gi0.22          114         23          0

24be.051c.10fd   forward   Gi0.22          133        299          0

24be.051c.10ff   forward   Gi0.22           46         21          0

0011.0afa.f303   forward   Gi0.22          129          7          0

e41f.1396.6796   forward   Gi0.22           27          1          0

1060.4b64.9e6c   forward   Gi0.22          138         25          0

0024.8196.1def   forward   Gi0.22          142       2547          0

0008.9bbb.56a4   forward   Gi0.22          142       2549          0

001b.78ac.37c4   forward   Gi0.22           43         73          0

0030.5e04.00f4   forward   Gi0.22           27          1          0

001e.0b40.07f1   forward   Gi0.22          136         24          0

0025.b314.c136   forward   Gi0.22          148         25          0

0023.240b.eb13   forward   Gi0.22          143         46          0

0030.5e04.00f9   forward   Gi0.22           27          1          0

0023.240b.e812   forward   Gi0.22           24         20          0

Bridge Group 23:

fc28.000d.0000   forward   Gi0.23          147        232      49532

001e.0b34.011d   forward   Gi0.23          147         26          0

0023.240b.eabe   forward   Gi0.23          140         54          0

0024.d785.b120   forward   Do0.23           P       53687      59082

1060.4b65.b11e   forward   Gi0.23          140         48          0

0015.5dba.b201   forward   Gi0.23          147         88          0

f0de.f13e.c21b   forward   Gi0.23            5        336          0

24b6.57c7.ca17   forward   Gi0.23          147       4594        185

Bridge Group 255:

581f.aa1c.0b06   forward   Do0.666          P         283        184

2064.3245.f2d7   forward   Do0.666          P        1433        954

7081.05c2.9cbb   forward   Gi0.666         147      17491      18127

    Address       Action   Interface       Age   RX count   TX count

7081.05c2.9c0d   forward   Gi0.666          50         15          0

708d.0956.ee58   forward   Do1.666          P         592        539

24b6.57c7.ca17   forward   Gi0.666         146       5053        506

AP-K023-1#

and here's from the 2602

AP-K023-2#show bridge

Total of 300 station blocks, 300 free

Codes: P - permanent, S - self

Bridge Group 1:

Bridge Group 22:

Bridge Group 255:

AP-K023-2#

I don't know what's up but no mac addresses are coming in on either vlan on the 2602.

This has to be the core issue because I can get the Wlans up and running but once connected I get nowhere.

VIP Purple

Re: Layer 2 connectivity problem AP 2602, empty mac-address tabl

Hi,

Martin Ostberg wrote:

No, the command is show bridge (bridge group number).

Here's an output from the 1140.

AP-K023-1#show bridge 


Total of 300 station blocks, 190 free
Codes: P - permanent, S - self


Bridge Group 1:

----------------------------------------------------------------
AP-K023-2#show bridge 


Total of 300 station blocks, 300 free
Codes: P - permanent, S - self


Bridge Group 1:


Bridge Group 22:


Bridge Group 255:


AP-K023-2#

As per my knowledge, you dont have any client connection with this AP.

Regards

Re: Layer 2 connectivity problem AP 2602, empty mac-address tabl

What is the config on the port the AP is connected to?

HTH,
Steve

------------------------------------------------------------------------------------------------
Please remember to rate useful posts, and mark questions as answered

HTH, Steve ------------------------------------------------------------------------------------------------ Please remember to rate useful posts, and mark questions as answered
New Member

Re: Layer 2 connectivity problem AP 2602, empty mac-address tabl

switchport trunk allowed vlan 1,22,666

switchport mode trunk

spanning-tree portfast trunk

Hall of Fame Super Silver

Re: Layer 2 connectivity problem AP 2602, empty mac-address tabl

Check to see if spanning-tree is forwarding or blocking in the switch port. You do need clients associated to an SSID also that is assigned to VLAN 22. Can you just configure the AP and try associating a client just to see again.

Sent from Cisco Technical Support iPhone App

-Scott
*** Please rate helpful posts ***
New Member

Re: Layer 2 connectivity problem AP 2602, empty mac-address tabl

spanning tree is not blocking the port, it's in forwarding state. I can access the AP just fine.

Hall of Fame Super Silver

Re: Layer 2 connectivity problem AP 2602, empty mac-address tabl

Is Vlan 22 in a forwarding state? Access to the AP is in Vlan 1 which is the native Vlan. The question you had was for Vlan 22. This is what we need to look at.

Sent from Cisco Technical Support iPhone App

-Scott
*** Please rate helpful posts ***
New Member

Re: Layer 2 connectivity problem AP 2602, empty mac-address tabl

Sorry: I ment that it is in forwarding state on all vlans.

Vlan                Role Sts Cost      Prio.Nbr Type

------------------- ---- --- --------- -------- --------------------------------

VLAN0001            Desg FWD 20000     128.17   P2p Edge

VLAN0022            Desg FWD 20000     128.17   P2p Edge

VLAN0666            Desg FWD 20000     128.17   P2p Edge

/Martin

983
Views
0
Helpful
11
Replies