Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

poz
New Member

LWAPP switch port configuration

Ok, I have seen some lwapp configurations threads that describe the switch port conifg but not in detail. What is the recommended port configuration for an LWAPP? the macro-wireless is still active in the latest IOS versions buth the recommended website: http://www.cisco.com/web/go/smartports/index.html link is broken. is there a macro for LWAPP? should you enable port secuirty on an LWAPP port? is this a good idea? I know the basic config is any vlan that is routed to WLC I used the example at : http://www.cisco.com/application/pdf/paws/69719/wlc_lwap_config.pdf

Im looking for Cisco recommended best practices info for port configuration ont 3750 advip, any help is appreciated

1 REPLY

Re: LWAPP switch port configuration

The smartport macro is for an autonomous AP

If you do a "show parser macro" you will see the definitions for all the built-in macros

here is the wireless one

--------------------------------------------------------------

Macro name : cisco-wireless

Macro type : default interface

# macro keywords $native_vlan

# Access Uplink to Distribution

switchport trunk encapsulation dot1q

# Define unique Native VLAN on trunk ports

# Recommended native vlan should NOT be 1

switchport trunk native vlan $native_vlan

# Update the allowed VLAN range such that it

# includes data, voice and native VLANs

switchport trunk allowed vlan ALL

# Hardcode trunk and disable negotiation to speed up convergence

switchport mode trunk

switchport nonegotiate

# Configure qos to trust this interface

auto qos voip trust

mls qos trust cos

# Ensure that switch devices cannot become active on the interface.

spanning-tree bpduguard enable

Here is a port config for an lwapp AP

H113#sh running-config interface gigabitEthernet 0/46

Building configuration...

Current configuration : 299 bytes

!

interface GigabitEthernet0/46

description MR1 AP

switchport access vlan 80

switchport mode access

priority-queue out

mls qos trust dscp

You can build a macro and apply it to an interface or range of interfaces

conf t

macro name LWAPP-ap

switchport access vlan 80

switchport mode access

priority-queue out

cdp enable

speed auto

duplex auto

spanning-tree portfast

spanning-tree bpdufilter enable

spanning-tree bpduguard enable

@

!

int range gi 0/12 - 15

macro apply LWAPP-AP

end

2967
Views
5
Helpful
1
Replies