Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

LWAPP will not join WiSM WLC

Hello all,

We are currently converting our WLSM infrastructure to the new WiSM and at the moment testing with several converted to LWAPP 1231AG access points.

Now we were able to successfully have both AP's join a controller (One using MIC, the other SSC) and now they both have disassociated with the controller and will not send a JOIN request.

The only thing we have done is add a new virtual VLAN interface as previously during testing, had the WLAN bind to the management interface which it defaults to if you do not create a virtual one.

Also I had enabled WPA/WPA2 security to test our client authentication via RADIUS.

I mentioned this as I noticed that when the ap's were trying to re-join the controller, they were trying to create a RSA certificate.

Anyway we disabled the RADIUS authentication to try get the ap's to join.

Seems that they do discover the controller no problems so there is activity between the controller and AP but apparantely no JOIN request is being sent or delivered.

We are also using DHCP to send the AP's the controller information.

Here are samples of what is happening on the AP and controller:-

*Mar 1 00:00:06.447: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0, changed state to up

*Mar 1 00:00:23.550: %LWAPP-5-CHANGED: LWAPP changed state to DISCOVERY

*Mar 1 00:00:23.579: SSC Load Current Size crypto_mykey 116, offset 9376, Saved Size soap_cert_crypto_mykey 124

*Mar 1 00:00:35.694: %DHCP-6-ADDRESS_ASSIGN: Interface FastEthernet0 assigned DHCP address 10.22.0.245, mask 255.255.0.0, hostname AP0011.9206.9b4a

Translating "CISCO-LWAPP-CONTROLLER.bowdoin.edu"...domain server (139.140.226.20) (139.140.226.21)

*Mar 1 00:00:48.158: LWAPP_CLIENT_ERROR: lwapp_name_lookup - Could Not resolve CISCO-LWAPP-CONTROLLER.bowdoin.edu

*Mar 1 00:01:03.194: LWAPP_CLIENT_ERROR_DEBUG: spamHandleJoinTimer: Did not recieve the Join response

*Mar 1 00:01:03.194: LWAPP_CLIENT_ERROR_DEBUG: No more AP manager IP addresses remain.

*Mar 1 00:01:08.230: LWAPP_CLIENT_ERROR_DEBUG: spamHandleJoinTimer: Did not recieve the Join response

*Mar 1 00:01:08.230: LWAPP_CLIENT_ERROR_DEBUG: No more AP manager IP addresses remain.

*Mar 1 00:01:08.399: %SYS-5-RELOAD: Reload requested by LWAPP CLIENT. Reload Reason: DID NOT GET JOIN RESPONSE.

*Mar 1 00:01:08.400: %LWAPP-5-CHANGED: LWAPP changed state to DOWN

And on controller:-

Sun Aug 30 15:46:01 2009: 00:1e:f7:47:7b:a6 Received LWAPP DISCOVERY

REQUEST from AP 00:1e:f7:47:7b:a6 to 00:25:84:a9:a2:8b on port '29'

Sun Aug 30 15:46:01 2009: 00:1e:f7:47:7b:a6 Successful transmission of

LWAPP Discovery Response to AP 00:1e:f7:47:7b:a6 on port 29

Sun Aug 30 15:46:01 2009: 00:1e:f7:47:7b:a6 Received LWAPP DISCOVERY

REQUEST from AP 00:1e:f7:47:7b:a6 to 00:25:84:a9:a2:8b on port '29'

Sun Aug 30 15:46:01 2009: 00:1e:f7:47:7b:a6 Successful transmission of

LWAPP Discovery Response to AP 00:1e:f7:47:7b:a6 on port 29

I had also converted one of the AP's back to autonomous mode and then back to LWAPP mode using the Cisco conversion utility and re-entered the hash key onto the controller.

Also had "debug pm pki enable" on to check for errors but absolutely nothing had been reported. Could that be because the AP's had already been associated before?

Any ideas?

Cheers,

- Trevor

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Gold

Re: LWAPP will not join WiSM WLC

Hi Trevor,

Commands and troubleshooting can be found here ...

Troubleshoot and Configure Initial Wireless Services Module (WiSM) Setup

http://www.cisco.com/en/US/products/hw/modules/ps2706/products_tech_note09186a00808330a9.shtml

Hope this helps.

9 REPLIES
Hall of Fame Super Gold

Re: LWAPP will not join WiSM WLC

Troubleshoot a Lightweight Access Point Not Joining a Wireless LAN Controller

http://www.cisco.com/en/US/products/ps6366/products_tech_note09186a00808f8599.shtml

Community Member

Re: LWAPP will not join WiSM WLC

Thanks for the link. After checking that out and still having the same issue I decided to disable the port channel config on the 4 controller ports and that allowed the AP to re-join to the controller.

Issue is now trying to figure out what happened with the port channel configuration.

We had setup 2 port channels for each controller group (port channel 11 for 1-4 and portland channel 12 for 5-8).

The port channel configuration is pretty well much according to the docs:-

interface Port-channel11

description wlc-5

switchport

switchport trunk encapsulation dot1q

switchport trunk native vlan 1001

switchport trunk allowed vlan 20,803

switchport mode trunk

no ip address

mls qos trust dscp

spanning-tree portfast

end

and the WiSM port configuration:-

1-4/5-8

switchport

switchport trunk encapsulation dot1q

switchport trunk native vlan 1001

switchport trunk allowed vlan 20,803

switchport mode trunk

no ip address

no logging event link-status

no snmp trap link-status

mls qos trust dscp

where the AP-Managment and Management vlans are on 20.

This should be fine though correct?

- Trevor

Hall of Fame Super Gold

Re: LWAPP will not join WiSM WLC

Hi Trevor,

Commands and troubleshooting can be found here ...

Troubleshoot and Configure Initial Wireless Services Module (WiSM) Setup

http://www.cisco.com/en/US/products/hw/modules/ps2706/products_tech_note09186a00808330a9.shtml

Hope this helps.

Re: LWAPP will not join WiSM WLC

That doesnt make sense... When i have this issue i flash the ap back to autonomous and tehn lwapp her again. Normally fixes the problem for me... but to bring down the channel and it corrects it ...? Odd...

"Satisfaction does not come from knowing the solution, it comes from knowing why." - Rosalind Franklin
___________________________________________________________
Hall of Fame Super Gold

Re: LWAPP will not join WiSM WLC

Hi George,

That's why I gave him the link about configuring the Sup720 because I believe he may have missed a step.

Community Member

Re: LWAPP will not join WiSM WLC

Hi,

Everything seems to have been done according to the documentation although we ended up creating new port channels rather than use the 2 that were automatically created (293 and 294) as normally you cannot use those channels higher than 255?

The other thing I noticed is that the port channel load balance is 'src-dst-port' rather than 'src-dst-ip', would that make a difference?

Cheers,

- Trevor

Community Member

Re: LWAPP will not join WiSM WLC

My bad!! I had forgotten to use the following

wism module controller 1 native-vlan

wism module controller 1 allowed-vlan native vlan id(40), vlan id1, vlan2, etc.

So now when I do a wism status on the switch I do get the native vlan id, allowed vlans etc.

Only issue now is that it seems:-

"wism module controller 1 qos-trust dscp"

is not supported on our switch (It is running IOS version 12.2(18)SXF5 though).

So attempting to enable the port channel on the wism ports report:-

"Command rejected (Port-channel11, Gi6/1): QoS attribute(s)(trust/cos/vlan-based) of Port-channel11, Gi6/1 is(are) not compatible with the port-channel"

- Trevor

Community Member

Re: LWAPP will not join WiSM WLC

Okay, seems I did not have to do anything once I used the wism module ... commands and seems we did not even need to manually create the port channel groups afterall.

I apologize for the silly questions as this is the first time working with the WiSM setup.

Thanks for the help!

Hall of Fame Super Gold

Re: LWAPP will not join WiSM WLC

Thanks for the rating Trevor. Happy to see everything is working fine.

1244
Views
0
Helpful
9
Replies
CreatePlease to create content