Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

MAC Flaps from Wireless Network

Hello everyone!

I had this topic posted to another support forum but never got a response.  So I'm posting it here:

I'm  getting MAC flap notifications from 2 switches at our remote office  from the same two switches (switch 2 & 6).  There are a total of 7  switches (5 on the first floor & 2 on the second floor).  Each  switch connects to the root bridge with no redundant links.  There are 4  access points that are autonomous with two SSIDs; 2 of the APs are  connected to switch 2 (1st floor) and the remaining two are connected to  switch 6 (second floor).  The switchport configuration is as follows  which is the same at our main campus:

interface GigabitEthernet1/0/1

description *** WIRELESS ACCESS POINT ***

switchport mode trunk

switchport nonegotiate

speed 100

duplex full

macro description cisco-wireless

spanning-tree bpduguard enable

end

At  the main campus we have a 5508 WLC with 85 LAPs and we don't have this  issue.  My assumption at this point has to do with roaming since our  therapists have to move between both floors.  What's even strange is  that I can't find the mac (0013.0210.5344) of the device causing the  flaps when I run the command 'show dot11 assoc' from my APs.  All I know  based off the MAC is that it's an Intel WNIC.  Here is the config of  one of the APs at the remote office.  How can I get to the bottom of  resolving these MAC flapping notifications?

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname pag1ap01

!

!

aaa new-model

!

!

aaa authentication login default local

aaa authorization exec default local

!

aaa session-id common

clock timezone -0500 -5

clock summer-time -0400 recurring

ip domain name <DOMAIN>

ip name-server <DNS IP>

ip name-server <DNS IP>

!

!

dot11 vlan-name default vlan 1

dot11 vlan-name dsl vlan 6

!

dot11 ssid pathwaysaironet

   vlan 1

   authentication open

!

dot11 ssid patnet

   vlan 6

   authentication open

   guest-mode

!

dot11 network-map

power inline negotiation injector 001a.6c7c.4882

power inline negotiation prestandard source

!

!

!

!

bridge irb

!

!

interface Dot11Radio0

no ip address

no ip route-cache

!

encryption vlan 6 key 1 size 40bit <KEY> transmit-key

encryption vlan 6 mode wep mandatory

!

encryption vlan 1 key 1 size 128bit <KEY> transmit-key

encryption vlan 1 mode wep mandatory

!

ssid pathwaysaironet

!

ssid patnet

!

speed  basic-1.0 basic-2.0 basic-5.5 11.0 6.0 9.0 12.0 18.0 24.0 36.0 48.0 54.0

station-role root

!

interface Dot11Radio0.1

encapsulation dot1Q 1 native

no ip route-cache

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface Dot11Radio0.6

encapsulation dot1Q 6

no ip route-cache

bridge-group 6

bridge-group 6 subscriber-loop-control

bridge-group 6 block-unknown-source

no bridge-group 6 source-learning

no bridge-group 6 unicast-flooding

bridge-group 6 spanning-disabled

!

interface FastEthernet0

no ip address

no ip route-cache

speed 100

full-duplex

!

interface FastEthernet0.1

encapsulation dot1Q 1 native

no ip route-cache

bridge-group 1

no bridge-group 1 source-learning

bridge-group 1 spanning-disabled

!

interface FastEthernet0.6

encapsulation dot1Q 6

no ip route-cache

bridge-group 6

no bridge-group 6 source-learning

bridge-group 6 spanning-disabled

!

interface BVI1

ip address <IP ADDRESS> <MASK>

no ip route-cache

!

ip default-gateway <GATEWAY IP>

ip http server

ip http authentication aaa

no ip http secure-server

ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag

snmp-server community snmpsux RO

bridge 1 route ip

!

!

!

line con 0

line vty 0 4

!

sntp server <SNTP IP>

sntp broadcast client

end

Yes,  we're not using the most secure encryption on the wireless and that'll  be changed but I need to resolve the flapping issue first.  You're help  is greatly appreciated.  Thanks!

Regards,

Terence

1 ACCEPTED SOLUTION

Accepted Solutions
Gold

Re: MAC Flaps from Wireless Network

No wonder why u have issues:-) Try setting this as 1,6,11 and 1 where first channel 1 and last channel 1 AP's are far apart physically.

Hope that helps.

Regards

Najaf
Please rate useful posts
Sent from Cisco Technical Support iPad App

12 REPLIES
Gold

Re: MAC Flaps from Wireless Network

Hi Tereace,

Is this Mac flapping causing any trouble for you?

It is very normal on switch to display this mac flapping message if APs are connected to the switch port. The reason for this is due to the fact that switch learns of a particular clients mac from one particular port to which the AP (assume this is AP01)is connected to. Now when the wireless client roam to other AP( assume AP02 which is connected on a different port of same switch where AP01 is connected) the switch will learn that same MAC address on a different port I.e AP02's port and displays the mac flap message.

If u check show dot11 asso on all AP's I'm sure that u will be able to trace the MAC address which is flapping.

Hope that helps

Regards
Najaf

Sent from Cisco Technical Support iPad App

New Member

MAC Flaps from Wireless Network

Najaf,

We have had some complaints about some wireless issues and I'm not sure if this is causing those problems.  However, other than that, the only trouble it's causing is syslog messages which isn't a technical or performance issue.  I was hoping to find out if I can configure local & client power as well as static channel assignments will fix the problem.

Regards,

Terence

Gold

Re: MAC Flaps from Wireless Network

Hi,

As far as I have seen so far this doesn't create any performance issue with wireless. I agree that this will generate syslog message which is not much relevant.

What sort of wireless issue has been reported from the site? Most likely the issues would have been caused by channel inference but it will be difficult to say it for sure unless u perform a site survey.

Regards

Najaf

Sent from Cisco Technical Support iPad App

New Member

MAC Flaps from Wireless Network

Today was the first day I was able to get over to this office and perform a quick site survey.  From my findings it looks like channel interference may be the cause of complaints about drops, etc.  I'm going to set the channel assignments manually and set the AP/Client local power and see if that helps.

Gold

Re: MAC Flaps from Wireless Network

Hi,

This are autonomous AP's right? Are they not using manual channel assignment now?.

Regards

Najaf

Sent from Cisco Technical Support iPad App

New Member

MAC Flaps from Wireless Network

Based on that running config of one of those autonomous APs I posted they're not manually set.

Gold

Re: MAC Flaps from Wireless Network

Running config mostly likely will not show you the channel setting I would assume. You could check what channels AP's are running with show cont dot110 and verify is they are on non overlapping channels.

Regards
Najaf

Sent from Cisco Technical Support iPad App

New Member

MAC Flaps from Wireless Network

They are definitely overlapping.  They are within the 10-20% overlap range of where they're physically placed and the channels are currently 1, 3, 7, and 9.

Gold

Re: MAC Flaps from Wireless Network

No wonder why u have issues:-) Try setting this as 1,6,11 and 1 where first channel 1 and last channel 1 AP's are far apart physically.

Hope that helps.

Regards

Najaf
Please rate useful posts
Sent from Cisco Technical Support iPad App

New Member

MAC Flaps from Wireless Network

Actually,

I've just done that before you replied.  I'm gonna conduct a quick site survey and see what happens but I think this will resolve most, if not, all the issues.  Thanks!

Gold

Re: MAC Flaps from Wireless Network

Thanks for using the rating...

Let us hope for the best with your wireless issues :-)

Regards

Najaf

Sent from Cisco Technical Support iPad App

Re: MAC Flaps from Wireless Network

Terence,

To avoid channel interference keep same channel aps atleast 20dBm apart. That means take a laptop with softwear that reads dBm, not bars. Stand next to your AP on channel 1. Say you get a 50 dBm (RSSI). Your next ap you hear in that same channel should be at 70 dBm (RSSI).

Make sense?

__________________________________________________________________________________________
"Satisfaction does not come from knowing the solution, it comes from knowing why." - Rosalind Franklin
__________________________________________________________________________________________
‎"I'm in a serious relationship with my Wi-Fi. You could say we have a connection."

__________________________________________________________________________________________ "Satisfaction does not come from knowing the solution, it comes from knowing why." - Rosalind Franklin ___________________________________________________________
605
Views
0
Helpful
12
Replies