Cisco Support Community
Community Member

Missing "config" command in CLI (Cisco 1140 AP)

Hi All

I am trying to chang IP configuraton for my Cisco 1140 AP, but in CLI I dont have a "config" command (i used en before to enable administrative mode)

Bellow are the commands I can see:


Exec commands:

  cd               Change current directory

  clear            Reset functions

  clock            Manage the system clock

  crypto           Encryption related commands.

  debug            Debugging functions (see also 'undebug')

  delete           Delete a file

  dir              List files on a filesystem

  disable          Turn off privileged commands

  enable           Turn on privileged commands

  exit             Exit from the EXEC

  fsck             Fsck a filesystem

  help             Description of the interactive help system

  led              LED functions

  lock             Lock the terminal

  login            Log in as a particular user

  logout           Exit from the EXEC

  lwapp            lwapp exec commands

  mkdir            Create new directory

  monitor          Monitoring different system events

  more             Display the contents of a file

  name-connection  Name an existing network connection

  no               Disable debugging functions

  ping             Send echo messages

  pwd              Display current working directory

  release          Release a resource

  reload           Halt and perform a cold restart

  rename           Rename a file

  renew            Renew a resource

  rmdir            Remove existing directory

  send             Send a message to other tty lines

  set              Set system parameter (not config)

  show             Show running system information

  systat           Display information about terminal lines

  terminal         Set terminal line parameters

  test             Test subsystems, memory, and interfaces

  traceroute       Trace route to destination

  undebug          Disable debugging functions (see also 'debug')

  upgrade          Upgrade software

  verify           Verify a file

  where            List active connections

In addition, I am keep getting the following messages:

*Mar  1 00:38:13.933: %CAPWAP-3-ERRORLOG: Not sending discovery request AP does not have an Ip !!

*Mar  1 00:38:23.883: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0, changed state to up

I am not sure what I am doing wrong. I try to do a hard reset but it didnt work.

Any ideas?


Accepted Solutions
Hall of Fame Super Silver

Missing "config" command in CLI (Cisco 1140 AP)

You need to convert that lwapp ap to ios. Here are the instructions.

*** Please rate helpful posts ***

Missing "config" command in CLI (Cisco 1140 AP)

promt is indicating it is on Light waight mode . in this mode conf t will not work . for configuration of ip and gateway and contrller below is command

lwap ap ip add X.X.X.X X.X.X.X

lwap ap ip default-gateway X.X.X.X

lwap ap controller ip add X.X.X.X

lwap ap hostname XXXX


Posted by WebUser Prakash Bharadwaj from Cisco Support Community App

Community Member

Missing "config" command in CLI (Cisco 1140 AP)

Thanks for the quick response.

What is light waight moe?

How can I switch to regular mode?

Hall of Fame Super Silver

Missing "config" command in CLI (Cisco 1140 AP)

You need to convert that lwapp ap to ios. Here are the instructions.

*** Please rate helpful posts ***
Community Member

Missing "config" command in CLI (Cisco 1140 AP)


Another queastion:

I verified that my AP is Lightweight by the part id (AIR-LAP1141N)

Now, when I browse to Cisco download page, I have 3 options for OS:

- Autonomous AP IOS Software

- IOS Boot Images

- IOS Software

- Lightweight AP IOS Software

Which of the above should I use in order to switch the AP to regular mode?

Does anyone knows what is the difference between IOS software and the Autonomous IOS software?





Community Member

I Have the same problem I

I Have the same problem I order a Cisco  AIR-LAP1141N) keep getting an error config t

any help

Hall of Fame Super Silver

Re: Missing "config" command in CLI (Cisco 1140 AP)

What you need is the Autonomous AP IOS Software. Then follow the instructions I posted earlier on how to tftp that to the AP. Make sure to disable your firewall on your computer so that the transfer does not fail.

Sent from Cisco Technical Support iPhone App

*** Please rate helpful posts ***
CreatePlease to create content