Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Need help with IOS commands to see wireless printer

Seems that I'm not asking the question correctly, or providing the right information.

The problem:

I've purchased a wireless printer, (an HP 6500a) and I can not see / ping / use the printer on the wireless network.

Environment:

Cisco 891 ISR in standalone. Single office - Home-office environment. Nothing spectacular. WLAN connected and operational to the internet.

The printer is configured to use a static IP of 10.0.0.3 and reports that it is connected to the AP. However, when I ping FROM the command line at the AP, I DO NOT see the printer. (I did previously, but we lost power last night due to a storm and I'm still trying to reconfigure it...) DHCP is configured on the router to exclude the range 10.0.0.1 through 10.0.0.99

How do I configure the wireless router to allow any connected client to share files / printers etc? Seems that the Cisco router has this shut off

by default and I've found nothing in the user manual or by asking for help on here how to reverse this so that I can share printers / files on the LAN.

Please, I'm not stupid, but I'm only casually familiar with IOS and Cisco's networking terms.

Thanks in advance,

-Mike

=============== Begin Wiresless AP config (running-config) ==============

Current configuration : 3122 bytes

!

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname (Remnoved)

!

enable secret 5 (Removed)

!

no aaa new-model

!

!

dot11 syslog

!

dot11 ssid (Removed)

   vlan 1

   authentication open

   authentication key-management wpa

   mbssid guest-mode

   wpa-psk ascii 0 (Removed)

!

!

!

username (removed)

username (Removed)

!

!

bridge irb

!

!

interface Dot11Radio0

no ip address

no ip route-cache

!

encryption vlan 1 mode ciphers tkip

!

broadcast-key vlan 1 change 30

!

!

ssid (Removed)

!

antenna gain 0

station-role root

!

interface Dot11Radio0.1

encapsulation dot1Q 1 native

no ip route-cache

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface Dot11Radio1

no ip address

no ip route-cache

!

encryption vlan 1 mode ciphers tkip

!

broadcast-key vlan 1 change 30

!

!

ssid (Removed)

!

antenna gain 0

dfs band 3 block

channel dfs

station-role root

!

interface Dot11Radio1.1

encapsulation dot1Q 1 native

no ip route-cache

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface GigabitEthernet0

description the embedded AP GigabitEthernet 0 is an internal interface connecting AP with the host router

no ip address

no ip route-cache

!

interface GigabitEthernet0.1

encapsulation dot1Q 1 native

no ip route-cache

bridge-group 1

no bridge-group 1 source-learning

bridge-group 1 spanning-disabled

!

interface BVI1

ip address dhcp client-id GigabitEthernet0

no ip route-cache

!

ip http server

no ip http secure-server

ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag

access-list 110 permit icmp any any echo

access-list 110 permit icmp any any echo-reply

access-list 110 permit icmp any any source-quench

access-list 110 permit icmp any any packet-too-big

access-list 110 permit icmp any any time-exceeded

bridge 1 route ip

!

!

banner login ^CC

% Password change notice.

-----------------------------------------------------------------------

Default username/password setup on AP is cisco/cisco with privilege level 15.

It is strongly suggested that you create a new username with privilege level

15 using the following command for console security.

username <myuser> privilege 15 secret 0 <mypassword>

no username cisco

Replace <myuser> and <mypassword> with the username and password you want to

use. After you change your username/password you can turn off this message

by configuring  "no banner login" and "no banner exec" in privileged mode.

-----------------------------------------------------------------------

^C

!

line con 0

privilege level 15

login local

no activation-character

line vty 0 4

login local

!

cns dhcp

end

4 REPLIES
Hall of Fame Super Silver

Re: Need help with IOS commands to see wireless printer

Can you tell us what ap you have. Can you post your config of the router and ap?

Thanks,

Scott Fella

Sent from my iPhone

-Scott
*** Please rate helpful posts ***
Hall of Fame Super Silver

Re: Need help with IOS commands to see wireless printer

Sorry... My phone didn't show the whole thread do I didn't see your ap config. Is your wireless users working okay except they can't file share?

Sent from Cisco Technical Support iPhone App

-Scott
*** Please rate helpful posts ***
New Member

Re: Need help with IOS commands to see wireless printer

Wireless clients can get on w/o issue. Nobody can ping anyone else or see them.

No file sharing, no printer.

Tried using the web-based config which works for some items, but wont access the advanced config.

I'm on my way into town, so can't post the router config, but it is posted in my earlier question

of last week. I can login later if you otherwise need it here.

Thanks,

-Mike

Re: Need help with IOS commands to see wireless printer

you're not blocking anything so the clients should be able to see each other. 

show dot11 associations

will show you the clients that are connected to the AP

Steve

HTH, Steve ------------------------------------------------------------------------------------------------ Please remember to rate useful posts, and mark questions as answered
381
Views
0
Helpful
4
Replies
CreatePlease to create content