Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

New LWAPP APs do not join WLCs any more

Dear all,

We have two WLC 4402 controllers and plenty of LWAPP access points. Recently new LWAPP access points do not join the WLCs though there are valid licenses available. It seems like this happened after upgrading the WLCs from version 4.0.179.8 to 5.2.157.0. Access points model is AIR-LAP1242AG-E-K9 running LWAPP image version 3.0.51.0.

Unfortunately Cisco support for our WLCs has ended some time ago, otherwise we would have updated the WLCs to newest release 7.0.240.0 like described in this thread: https://supportforums.cisco.com/thread/2042708

What we did is setting the IP address, netmask, default gateway and primary controller for CAPWAP and LWAPP statically at the new APs. This was also needed before because APs and WLCs are in different networks and cannot find each other otherwise. Further we set AP date and time via clock set, but for security reason this is not written to ROM and therefore lost after every reboot.

Ping requests are successful from AP to WLC as well as from WLC to AP. Nevertheless access point's console shows the following error message every few seconds:

"Jul 22 17:57:50.354: %CAPWAP-3-ERRORLOG: Could Not resolve CISCO-CAPWAP-CONTROLLER

Translating "CISCO-LWAPP-CONTROLLER"...domain server (255.255.255.255)"

What else can we do? Thanks a lot for your help!

5 REPLIES
Hall of Fame Super Gold

New LWAPP APs do not join WLCs any more

after upgrading the WLCs from version 4.0.179.8 to 5.2.157.0

I would downgrade the firmware back to 4.0.X as the firmware version 5..X is considered as THE MOST BUGGY firmware version for WLC.

Can you post the output to the following commands:

1.  WLC:  sh sysinfo;

2.  WLC:  sh time;

3.  AP:  sh version;

4.  AP:  sh inventory; and

5.  AP:  sh ip int brief

Cisco Employee

New LWAPP APs do not join WLCs any more

Please go through the below link it will help you to troubleshoot the issue

http://www.cisco.com/en/US/products/ps6366/products_tech_note09186a00808f8599.shtml

New LWAPP APs do not join WLCs any more

What does nslookup report as the answer to the question:

nslookup cisco-capwap-controller ?  it would appear from the console log the it returns nothing..

New Member

Re: New LWAPP APs do not join WLCs any more

Dear all,

thanks a lot for your help. I enabled debug mode on access point and wireless controller now. The WLC receives a LWAPP discovery request and responds, but then there are problems with the join request. The WLC complains that AP is not registering with BASE MAC. Therefore I have added its MAC address in AP Policies and accepted SSC, MIC and LSC temporary, but unfortunately nothing changed. The command "sh inv" on the AP shows nothing for some reason. Further I still haven't found a solution to set the right date and time for the  AP.

Do you have any ideas how to solve this issue? Thanks so much!

AP:

*Nov  4 04:04:17.614: LWAPP_CLIENT_EVENT: spamResolveStaticGateway  - gateway found

*Nov  4 04:04:17.614: UDP: sent src=192.168.10.30(48270), dst=192.168.1.10(5246), length=125

*Nov  4 04:04:17.615: LWAPP_CLIENT_EVENT: spamSendDiscoveryRequest: sending discovery type 1 to 192.168.1.10

*Nov  4 04:04:17.615: UDP: sent src=192.168.10.30(52366), dst=192.168.1.10(12223), length=118

*Nov  4 04:04:17.616: UDP: sent src=192.168.10.30(48270), dst=255.255.255.255(5246), length=125

WLC:

*Jul  24 12:54:37.624: 70:ca:9b:5d:c9:ee Received LWAPP  DISCOVERY REQUEST  from AP 70:ca:9b:5d:c9:ee to 00:18:73:39:40:46 on  port '29'

*Jul 24 12:54:37.624: Received a packet which is a (type = DISCOVERY_REQUEST) with session id 0

*Jul 24 12:54:37.624: Join Priority Processing status = 0, Incoming Ap's Priority 1, MaxLrads = 25,joined Aps =19

*Jul 24 12:54:37.624: 70:ca:9b:5d:c9:ee Successful transmission of LWAPP Discovery Response to AP 70:ca:9b:5d:c9:ee on port 29

*Jul 24 12:55:05.620: 70:ca:9b:5d:c9:ee AP not registering with BASE MAC.

*Jul 24 12:55:05.620: Failed to parse CAPWAP packet from 192.168.10.30:48270

*Jul 24 12:55:05.620: Failed to process packet from 192.168.10.30:48270

Hall of Fame Super Gold

New LWAPP APs do not join WLCs any more

Do you have any ideas how to solve this issue?

Let me phrase it this way:  If you do get the chance to open a TAC Case and tell TAC that the issues happen "after upgrading the WLCs from version 4.0.179.8 to 5.2.157.0", strong chance the first thing TAC will tell you is STAY AWAY from firmware 5.X as a whole.

I understand that you don't have any support to download the 7.0.240.X firmware so this is why I'm recommending you downgrade back to 4.0.X as it's more stable and more reliable. 

620
Views
0
Helpful
5
Replies