Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

No DHCP on wireless LAN

Hi guys, I have a Cisco 857W wireless ADSL router and I can get my windows XP w/s to connect but no IP address is assigned. I get a message saying limited or no conenctivity.

Relevant config is:

interface Dot11Radio0

description Wireless LAN

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

ip nat inside

ip virtual-reassembly

ip route-cache flow

!

encryption vlan 1 key 1 size 128bit xxx transmit-key

encryption vlan 1 mode wep mandatory

!

ssid NOC

vlan 1

authentication open

guest-mode

infrastructure-ssid

!

world-mode dot11d country AU both

speed basic-1.0 basic-2.0 basic-5.5 basic-6.0 basic-9.0 basic-11.0 basic-12.0 basic-18.0 basic-24.0 basic-36.0 basic-48.0 basic-54.0

channel 2452

station-role root

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

!

interface Dot11Radio0.1

encapsulation dot1Q 1 native

no snmp trap link-status

no cdp enable

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

!

interface Vlan1

description Internal LAN

ip address 10.10.10.1 255.255.255.248

ip access-group 100 in

no ip redirects

no ip unreachables

no ip proxy-arp

ip nat inside

ip virtual-reassembly

ip route-cache flow

ip tcp adjust-mss 1412

Any ideas?

Thanks

Dean

2 REPLIES
New Member

Re: No DHCP on wireless LAN

Hi Dean,

You can try with following config

world-mode dot11d country AU both

ssid NOC

speed basic-1.0 basic-2.0 basic-5.5 basic-6.0 basic-9.0 basic-11.0 basic-12.0 basic-18.0 basic-24.0 basic-36.0 basic-48.0 basic-54.0

channel 2452

station-role root

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

!

interface FastEthernet0.1

encapsulation dot1Q 1 Native

no ip route-cache

bridge-group 1

no bridge-group 1 source-learning

bridge-group 1 spanning-disabled

!

ip dhcp pool LAN

network 10.10.10.0 255.255.255.248

default-router 10.10.10.1

I hope it will help you.

Thankx&Regds

Saji k.s

New Member

Re: No DHCP on wireless LAN

ok you haven't setup your bridge-group 1 properly.

Your DHCP pool is associated with Vlan1 - however your dot11radio0 is associated with Bridge-group 1 and Vlan 1 isn't - therefore you won't get ip's assigned from your DHCP pool.

Do this and you will be sweet:

ip dhcp pool Local

import all

network 10.10.10.0 255.255.255.248

default-router 10.10.10.1

dns-server 10.10.10.1

!

!

bridge irb

!

!

!

!

interface FastEthernet0

!

interface FastEthernet1

!

interface FastEthernet2

!

interface FastEthernet3

!

interface Dot11Radio0

no ip address

!

broadcast-key change 60

!

!

encryption mode ciphers tkip

!

ssid NOC

authentication open

authentication key-management wpa

guest-mode

wpa-psk ascii 0 'enter your keye here'

!

speed basic-1.0 basic-2.0 basic-5.5 basic-6.0 basic-9.0 basic-11.0 basic-12.0 basic-18.0 basic-24.0 basic-36.0 basic-48.0 basic-54.0

station-role root

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 spanning-disabled

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

!

interface Vlan1

no ip address

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 spanning-disabled

!

!

interface BVI1

ip address 10.10.10.1 255.255.255.248

ip access-group Outbound in

ip nat inside

ip virtual-reassembly

!

bridge 1 protocol ieee

bridge 1 route ip

231
Views
0
Helpful
2
Replies