Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Pesky DHCP problem with 1301 NonRoot Bridge

I am having an intermittent problem with clients not receiving DCHP assignments when connecting to a 1310 in non-root (with wireless clients) mode. The 1310 is associating with another 1310 in root mode (with wireless clients) via an infrastructure ssid. Clients are connecting via an ssid in guest mode. The root bridge is wired to a netvanta router which is acting as the DHCP server. Everything is working fine except when I associate with the non-root bridge I can only get an ip address after waiting several minutes. When I watch the debug logs on the nevtana DHCP I can see the request broadcasts come in and I can see that it is sending an offer, but the offer does not seem to make it's way back to the client. If I assign a manual IP address from our subnet to the client computer everything works fine and if I associate with the root bridge via a wireless client it works fine as well. At the moment there are no VLANs, no authentication and just the two SSIDs. Also, everything is on the same subnet. I feel like I've looked at everything, cleared arp caches and can't seem to find this pesky little bug. Any ideas? Thanks

3 REPLIES

Re: Pesky DHCP problem with 1301 NonRoot Bridge

Your problem may be related to your having two SSIDs and no VLANs. If using more than one SSID you should really have VLANs defined and attached to the SSIDs. Try removing one SSID and see if that improves matters.

If you need to use multiple SSIDs and VLANs the switch or whatever the bridges are connected to must also support VLANs and have them defined on it.

New Member

Re: Pesky DHCP problem with 1301 NonRoot Bridge

Thanks for the suggestion. I removed one of the SSIDs and still had the same problem. It's only on the non-root ap that I am having DHCP troubles. When connecting to the root AP everything works as expected. The thing that has me confused is that if I wait long enough I eventually do get a DHCP assignment when connecting throught the non-root AP. I don't understand what would cause most, but not all, of the broadcasts not to make it through. Once I have the IP address the connection works flawlessly.

New Member

Re: Pesky DHCP problem with 1301 NonRoot Bridge

In case it's useful here is the config from the root AP. The non-root is pretty much the same except the role is non-root bridge with wireless clients. I'm pretty new at this so there is the chance that I am doing something obviously wrong. Thanks again.

!

version 12.3

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec localtime show-timezone

service password-encryption

!

hostname Cisco_Root

!

!

clock timezone GMT -7

clock summer-time T recurring

ip subnet-zero

!

!

aaa new-model

!

!

aaa authentication login default local

aaa authorization exec default local

aaa session-id common

!

dot11 ssid Guest

authentication open

guest-mode

!

dot11 ssid WLAN

authentication open

infrastructure-ssid

!

!

!

username *** password ***

!

bridge irb

!

!

interface Dot11Radio0

no ip address

no ip route-cache

!

ssid Guest

!

ssid WLAN

!

speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0

station-role root bridge wireless-clients

antenna receive right

antenna transmit right

antenna gain 12

bridge-group 1

!

interface FastEthernet0

no ip address

no ip route-cache

bridge-group 1

hold-queue 80 in

!

interface BVI1

ip address 192.168.5.2 255.255.255.0

no ip route-cache

!

ip default-gateway 192.168.5.1

ip http server

ip http authentication aaa

no ip http secure-server

ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag

!

!

control-plane

!

bridge 1 route ip

!

!

!

line con 0

line vty 0 4

!

sntp server 192.5.41.41

end

185
Views
0
Helpful
3
Replies
CreatePlease to create content