Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Users might experience few discrepancies in Search results. We are working on this on our side. We apologize for the inconvenience it may have caused.
New Member

Please help with Wireless AP-1242AG-E-K9

Hello community,

I have troubles with configuring subj Wireless device, so I can connect to the Wireless but IP adress didnt assigned to client device dispite of DHCP pool configured. As you may see this AP connected by etehernet to anther SOHO router with Static IP on BVI1.

!

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname N_WIFI_3

!

logging buffered 20000 warnings

logging rate-limit console 9

enable secret 5 pass

!

no aaa new-model

no ip domain lookup

ip domain name 192.168.0.1

no ip dhcp use vrf connected

ip dhcp excluded-address 192.168.3.1

!

ip dhcp pool N_WIFI_3

   network 192.168.3.0 255.255.255.0

   default-router 192.168.3.1

   lease 10

!

!

!

dot11 ssid N_WIFI_3

   authentication open

   authentication key-management wpa

   guest-mode

   wpa-psk ascii 7 025756085F53597614

!

power inline negotiation prestandard source

!

!

username Cisco password 7 096F471A1A0A

!

bridge irb

!

!

interface Dot11Radio0

ip address pool N_WIFI_3

no ip route-cache

!

encryption mode ciphers aes-ccm

!

ssid N_WIFI_3

interface Dot11Radio0

ip address pool N_WIFI_3

no ip route-cache

!

encryption mode ciphers aes-ccm

!

ssid N_WIFI_3

!

speed  basic-1.0 2.0 5.5 11.0 6.0 9.0 12.0 18.0 24.0 36.0 48.0 54.0

station-role root bridge

bridge-group 1

bridge-group 1 spanning-disabled

!

interface Dot11Radio1

no ip address

no ip route-cache

shutdown

no dfs band block

channel dfs

station-role root

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface FastEthernet0

no ip address

no ip route-cache

duplex auto

speed auto

bridge-group 1

bridge-group 1 spanning-disabled

!

interface BVI1

description Local

ip address 192.168.0.3 255.255.255.0

no ip route-cache

!

ip default-gateway 192.168.0.1

ip http server

no ip http secure-server

ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag

bridge 1 route ip

!

!

!

line con 0

line vty 0 4

login local

!

End

1 ACCEPTED SOLUTION

Accepted Solutions
VIP Purple

Re: Please help with Wireless AP-1242AG-E-K9

Hi

You have configured wrong command ( station role root bridge) under Radio 0 interface.Due to this wireless client cannot associate to it & normally that mode is used when you configurre ROOT - NON-ROOT bridge set up.

Here is the very basic configuration you required this to get working. (Hihglighted purple color missing info). Also configure this on Radio1 as well to give better experience for the client who is  support on 5GHz

hostname N_WIFI_3

!

ip dhcp excluded-address 192.168.3.1

ip dhcp pool N_WIFI_3

   network 192.168.3.0 255.255.255.0

   default-router 192.168.3.1

   lease 10

!

dot11 ssid N_WIFI_3

   authentication open

   authentication key-management wpa version 2

   guest-mode

   wpa-psk ascii 7 025756085F53597614

!

interface Dot11Radio0

ssid N_WIFI_3

encryption mode ciphers aes-ccm

speed  basic-1.0 2.0 5.5 11.0 6.0 9.0 12.0 18.0 24.0 36.0 48.0 54.0

speed default

station-role root bridge

station-role root

bridge-group 1

!

interface Dot11Radio1

ssid N_WIFI_3

encryption mode ciphers aes-ccm

no shutdown

station-role root

bridge-group 1

!

interface FastEthernet0

bridge-group 1

!

interface BVI1

ip address 192.168.0.3 255.255.255.0

!

ip default-gateway 192.168.0.1

See this post as well

https://supportforums.cisco.com/thread/2243196

HTH

Rasika

*** Pls rate all useful responses ***

3 REPLIES
Hall of Fame Super Silver

Please help with Wireless AP-1242AG-E-K9

Here are some links you can review.  The dhcp you set will not work since you have to define bridge groups for different vlans.

Here are some docs for configuraing multiple ssids or vlans and dhcp sever

https://supportforums.cisco.com/docs/DOC-14496

http://www.cisco.com/en/US/tech/tk722/tk809/technologies_configuration_example09186a0080c0b93c.shtml

http://www.my80211.com/cisco-auton-cli-commands/2010/3/8/autonomous-configure-a-cisco-ap-to-provide-dhcp-services.html

Thanks,

Scott

Help out other by using the rating system and marking answered questions as "Answered"

-Scott
*** Please rate helpful posts ***
VIP Purple

Re: Please help with Wireless AP-1242AG-E-K9

Hi

You have configured wrong command ( station role root bridge) under Radio 0 interface.Due to this wireless client cannot associate to it & normally that mode is used when you configurre ROOT - NON-ROOT bridge set up.

Here is the very basic configuration you required this to get working. (Hihglighted purple color missing info). Also configure this on Radio1 as well to give better experience for the client who is  support on 5GHz

hostname N_WIFI_3

!

ip dhcp excluded-address 192.168.3.1

ip dhcp pool N_WIFI_3

   network 192.168.3.0 255.255.255.0

   default-router 192.168.3.1

   lease 10

!

dot11 ssid N_WIFI_3

   authentication open

   authentication key-management wpa version 2

   guest-mode

   wpa-psk ascii 7 025756085F53597614

!

interface Dot11Radio0

ssid N_WIFI_3

encryption mode ciphers aes-ccm

speed  basic-1.0 2.0 5.5 11.0 6.0 9.0 12.0 18.0 24.0 36.0 48.0 54.0

speed default

station-role root bridge

station-role root

bridge-group 1

!

interface Dot11Radio1

ssid N_WIFI_3

encryption mode ciphers aes-ccm

no shutdown

station-role root

bridge-group 1

!

interface FastEthernet0

bridge-group 1

!

interface BVI1

ip address 192.168.0.3 255.255.255.0

!

ip default-gateway 192.168.0.1

See this post as well

https://supportforums.cisco.com/thread/2243196

HTH

Rasika

*** Pls rate all useful responses ***

New Member

Please help with Wireless AP-1242AG-E-K9

Thank you very much. All works fine

289
Views
0
Helpful
3
Replies
CreatePlease to create content