Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

"c1941w" how to communicate AP to router

I am configuring to Cisco1941W.

but I can't ping from AP to Router or opposite.

when I use VLAN1, then I can do it.

So how to configure only using VLAN100 and VLAN200?

(router)

interface Wlan-GigabitEthernet0/0
switchport mode trunk
!

interface GigabitEthernet0/0.1
encapsulation dot1Q 100 native
no  ip address
!
interface GigabitEthernet0/0.2
encapsulation dot1Q 200
no ip address

!

interface wlan-ap0
ip unnumbered Vlan100

!

interface Vlan100
ip address 1.1.1.1 255.255.255.0
!
interface Vlan200
ip address 2.2.2.2 255.255.255.0

(AP)

bridge irb

!

interface GigabitEthernet0.100
encapsulation dot1Q 100 native
no ip route-cache
bridge-group 1
no bridge-group 1 source-learning
bridge-group 1 spanning-disabled
!
interface GigabitEthernet0.200
encapsulation dot1Q 200
no ip route-cache
bridge-group 2
no bridge-group 2 source-learning
bridge-group 2 spanning-disabled
!
interface BVI1
ip address 1.1.1.2 255.255.255.0

If it's not enough information, please point out me.

1 ACCEPTED SOLUTION

Accepted Solutions

Re: "c1941w" how to communicate AP to router

The interface Wlan-GigabitEthernet0/0 is a true switchport, so on the router side, all you need is the switchport mode trunk, and switchport trunk native vlan 100 commands.  You don't need to sub-interface it.

On the AP side, you need to configure it as you would any other standalone AP.  Bridge-groups and subinterfaces, bridge-group 1 for the subinterface that is the native vlan

HTH, Steve ------------------------------------------------------------------------------------------------ Please remember to rate useful posts, and mark questions as answered
1 REPLY

Re: "c1941w" how to communicate AP to router

The interface Wlan-GigabitEthernet0/0 is a true switchport, so on the router side, all you need is the switchport mode trunk, and switchport trunk native vlan 100 commands.  You don't need to sub-interface it.

On the AP side, you need to configure it as you would any other standalone AP.  Bridge-groups and subinterfaces, bridge-group 1 for the subinterface that is the native vlan

HTH, Steve ------------------------------------------------------------------------------------------------ Please remember to rate useful posts, and mark questions as answered
389
Views
0
Helpful
1
Replies
CreatePlease to create content