Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Roaming of clients in 1852

I've just deployed a mobility express with 4 1852 access points. 

My clients doesnt seem to roam at all. i.e client is connected to access point 1, walks around to nearby access point 2 but is still being connected to access point 1. And of course a significant drop in performance. From maybe 500Mbit/s to around 80-100Mbit/s. 

 

I just used the default installation, did some minor settings such as switching off LEDs. 

 

Network info:

Software running: 8.3.112.0

Fast SSID: enabled

RF Optimization: Enabled

Traffic Type: Voice and Data

 

Any ideas on what the problem might be or where i can start looking into this?

9 REPLIES
Hall of Fame Super Gold

Re: Roaming of clients in 1852

The final decision to join which AP falls on the wireless client.  There are some wireless chipset, like Intel, that has a feature called Aggressive Roaming which can be enabled.  Another thing to do is to ensure the wireless NIC's firmware is up to date.  The older the firmware the less chances of roaming properly.

 

IMPORTANT:  Please be aware that your controller is affected by the KRACK vulnerability (Multiple Vulnerabilities in Wi-Fi Protected Access and Wi-Fi Protected Access II)

 

New Member

Re: Roaming of clients in 1852

Thanks for the headsup on the KRACK vulnerabilities, i've scheduled to patch them today or tomorrow. Just need to register the devices and the contracts to be able to download the new versions. 

 

Regarding the roaming issues, this happens to all clients, ie my brand new Samsung Note8 and also my Windows 10 computer with brand new drivers for my intel AC card. 

Hall of Fame Super Gold

Re: Roaming of clients in 1852


Cisco SE wrote:

client is connected to access point 1, walks around to nearby access point 2 but is still being connected to access point 1. And of course a significant drop in performance. From maybe 500Mbit/s to around 80-100Mbit/s. 


What are the data rates enabled on the controller? 

What is the exact model of the Intel wireless NIC and what is the exact version loaded on the NIC?


Cisco SE wrote:

i've scheduled to patch them today or tomorrow. Just need to register the devices and the contracts to be able to download the new versions. 


You can't patch them, yet, because Cisco hasn't released the fixed software yet (see below). 

KRACK.png

 

Just a reminder that this vulnerability affects anything with a wireless NIC. It's not just wireless AP but also wireless clients as well. Patching the client will fix 9 out of 10 vulnerabilities but not CVE-2017-13082. (CVE-2017-13082 will be patched on the AP side.)

New Member

Re: Roaming of clients in 1852

When it comes to my computer for example,  i have a intel ac 7260 card. When i stand next to an access point, i get roughly 300Mbit/s, and as i move around it drops to around 60-80mbit/s and it seems that i dont get redirected to the closest access point. 

 

This is what i see in the main access point (where controller is)

Max Capabilities 802.11n 2.4GHz,802.11ac 5GHz
Spatial Streams : 4 (2.4GHz), 4 (5.0GHz)
Max. Data Rate : 289 Mbps(2.4GHz), 1733 Mbps(5.0GHz)
 
 
On the right side i see:
Channels
2.4GHz 6
5GHz (100, 104, 108, 112)
Configured Rate
2.4GHz Min: 11 Mbps, Max: 289 Mbps
5GHz  Min: 6 Mbps, Max: 1300 Mbps
 
Thanks for the other info, i looked yesterday and it was supposed to be released yesterday... :(
Highlighted
Hall of Fame Super Gold

Re: Roaming of clients in 1852

What is the driver version is the wireless NIC card running?  The latest Intel 7260 driver can be found HERE.

Look at the data rates enabled on the WLC.  What are the rates that are enabled?  

New Member

Re: Roaming of clients in 1852

Thats the driver version im running. 

 

I cant see any configuration option for data rates in the gui. please note that im running the built in controller in the access point, not the standalone wlc 

is there a CLI command for checking which rates are set?

Cisco Employee

Re: Roaming of clients in 1852

I can see the client connecting on 802.11b. You can try disabling lower data rates 1,2.5.5 

 

>>>>Show 802.11b 

willl show the data rates enabled. 

 

--- to disable lower data rate you can use below commands: 

>>>>config 802.11b disable network

>>>>config 802.11b rate disabled 1

>>>>config 802.11b rate disabled 2

>>>>config 802.11b rate disabled 5.5

>>>> config 802.11b enable network

 

Please perform this activity on maintenance windows... 

 

---- Vengat

 

************** Please rate useful posts****************

 

New Member

Re: Roaming of clients in 1852

here is the output of show 802.11b, see attached file

 

 

Hall of Fame Super Gold

Re: Roaming of clients in 1852

Disable data rates 1- to 11 Mbps. Make 12 Mbps as Mandatory and the rest are Supported. Do this to both radios.
Next, get a reading of the wireless client and post the complete output to the command "sh client detail <wireless client MAC address>".
278
Views
0
Helpful
9
Replies
CreatePlease to create content