Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Setting a WLAN on 1841W in autonomous mode!

Hi guys

I have a setup where i am installing 1841W router which also has an 4-port ethernet module for wired users.

There are different levels of complexities involved, as of now I will only keep it to 4 points:

1. I need to have just one VLAN on the WLAN (VLAN 320)

2. The users will be required to be authenticated via a NPS server across the WAN

3. The wired users will have two VLANs, Data and Voice (VLAN 240 and 651)

4. All the VLANs will need to go a DHCP servers for ip addresses for the clients.

Based on the above, I have compiled a rough config, wanted to know if I am missing something:

***************************Router********************************

hostname A

!

no aaa new-model !(I have to configure this bit)

service-module wlan-ap 0 bootimage autonomous

!

controller Cellular 0/1

!

interface Loopback0

ip address 128.1.1.1 255.255.255.255

!

interface Loopback1

ip address 10.51.240.1 255.255.255.255

!

interface Embedded-Service-Engine0/0

no ip address

shutdown

!

interface GigabitEthernet0/0

no ip address

shutdown

duplex auto

speed auto

!

interface wlan-ap0

description Service module interface to manage the embedded AP

ip address 1.1.1.1 255.255.255.255

arp timeout 0

no mop enabled

no mop sysid

!

interface Wlan-GigabitEthernet0/0

description Internal switch interface connecting to the embedded AP

no ip address

!

interface GigabitEthernet0/0/0

switchport access vlan 240

switchport voice vlan 651

no ip address

!

interface GigabitEthernet0/0/1

switchport access vlan 240

switchport voice vlan 651

no ip address

!

interface GigabitEthernet0/0/2

switchport access vlan 240

switchport voice vlan 651

no ip address

!

interface GigabitEthernet0/0/3

switchport access vlan 240

switchport voice vlan 651

no ip address

!

ip route 0.0.0.0 0.0.0.0 Cellular0/1/0 !(Assuming 3G service is working)

**********AP CONFIG************

hostname AP1

!

enable secret 5 $1$nD9N$8fK4tS4Yb8k7rTYyosEU2/

!

dot11 syslog

!

dot11 ssid VCORP

   vlan 320

!

!

!

username cisco privilege 15 secret 5 $1$Oc3J$IjBvJw47ZjflC2181on6k0

!

!

bridge irb

!

!

interface Dot11Radio0

no ip address

no ip route-cache

!

ssid VCORP

!

antenna gain 0

station-role root

!

interface Dot11Radio0.1

encapsulation dot1Q 320 native

no ip route-cache

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface Dot11Radio1

no ip address

no ip route-cache

!

ssid VCORP

!

antenna gain 0

no dfs band block

channel dfs

station-role root

!

interface Dot11Radio1.1

encapsulation dot1Q 320 native

no ip route-cache

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface GigabitEthernet0

description the embedded AP GigabitEthernet 0 is an internal interface connecting AP with the host router

no ip address

no ip route-cache

!

interface GigabitEthernet0.1

encapsulation dot1Q 320 native

no ip route-cache

bridge-group 1

no bridge-group 1 source-learning

bridge-group 1 spanning-disabled

!

interface BVI1

ip address 10.51.246.1 255.255.255.0

ip helper-address 10.32.0.155

no ip route-cache

!

bridge 1 route ip

!

Any suggestions if I am missing anything, or you think anythiing is wrong? I am not sure whether ip is to be given on the BVI interface or on

G0 or G0.1???

Cheers,

Mohit

4 REPLIES
VIP Purple

Setting a WLAN on 1841W in autonomous mode!

Hi Mohit,

Based on your other post, I think you already got this working.

It should be BVI where you assign IP & not G0 or G0.1

HTH

Rasika

**** Pls rate all useful responses ****

New Member

Setting a WLAN on 1841W in autonomous mode!

Universal Client Mode

Universal client mode is a wireless radio station role that allows the radio to act as a wireless client to another access point or repeater. This feature is exclusive to the integrated radio running in the Cisco 870, 1800, 2800, and 3800 integrated service routers (ISRs).

Universal client mode has the following features and limitations:

•You can configure universal client mode on the main dot11radio interface only, subinterfaces are not supported.

•Universal client can associate to access points with radio VLANs.

•Layer-3 routing is supported over the radio interface. However, there is no support for layer 2 (L2) bridging. The user cannot configure a dot11radio interface with a bridge-group when in universal client mode.

•Service Set Identifiers (SSIDs) are required to be configured on the dot11 interface operating as a universal client; association to an access point running in guest mode is not supported.

•The universal client can associate to Cisco access points, third party access points, and repeaters. It cannot associate to Cisco root bridges or Cisco workgroup bridges.

•Easy VPN does not support universal client mode using DHCP.

New Member

Setting a WLAN on 1841W in autonomous mode!

Hi guys

The config went ok.

Just a word of caution to people who are doign it for the first time,

the

interface Wlan-GigabitEthernet0/0 config should align with your BVI interface config.

Like in my case I used VLAN 1 on WLAN-G0/0 and the same in the AP config ie  BVI1

I had used a SVI for VLAN 1 on the router with ip in the same subnet as ip on the bvi1 interface.

Rest all smooth!


Cisco Employee

Setting a WLAN on 1841W in autonomous mode!

One more good ISR config example..

http://www.dslreports.com/faq/15257

454
Views
0
Helpful
4
Replies