Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Should my VLAN interface be UP UP ??

My 871W config is below then the output of the command "show ip int brief". I can get a wireless client to authinticate ok but the client will not pick up an IP address form DHCP?

How do I get my VLAN 1 interface into an UP UP state?

Help!

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname yourname

!

boot-start-marker

boot-end-marker

!

logging buffered 51200 warnings

!

no aaa new-model

!

dot11 syslog

!

dot11 ssid wlan

vlan 1

authentication open

!

ip cef

no ip dhcp use vrf connected

ip dhcp excluded-address 192.168.123.1

ip dhcp excluded-address 192.168.123.2

ip dhcp excluded-address 192.168.123.1 192.168.123.10

ip dhcp excluded-address 10.10.10.1

!

ip dhcp pool LAN-POOL

import all

network 192.168.123.0 255.255.255.0

default-router 192.168.123.1

!

ip dhcp pool wireless-pool

import all

network 10.10.10.0 255.255.255.0

default-router 10.10.10.1

lease 0 2

!

!

!

!

username xxxxx privilege 15 secret 5 xxxxxxxxx.

!

!

archive

log config

hidekeys

!

!

!

bridge irb

!

!

interface FastEthernet0

!

interface FastEthernet1

switchport access vlan 2

!

interface FastEthernet2

switchport access vlan 2

!

interface FastEthernet3

switchport access vlan 2

!

interface FastEthernet4

description $FW_OUTSIDE$

ip address dhcp

ip access-group 199 in

ip nat outside

ip virtual-reassembly

zone-member security out-zone

shutdown

duplex auto

speed auto

!

interface Dot11Radio0

no ip address

!

encryption vlan 1 key 1 size 128bit xxx transmit-key

encryption vlan 1 mode wep mandatory

!

ssid wlan

!

speed basic-1.0 basic-2.0 basic-5.5 basic-6.0 basic-9.0 basic-11.0 basic-12.0 basic-18.0 basic-24.0 basic-36.0 basic-48.0 basic-54.0

station-role root

!

interface Dot11Radio0.1

encapsulation dot1Q 1 native

no cdp enable

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 spanning-disabled

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

!

interface Vlan1

description Internal-LAN

no ip address

ip nat inside

ip virtual-reassembly

ip tcp adjust-mss 1452

bridge-group 1

bridge-group 1 spanning-disabled

!

interface Vlan2

ip address 192.168.123.1 255.255.255.0

!

interface BVI1

ip address 10.10.10.1 255.255.255.0

!

ip forward-protocol nd

!

yourname#sh ip int brie

Interface IP-Address OK? Method Status Protocol

FastEthernet0 unassigned YES unset up down

FastEthernet1 unassigned YES unset up up

FastEthernet2 unassigned YES unset up down

FastEthernet3 unassigned YES unset up down

FastEthernet4 unassigned YES NVRAM administratively down down

Dot11Radio0 unassigned YES NVRAM up up

Dot11Radio0.1 unassigned YES unset up up

Vlan1 unassigned YES NVRAM up down

NVI0 unassigned YES unset administratively down down

Vlan2 192.168.123.1 YES NVRAM up up

BVI1 10.10.10.1 YES NVRAM up up

5 REPLIES
Hall of Fame Super Silver

Re: Should my VLAN interface be UP UP ??

If you don't have anything active on vlan 1 then it will show down. Take a look at this link. It has a cool spreadsheet:

http://articles.techrepublic.com.com/5100-10878_11-6112367.html?tag=nl.e138

-Scott
*** Please rate helpful posts ***
New Member

Re: Should my VLAN interface be UP UP ??

Hi!

Seems to be an issue with WEP key.

Please remove the wep key and mode from dot11radio0 and then try.

There is no IP address on VLAN1. Thus, line protocol would stay down. (Up down). VLAN 1 is mapped to bridge-group 1, so BVI1 is the inside interface.

Also, please remove ip nat inside from vlan 1, and put this under BVI1.

HTH

-Jai

New Member

Re: Should my VLAN interface be UP UP ??

Stil not UP UP??

Wouldnt the dot11radio0.1 be in VLAN 1 and bring the VLAN interface up?

!

bridge irb

!

!

interface FastEthernet0

!

interface FastEthernet1

switchport access vlan 2

!

interface FastEthernet2

switchport access vlan 2

!

interface FastEthernet3

switchport access vlan 2

!

interface FastEthernet4

description $FW_OUTSIDE$

ip address dhcp

ip access-group 199 in

--More-- ip nat outside

ip virtual-reassembly

zone-member security out-zone

shutdown

duplex auto

speed auto

!

interface Dot11Radio0

no ip address

!

ssid wlan

!

speed basic-1.0 basic-2.0 basic-5.5 basic-6.0 basic-9.0 basic-11.0 basic-12.0 basic-18.0 basic-24.0 basic-36.0 basic-48.0 basic-54.0

station-role root

!

interface Dot11Radio0.1

encapsulation dot1Q 1 native

no cdp enable

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 spanning-disabled

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

!

interface Vlan1

description Internal-LAN

no ip address

ip virtual-reassembly

ip tcp adjust-mss 1452

bridge-group 1

bridge-group 1 spanning-disabled

!

interface Vlan2

ip address 192.168.123.1 255.255.255.0

!

interface BVI1

ip address 10.10.10.1 255.255.255.0

ip nat inside

ip virtual-reassembly

!

ip forward-protocol nd

!

ip http server

ip http access-class 2

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

ip nat inside source static tcp 192.168.123.2 3389 interface FastEthernet4 3389

ip nat inside source list 1 interface FastEthernet4 overload

!

!

control-plane

!

!

line con 0

login local

no modem enable

line aux 0

line vty 0 4

--More--

yourname#

yourname#sh ip int brie

Interface IP-Address OK? Method Status Protocol

FastEthernet0 unassigned YES unset up down

FastEthernet1 unassigned YES unset up up

FastEthernet2 unassigned YES unset up down

FastEthernet3 unassigned YES unset up down

FastEthernet4 unassigned YES NVRAM administratively down down

Dot11Radio0 unassigned YES manual up up

Dot11Radio0.1 unassigned YES unset up up

Vlan1 unassigned YES manual up down

NVI0 unassigned YES unset administratively down down

Vlan2 192.168.123.1 YES NVRAM up up

BVI1 10.10.10.1 YES manual up up

Thanks

New Member

Re: Should my VLAN interface be UP UP ??

Yes, dot11radio0.1 belongs to VLAN 1, which is up/up. This pasted configuration seems fine to me.

not able to see bridging commands:

thus, please make sure you have follwoing commands on the router:

bridge 1 protocol ieee

bridge 1 route ip

HTH

-Jai

New Member

Re: Should my VLAN interface be UP UP ??

Tried that suggestion and still not UP UP.

Could be a code issue? Ill down grade the code to an earlier release and see if it works then.

Thanks for the replies.

361
Views
0
Helpful
5
Replies
CreatePlease to create content