Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Switch configuration for LAPs

A local mode LAP is broadcasting WLANs that use VLAN10, VLAN20, and VLAN30.  The switchport the LAP is connected to is configured in access mode.  Do VLANs 10, 20 & 30, need to be configured on the switch? 

1 ACCEPTED SOLUTION

Accepted Solutions
VIP Purple

Re: Switch configuration for LAPs

No,

You need to configure the WLC port as trunk and allow these vlan to this port.

Example:

WLC:

interface GigabitEthernet1/0/1

description Trunk Port to Cisco WLC

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 10,20,30

switchport mode trunk

AP:

interface GigabitEthernet1/0/22

description Access Port Connection to Cisco Lightweight AP

switchport access vlan 10 ------> in which vlan AP getting ip

switchport mode access

no shutdown

Regards

Dont forget to rate helpful posts

4 REPLIES
VIP Purple

Re: Switch configuration for LAPs

No,

You need to configure the WLC port as trunk and allow these vlan to this port.

Example:

WLC:

interface GigabitEthernet1/0/1

description Trunk Port to Cisco WLC

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 10,20,30

switchport mode trunk

AP:

interface GigabitEthernet1/0/22

description Access Port Connection to Cisco Lightweight AP

switchport access vlan 10 ------> in which vlan AP getting ip

switchport mode access

no shutdown

Regards

Dont forget to rate helpful posts

New Member

Switch configuration for LAPs

I thought so.  I just wanted to run it by you gurus to make sure my thinking was correct.

VIP Purple

Re: Switch configuration for LAPs

Just to add, below are some additional best practice config lines for those ports if you are concern about QoS & STP convergence

--- WLC Trunk Port -----

mls qos trust cos

spanning-tree portfast trunk

--- AP access Port -----

mls qos trust dscp

spanning-tree portfast

HTH

Rasika

**** Pls rate all useful responses ****

VIP Purple

Switch configuration for LAPs

165
Views
5
Helpful
4
Replies