Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

TAR Checksum error on 1220 AP

I have been trying to load an image into the AP from the tftp server. I changed the filename to c1200-k9w7-tar.default and configured my PC to 10.0.0.2. When the AP boots up (from default settings), the error message goes like this " examining image...TAR checksum error in tftp://255.255.255.255/c1200-k9w7-tar.default

It than loads the corrupted image which has no firmware. Please advise on how to get this recovered

P/S: I have attached the exact error message from the console

3 REPLIES
Green

Re: TAR Checksum error on 1220 AP

Have you tried downloading a fresh copy of the tarball from Cisco?

Is the image copied from another AP? Was it copied in BIN mode (versus ASCII MODE, which is only a seven bit per character transfer).

What TFTP server are you using? I've had the best luck with 3CDAEMON from 3COM ... make sure you have at least version 2 ... ver 1 has too many bugs and won't do file sizes greater than 32 meg. BOTH versions have some ugly security holes ... only run it when you need it.

Good Luck

Scott

New Member

Re: TAR Checksum error on 1220 AP

I downloaded the image from the CCO. The TFTP server used is SolarWinds. I tried with 3COM as well - both did not work. The file size on the APs are less than 5MB...so, I guess that's fine. Why am I getting "checksum error" when I am doing exactly what is written in this document - "http://www.cisco.com/en/US/products/hw/wireless/ps4570/products_configuration_guide_chapter09186a00801d0188.html#wp1038660"

New Member

Re: TAR Checksum error on 1220 AP

This is not really related to the Tar "checksum error", but if you are using solar winds make sure that you have the receive and send option on the tftp server setup in the settings. This stumped me for a few minutes. The only other thing is that you have the wrong image for the AP or the image isnt compiled. I have tried loading what i thought was a tar file but turned out was an uncompiled image of the IOS. Hope this helps.

856
Views
0
Helpful
3
Replies
CreatePlease to create content