Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

unknown protocol drops on switches

Hai,

I am facing a problem with cisco 3850 switch.

4 3850 switches are stacked this is the ios version.

Switch Ports Model              SW Version        SW Image              Mode  

------ ----- -----              ----------        ----------            ----  

     1 56    WS-C3850-48P       03.03.01SE        cat3k_caa-universalk9 INSTALL

*    2 56    WS-C3850-48P       03.03.01SE        cat3k_caa-universalk9 INSTALL

     3 56    WS-C3850-48P       03.03.01SE        cat3k_caa-universalk9 INSTALL

     4 56    WS-C3850-48P       03.03.01SE        cat3k_caa-universalk9 INSTALL

On all interfaces we are getting un known protocol drops.

This is happening only for the ports connected to Cisco IP Phone.

sh int gigabitEthernet 1/0/6

GigabitEthernet1/0/6 is up, line protocol is up (connected)

  Hardware is Gigabit Ethernet, address is 20bb.c001.b186 (bia 20bb.c001.b186)

  MTU 1500 bytes, BW 1000000 Kbit/sec, DLY 10 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  Full-duplex, 1000Mb/s, media type is 10/100/1000BaseTX

  input flow-control is off, output flow-control is unsupported

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input 00:00:09, output never, output hang never

  Last clearing of "show interface" counters 2d20h

  Input queue: 0/2000/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 20000 bits/sec, 26 packets/sec

  5 minute output rate 582000 bits/sec, 54 packets/sec

     1660799 packets input, 1143477736 bytes, 0 no buffer

     Received 11299 broadcasts (9112 multicasts)

     0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

     0 watchdog, 9112 multicast, 0 pause input

     0 input packets with dribble condition detected

     2420321 packets output, 1763948037 bytes, 0 underruns

     0 output errors, 0 collisions, 0 interface resets

******943 unknown protocol drops**********************************************

     0 babbles, 0 late collision, 0 deferred

     0 lost carrier, 0 no carrier, 0 pause output

     0 output buffer failures, 0 output buffers swapped out

I tried to troubleshoot the issue with dtp,lldp,cdp...etc...seems that is not the issue

What could be the issue? any clue?

Regards

Deva

10 REPLIES
VIP Purple

unknown protocol drops on switches

Hi Deva,

It could be DTP which is enabled by default on the switch interfaces and the router apparently doesn't understand dtp

Try to disabled the DTP on switch end by "switchport nonegotiate" command on interface level.

Regards

Dont forget to rate helpful posts.

New Member

unknown protocol drops on switches

interface GigabitEthernet1/0/6

switchport access vlan 727

switchport mode access

switchport voice vlan 427

switchport port-security maximum 2

switchport port-security

switchport port-security aging time 1

switchport port-security aging type inactivity

switchport port-security aging static

storm-control broadcast level 30.00

storm-control multicast level 50.00

storm-control action shutdown

spanning-tree portfast

interface GigabitEthernet1/0/6

switchport access vlan 727

switchport mode access

switchport voice vlan 427

switchport port-security maximum 2

switchport port-security

switchport port-security aging time 1

switchport port-security aging type inactivity

switchport port-security aging static

storm-control broadcast level 30.00

storm-control multicast level 50.00

storm-control action shutdown

spanning-tree portfast

New Member

Hi All/Deva, Do you have a

Hi All/Deva,

 

Do you have a solution the above mentioned problem, I seemed to be facing the same exact problem as well. 

Could you please share on what was done to have the fault/problem solved? 

Thanks and Regards,

Kanes.R

VIP Purple

unknown protocol drops on switches

post your "show run int g1/0/6" to see how the interface is configured.

Rasika

Hall of Fame Super Gold

unknown protocol drops on switches

Post the output to the command "sh controller e Gi1/0/6".

New Member

unknown protocol drops on switches

Transmit                  GigabitEthernet1/0/6   Receive                
            0 Total bytes                           0 Total bytes             
            0 Unicast frames                        0 Unicast frames          
            0 Unicast bytes                         0 Unicast bytes           
            0 Multicast frames                      0 Multicast frames        
            0 Multicast bytes                       0 Multicast bytes         
            0 Broadcast frames                      0 Broadcast frames        
            0 Broadcast bytes                       0 Broadcast bytes         
            0 System FCS error frames               0 IpgViolation frames     
            0 MacUnderrun frames                    0 MacOverrun frames       
            0 Pause frames                          0 Pause frames            
            0 Cos 0 Pause frames                    0 Cos 0 Pause frames      
            0 Cos 1 Pause frames                    0 Cos 1 Pause frames      
            0 Cos 2 Pause frames                    0 Cos 2 Pause frames      
            0 Cos 3 Pause frames                    0 Cos 3 Pause frames      
            0 Cos 4 Pause frames                    0 Cos 4 Pause frames      
            0 Cos 5 Pause frames                    0 Cos 5 Pause frames      
            0 Cos 6 Pause frames                    0 Cos 6 Pause frames      
            0 Cos 7 Pause frames                    0 Cos 7 Pause frames      
            0 Oam frames                            0 OamProcessed frames     
            0 Oam frames                            0 OamDropped frames       
            0 Minimum size frames                   0 Minimum size frames     
            0 65 to 127 byte frames                 0 65 to 127 byte frames   
            0 128 to 255 byte frames                0 128 to 255 byte frames  
            0 256 to 511 byte frames                0 256 to 511 byte frames  
            0 512 to 1023 byte frames               0 512 to 1023 byte frames 
            0 1024 to 1518 byte frames              0 1024 to 1518 byte frames
            0 1519 to 2047 byte frames              0 1519 to 2047 byte frames
            0 2048 to 4095 byte frames              0 2048 to 4095 byte frames
            0 4096 to 8191 byte frames              0 4096 to 8191 byte frames
            0 8192 to 16383 byte frames             0 8192 to 16383 byte frames
            0 16384 to 32767 byte frame             0 16384 to 32767 byte frame
            0 > 32768 byte frames                   0 > 32768 byte frames     
            0 Late collision frames                 0 SymbolErr frames        
            0 Excess Defer frames                   0 Collision fragments     
            0 Good (1 coll) frames                  0 ValidUnderSize frames   
            0 Good (>1 coll) frames                 0 InvalidOverSize frames  
            0 Deferred frames                       0 ValidOverSize frames    
            0 Gold frames dropped                   0 FcsErr frames           
            0 Gold frames truncated   
            0 Gold frames successful  
            0 1 collision frames      
            0 2 collision frames      
            0 3 collision frames      
            0 4 collision frames      
            0 5 collision frames      
            0 6 collision frames      
            0 7 collision frames      
            0 8 collision frames      
            0 9 collision frames      
            0 10 collision frames     
            0 11 collision frames     
            0 12 collision frames     
            0 13 collision frames     
            0 14 collision frames     
            0 15 collision frames     
            0 Excess collision frames 

LAST UPDATE 120931740 msecs AGO

Hall of Fame Super Gold

unknown protocol drops on switches

Deva,

There's nothing from your output.  All counters are "0".

New Member

Re: unknown protocol drops on switches

Please find the attached logs

Hall of Fame Super Gold

unknown protocol drops on switches

Can you please post the output to the command "sh interface count err"?

New Member

Hi All/Deva, Do you have a

Hi All/Deva,

 

Do you have a solution the above mentioned problem, I seemed to be facing the same exact problem as well. 

Could you please share on what was done to have the fault/problem solved? 

Thanks and Regards,

Kanes.R

7344
Views
0
Helpful
10
Replies
CreatePlease to create content