Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

Cisco Employee

updated WLC SW upgrade path doc

Is there an updated WLC Sw upgrade page where it shows all the latest codes, for exmaple I would like to see how to move from an older code to 4.2.207.

the doc id is 68835 http://www.cisco.com/en/US/tech/tk722/tk809/technologies_configuration_example09186a00805f381f.shtml

thanks

3 REPLIES
Gold

Re: updated WLC SW upgrade path doc

Just check out the release notes.  There is a table in there that shows if there are any interim upgrades needed between the version you are on and the one you are going to.

Cisco Employee

Re: updated WLC SW upgrade path doc

ok thanks, can I use the 4400 Rel notes for the WiSM, since there are no Rel notes for WiSM?

Hall of Fame Super Red

Re: updated WLC SW upgrade path doc

Hi There.

Here are the related noted

Special Rules for Upgrading to Controller Software Release 4.2.207.0


Caution Before upgrading your controller to software release 4.2.207.0, you must comply with the following rules.

Make sure you have a TFTP server available for the software upgrade. Keep these guidelines in mind when setting up a TFTP server:

Controller software release 4.2.207.0 is larger than 32 MB; therefore, you must make sure that your TFTP server supports files that are larger than 32 MB. Some TFTP servers that support files of this size are tftpd and the TFTP server within the WCS. If you attempt to download the 4.2.207.0 controller software and your TFTP server does not support files of this size, the following error message appears: "TFTP failure while storing in flash."

If you are upgrading through the service port, the TFTP server must be on the same subnet as the service port because the service port is not routable, or you must create static routes on the controller.

If you are upgrading through the distribution system network port, the TFTP server can be on the same or a different subnet because the distribution system port is routable.

A third-party TFTP server cannot run on the same computer as the WCS because the WCS built-in TFTP server and the third-party TFTP server require the same communication port.

If your controller is running software release 4.0.206.0 (or a later 4.0 release), 4.1.171.0 (or a later 4.1 release), or 4.2.61.0, 4.2.99.0, 4.2.112.0, or 4.2.130.0, you can upgrade your controller directly to software release 4.2.207.0. If your controller is running a 3.2 release or a 4.0 release prior to 4.0.206.0, you must upgrade your controller to an intermediate release prior to upgrading to 4.2.207.0. Table 1 shows the upgrade path that you must follow before downloading software release 4.2.207.0.

Table 1     Upgrade Path to Controller Software Release 4.2.207.0

Current Software Release
Upgrade Path to 4.2.207.0 Software

3.2.78.0 or later 3.2 release

Upgrade to 4.0.206.0 (or a later 4.0 release) before upgrading to 4.2.207.0.

4.0.155.5

Upgrade to 4.0.206.0 (or a later 4.0 release) before upgrading to 4.2.207.0.

4.0.179.11

4.0.206.0 or later 4.0 release

You can upgrade directly to 4.2.207.0.

4.1.171.0 or later 4.1 release

You can upgrade directly to 4.2.207.0.

4.2.61.0 or later 4.2 release

You can upgrade directly to 4.2.207.0.

http://www.cisco.com/en/US/docs/wireless/controller/release/notes/crn422070.html#wp336165

Cheers!

Rob

950
Views
0
Helpful
3
Replies