Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

vWLC with AP1602 + VMware Workstation Multiple IP

Hello,

I have configured a new vWLC system with AP1602's. I have followed the manual and used FlexConnect. Everything is working fine but when I connect the VM's on my laptop they don't get a DHCP address. If I assign a static IP it works. I'm not able to find anything in the manuals.

Can anyone assist?

 

Thanks,

Bryan

1 ACCEPTED SOLUTION

Accepted Solutions
Community Member

Hi Bryan,Cisco TAC resolved

Hi Bryan,

Cisco TAC resolved my problem. I had to upgrade my WLC 2504 to 7.6.120.0 and change the following.

1 -Configure a flexconnect group and all your flexconnect APs to that group:
From the controller GUI:
Wireless > FlexConnect Groups > Click on New
Fill the group name and click on Apply.

2 -Click on the AP group name, add the two flexconnect APs, then configure the WLAN VLAN mapping.
3 -On the controller CLI, enable DHCP Broadcast for locally switched clients on that flexconnect group, using below command:
config flexconnect group <groupName> dhcp overridden-interface enable

This works on our 2504 and vWLC.

Kind regards,

Marco

8 REPLIES

Hello,Make sure you switched

Hello,

Make sure you switched your APs from local to FlexConnect mode.

If it's not that, review Scott's post here: https://supportforums.cisco.com/discussion/12140926/cisco-ap-2602-joined-vwlc-there-no-wireless 

Community Member

Hi Florin,Thanks for the

Hi Florin,

Thanks for the reply. I've already configured FlexConnect on the system and AP. This works fine. I can connect my laptop and receive an IP address. The problem occurs when I try to connect my VMware VM to the wireless netwerk. It does connect but does not receive an IP address. When I configure a static IP it works fine.

It's like the vWLC only gives out one IP per connected cliënt.

Community Member

I tried a 2504 controller

I tried a 2504 controller with a new configuration and new AP's but in this setup my laptop also gets an IP but my virtual machine does not.

 

Any other thoughts? Anyone has this working?

Community Member

Hi Bryan,

Hi Bryan, is your problem solved? I've the same issue with VM's in bridged mode on FlexConnect APs (locally switched). Kind regards, Marco
Community Member

Hi Marco, I'm sad to say I

Hi Marco,

 

I'm sad to say I haven't solved it yet (haven't invested enough time). What I was able to find is that Cisco does not support two IP's for one MAC address with lightweight AP's. Autonomous AP's on the other hand work fine.

 

-Bryan

Community Member

Hi Bryan,Cisco TAC resolved

Hi Bryan,

Cisco TAC resolved my problem. I had to upgrade my WLC 2504 to 7.6.120.0 and change the following.

1 -Configure a flexconnect group and all your flexconnect APs to that group:
From the controller GUI:
Wireless > FlexConnect Groups > Click on New
Fill the group name and click on Apply.

2 -Click on the AP group name, add the two flexconnect APs, then configure the WLAN VLAN mapping.
3 -On the controller CLI, enable DHCP Broadcast for locally switched clients on that flexconnect group, using below command:
config flexconnect group <groupName> dhcp overridden-interface enable

This works on our 2504 and vWLC.

Kind regards,

Marco

Community Member

Thanks Marco, that solved the

Thanks Marco, that solved the issue. Nice that you took the time to share.

-Bryan

Debugging the internal DHCP

Debugging the internal DHCP server is typically a matter of finding a client that is having a problem getting an IP address. You need to run these debugs:

    debug client <MAC ADDRESS OF CLIENT>

The debug client is a macro that enables these debugs for you while focusing the debug out only on the client MAC address that you have entered:

    debug dhcp packet enable
    debug dot11 mobile enable
    debug dot11 state enable
    debug dot1x events enable
    debug pem events enable
    debug pem state enable
    debug cckm client debug enable

The main one for DHCP issues is the debug dhcp packet enable command that is enabled automatically by the debug client command.

513
Views
5
Helpful
8
Replies
CreatePlease to create content