Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Web authentication page not displaying

Hi guys,

I'm 95% of the way there with getting my wireless network up, I've just ran into a small issue that I can't seem to figure out.

I've configured the guest wlan interface and the client gets its IP address from my DHCP server. I am pushing a wpad configuration down to the client to force the client to use one of our two proxy servers. Using wireshark I can see that traffic is being routed from the client out of the interface.

This obviously fails though as the client is not yet authenticated. We are using local accounts on the controller using the lobby admin to provide guest access. What is not popping up is the Web Authentication window in my browser. Actually, it popped up once but my browsers pop up blocker blocked it. Now whenever the client tries to browse the internet the connection fails, as the user/client has not been authenticated.

Appreciate this may be something as simple as a browser problem, but I can't seem to figure it out? In the past as soon as the client has obtained an IP address this window has popped up. It does not do this any more?

Any tips would be much appreciate!

Thanks,

Darren                  

3 REPLIES

Web authentication page not displaying

https://supportforums.cisco.com/thread/2158102?tstart=0

Rating useful replies is more useful than saying "Thank you"
New Member

Web authentication page not displaying

Hi Amjad,

First of all thanks for your prompt reply.

Secondly, I really should have provided more information regarding my environment.

We use a Microsoft ISA 2004 server as our proxy server. We treat the particular subnet that the guest wireless is using as a 'trusted' network and allow this to pass through 'unauthenticated'. The reason to do this is to push the traffic through our Symantec cloud based proxy service (web filtering). This part actually works.

What we do is we don't set the proxy as enabled, per say, in the browser, what we do, from the DHCP scope, is to push down a wpad.dat configuration to the host. The forces the host to use the proxy configuration without being part of our domain. Our ISA expert got this going for me

Since I logged the first request for assistance I've got it working again, it just seems to be that on the first request, on a client, if the 'pop up blocker' is enabled on the client, that when the second window opens that informs you that you are connected and to use the 'log off' button within this window to disconnect your session, if you have the blocker enabled, stopping this window from opening, I can't seem to connect again from the client? Very wierd? I've tried clearing the cache of the machine and restarting? What I did was created another local user, disabled the pop-up blocker, then attempted to connect again and it worked? This makes me think it is something to do with the browser and not the wireless configuration??

Hope this makes sense?

Thanks,

Darren

Web authentication page not displaying

Hi Darren,

Thanks for the explanation.

At the point you get the log-out popup this means the authentication is went correctly and web-auth process succeeded.

Now, about the pop-up blocked it is really weird to get it not working if the pop-up blocker is enabled. From the WLC point of view the pop-up blocker is irrelevant at this point.

You may try several times from different clients to isolate furhter. it may be related to some other issue that happened

coincidentally with the pop-up blocker issue.

From what I see no issue on the infrastructure. it is only on the client just like what you described.

Isolate further please and let us know.

Regards,

Amjad

Rating useful replies is more useful than saying "Thank you"
1463
Views
0
Helpful
3
Replies
CreatePlease login to create content