Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Wenauth Failure

Dear All,

I have one 8500 WLC with latest version

.

I need to configure one SSID with Webauth.

I have already  installed the Webauthentication bundle successfully.

When I tried to connect to wireless, I am getting the webauth page.If I click the accept button,its not moving to the internet.

Do we need to make any other changes on the WLC ? Does it require any other special configs ?

Waiting for your advice

Thanks and Regards

Devakumar

14 REPLIES
New Member

Re: Webauth Failure

Dear All,

I have one 8500 WLC with latest version

.

I need to configure one SSID with Webauth.

I have already  installed the Webauthentication bundle successfully.

When I tried to connect to wireless, I am getting the webauth page.If I click the accept button,its not moving to the internet.

Do we need to make any other changes on the WLC ? Does it require any other special configs ?

Waiting for your advice

Thanks and Regards

Devakumar

VIP Purple

Wenauth Failure

Hall of Fame Super Silver

Re: Wenauth Failure

If you were able to upload a custom WebAuth, then the issue is with your HTML code. The button for the accept is broke as it should redirect to a failure or authorized state.

Sent from Cisco Technical Support iPhone App

-Scott
*** Please rate helpful posts ***
New Member

Re: Webauth Failure

Dear Scott, Thanks for your reply. I have successfully installed the webauth bundle. If I click preview it is redirecting to the installed page. Then If I click FREE INTERNET button it is  directly going to the URL which I have mentioned on the HTML file. At the same time, If my  client  try to connect to the SSID, I am getting the landing page . Then there is a button FREE-INTERNET  ..It is not going after I click the free internet button.. I have done three steps for testing Created a username and password on WLC for guest access 1) I tried Internal(default) Webauth Page. It works  2) I have created another HTML(Customized Webauth) file which has the option to ask username and password. With that HTML file I am able to connect to the wireless 3) I created an HTML file where I put the hidden username and password option .(Used the same username and password on the WLC).   instead of asking the credentials we coded on the html file. Then also it is working without any issue Do we need to make any other changes on the WLC ? Does it require any other special configs ? Do you have any idea what eaxctly we need to do for redirecting the webpage? Regards Dev Kumar

New Member

Re: Webauth Failure

Dear Scott,

Thanks for your reply.

I have successfully installed the webauth bundle. If I click preview it is redirecting to the installed page. Then If I click FREE INTERNET button it is directly going to the URL which I have mentioned on the HTML file.

At the same time, If my client try to connect to the SSID, I am getting the landing page . Then there is a button FREE-INTERNET ..It is not going after I click the free internet button.. I have done three steps for testing Created a username and password on WLC for guest access

1) I tried Internal(default) Webauth Page. It works

2) I have created another HTML(Customized Webauth) file which has the option to ask username and password. With that HTML file I am able to connect to the wireless

3) I created an HTML file where I put the hidden username and password option .(Used the same username and password on the WLC). instead of asking the credentials we coded on the html file. Then also it is working without any issue

Do we need to make any other changes on the WLC ? Does it require any other special configs ? Do you have any idea what eaxctly we need to do for redirecting the webpage?

Regards

Dev Kumar

Hall of Fame Super Silver

Re: Wenauth Failure

1) I tried Internal(default) Webauth Page. It works

> this usually points to the HTML code being the issue

2) I have created another HTML (Customized Webauth) file which has the option to ask username and password. With that HTML file I am able to connect to the wireless.

> so far so good

3) I created an HTML file where I put the hidden username and password option .(Used the same username and password on the WLC). instead of asking the credentials we coded on the html file. Then also it is working without any issue

> okay so everything is working?

Do we need to make any other changes on the WLC ? Does it require any other special configs ? Do you have any idea what eaxctly we need to do for redirecting the webpage?

So everything is working fine? What you are trying to do is redirect them to a URL after they authenticate? There is a setting on the WebAuth page to redirect to a URL you specify.


Sent from Cisco Technical Support iPhone App

-Scott
*** Please rate helpful posts ***
New Member

Re: Wenauth Failure

Dear Scott,

Thanks for your reply

This is for free internet access to the people who is visiting a shopping mall and around 300 clients will be connecting to this SSID .We dont want to use the username and password on the HTML file.

If my client try to connect to the SSID, I am getting  the landing page  on  following URLhttp://1.1.1.1/login........etc

Then there is a button on URL FREE-INTERNET   .When I click FREE-INTERNET this page is not moving.Its trying to refresh and stops.

Existing HTML file already has a setting for redirecting to the URL"google.com".

Regards

Devkumar

Hall of Fame Super Silver

Re: Wenauth Failure

Deva,

So if you use the default internal webauth and enter the credentials, everything works fine? I want to know, since your using credentials, if the default Cisco WebAuth page works or not?

Can you email me your WebAuth bundle so I can test it?

Sent from Cisco Technical Support iPhone App

-Scott
*** Please rate helpful posts ***
New Member

Re: Wenauth Failure

Dear Scot,

1) I use the default internal webauth and enter the credentials, it works fine. Default Cisco WebAuth page works perfectly.

2) I have created another HTML (Customized Webauth) file which has the  option to ask username and password.  That also works

I dont want to putr the username and password here

This is for free internet access to the people who is visiting a  shopping mall and around 300 clients will be connecting to this SSID .If I try to connect to the SSID, I am getting  the landing page  on  following URL

Then  there is a button on URL FREE-INTERNET   .When I click  FREE-INTERNET  this page is not moving.Its trying to refresh and stops.

https://1.1.1.1/fs/customwebauth/login.html?switch_url=https://1.1.1.1/login.html&ap_mac=dc:a5:f4:cc:88:c0&client_mac=00:24:d6:93:ef:ba&wlan=test&redirect=www.google.com/

I will attach the Webauth Bundle

Thanks

Deva

Hall of Fame Super Silver

Re: Wenauth Failure

My question is, why not use pass through. This way there are no credentials and you would create a custom WebAuth with an accept button and that's it. There is no reason to embed a username and password. That's is what I would do.

Sent from Cisco Technical Support iPhone App

-Scott
*** Please rate helpful posts ***
New Member

Re: Wenauth Failure

Dear Scott,

I am already using the passthrough option...Please find the snapshot

Regards

Dev

New Member

Re: Wenauth Failure

Dear Scott,

Did you get the time to look into the webauth Bundle.

Thanks alot for spending your valuable time

Regards

Deva

Hall of Fame Super Silver

Wenauth Failure

Just took a look at it... I'm not a pro at html and know the basics, but your code is way above what I would do or know.  So here is the thing.  If you have a custome webauth that has a username and password and that works, then what I would do is embed the username and password and hide that from the user view.  Then you would keep the Web Policy to authentication and that should work.  With pass through, the java script is different and that might be why your having issues.

Thanks,

Scott

Help out other by using the rating system and marking answered questions as "Answered"

-Scott
*** Please rate helpful posts ***

Re: Webauth Failure

If it is custom web auth script, ensure that the Scripting option is not blocked on             the client browser as the customized web page on the WLC is basically an HTML             script.

380
Views
0
Helpful
14
Replies
CreatePlease login to create content