Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Why am I not getting DHCP addresses?

This is driving me nuts...either getting 0.0.0.0 or 169 addresses....if I wireshark on local comp dhcp requests are going on but getting no replies to them.

If I make the AP a dhcp server the unit gets an address and can ping the AP but not the gateway.

Other APs are set up similarly with no issue. I just want a basic 1 SSID config...what am I doing wrong?

Current configuration : 1968 bytes

!

! Last configuration change at 02:22:39 UTC Mon Mar 1 1993 by Cisco

version 15.2

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname ap

!

!

logging rate-limit console 9

enable secret 5 $1$Mkq1$HdLwkEV0Hn/GwnQDYJ4Md.

!

no aaa new-model

no ip routing

no ip cef

no ip domain lookup

ip domain name bigstonetherapies.local

!

!

!

!

dot11 syslog

!

dot11 ssid BigTest

   authentication open

   authentication key-management wpa

   guest-mode

   wpa-psk ascii 7 071B245F5A584B5643

!

!

dot11 guest

!

!

!

username Cisco password 7 0802455D0A16

!

!

bridge irb

!

!

!

interface Dot11Radio0

no ip address

no ip route-cache

shutdown

!

encryption mode ciphers aes-ccm

!

ssid BigStone

!

antenna gain 0

stbc

beamform ofdm

station-role root

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 spanning-disabled

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

!

interface Dot11Radio1

no ip address

no ip route-cache

!

encryption mode ciphers aes-ccm

!

ssid BigStone

!

antenna gain 0

peakdetect

dfs band 3 block

stbc

beamform ofdm

channel dfs

station-role root

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 spanning-disabled

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

!

interface GigabitEthernet0

no ip address

no ip route-cache

duplex auto

speed auto

bridge-group 1

bridge-group 1 spanning-disabled

no bridge-group 1 source-learning

!

interface BVI1

ip address 10.0.0.40 255.255.255.0

no ip route-cache

ipv6 address dhcp

ipv6 address autoconfig

ipv6 enable

!

ip forward-protocol nd

ip http server

no ip http secure-server

ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag

!

!

bridge 1 route ip

!

!

!

line con 0

line vty 0 4

login local

transport input all

!

end

ap(config)#

1 ACCEPTED SOLUTION

Accepted Solutions
New Member

Why am I not getting DHCP addresses?

why is your radio0 interface on shutdown?? try enabling it, create subinterface Dot11radio0.1, Dot11radio1.1, and gigabitethernet0.1 with dot1q encryption 1 native, bridge-group 1. Your problem is related to native vlan mismatch on both sides i think.

12 REPLIES

Why am I not getting DHCP addresses?

Where is your DHCP server configured?

VIP Purple

Re: Why am I not getting DHCP addresses?

Your AP does not have default-gateway configured. In 15.2 IP routing is enabled by default & you can configure ip route 0.0.0.0 0.0.0.0 instead of "ip default-gateway" command.

Below is the extract from given release notes

http://www.cisco.com/en/US/docs/wireless/access_point/ios/release/notes/15.2_2_JB.html#wp147667

IP Routing Enabled By Default

IP routing is enabled by default in 15.2(2)JB. This default configuration will render ip default-gateway statements inoperable. The work around is to disable ip routing globally (config t, no ip routing), or configure a default route instead of a default-gateway (e.g. config t, ip route 0.0.0.0 0.0.0.0 ).

Also in the above AP configuration defined SSID (BigTest) & configured SSID (BigStone) under interface is different.

HTH

Rasika

**** Pls rate all useful responses ****

New Member

Why am I not getting DHCP addresses?

Alright so now IP routing is enabled and I have an IP route statement added but still same result.

My DHCP server is 10.0.0.21

version 15.2

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname ap

!

!

logging rate-limit console 9

enable secret 5 $1$Mkq1$HdLwkEV0Hn/GwnQDYJ4Md.

!

no aaa new-model

ip cef

no ip domain lookup

ip domain name bigstonetherapies.local

!

!

!

!

dot11 syslog

!

dot11 ssid BigStone

   authentication open

   authentication key-management wpa

   guest-mode

   wpa-psk ascii 7 071B245F5A584B5643

!

!

dot11 guest

!

!

!

username Cisco password 7 0802455D0A16

!

!

bridge irb

!

!

!

interface Dot11Radio0

no ip address

shutdown

!

encryption mode ciphers aes-ccm

!

ssid BigStone

!

antenna gain 0

stbc

beamform ofdm

station-role root

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 spanning-disabled

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

!

interface Dot11Radio1

no ip address

!

encryption mode ciphers aes-ccm

!

ssid BigStone

!

antenna gain 0

peakdetect

dfs band 3 block

stbc

beamform ofdm

channel dfs

station-role root

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 spanning-disabled

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

!

interface GigabitEthernet0

no ip address

duplex auto

speed auto

bridge-group 1

bridge-group 1 spanning-disabled

no bridge-group 1 source-learning

!

interface BVI1

ip address 10.0.0.40 255.255.255.0

ipv6 address dhcp

ipv6 address autoconfig

ipv6 enable

!

ip forward-protocol nd

ip http server

no ip http secure-server

ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag

ip route 0.0.0.0 0.0.0.0 10.0.0.1

!

!

bridge 1 route ip

!

!

!

line con 0

line vty 0 4

login local

transport input all

!

end

VIP Purple

Why am I not getting DHCP addresses?

Hi Anthony,

Are you able to ping 10.0.0.1 & 10.0.0.21 IP from the AP ?

Post the switchport interface configuration  where this AP connect to.

Rasika

New Member

Why am I not getting DHCP addresses?

Rasik,

I can ping everything from the AP. The switch is an ESW 520 managed from a GUI, no switchports are tagged for vlans.

Hall of Fame Super Silver

Why am I not getting DHCP addresses?

Connect a laptop to a port on that switch and see if the laptop gets a dhcp address.  Verify that the dhcp scope is enabled on the dhcp server.

Thanks,

Scott

Help out other by using the rating system and marking answered questions as "Answered"

-Scott
*** Please rate helpful posts ***
New Member

Why am I not getting DHCP addresses?

dhcp is working on the network. If I reset the AP to factory defaults it pulls an address from the server.

Hall of Fame Super Silver

Why am I not getting DHCP addresses?

Try using WPAv2 since your using AES-CCM.  Make sure that the clients are using WPA2-Personal (WPA2/AES)

config t

dot11 ssid BigStone

authentication key-management wpa version 2

For testing, set the BVI to dhcp and try to associate.

Thanks,

Scott

Help out other by using the rating system and marking answered questions as "Answered"

-Scott
*** Please rate helpful posts ***
New Member

Why am I not getting DHCP addresses?

why is your radio0 interface on shutdown?? try enabling it, create subinterface Dot11radio0.1, Dot11radio1.1, and gigabitethernet0.1 with dot1q encryption 1 native, bridge-group 1. Your problem is related to native vlan mismatch on both sides i think.

New Member

Why am I not getting DHCP addresses?

I truly appreciate all of the ideas, I thought Tat had it but still having the same issue after making the changes. Anything further anyone can suggest?  Here is current config.

Building configuration...

Current configuration : 2543 bytes

!

! Last configuration change at 04:10:47 UTC Fri Oct 25 2013 by Cisco

! NVRAM config last updated at 21:12:47 UTC Sun Oct 27 2013 by Cisco

! NVRAM config last updated at 21:12:47 UTC Sun Oct 27 2013 by Cisco

version 15.2

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname ap

!

!

logging rate-limit console 9

enable secret 5 $1$pUrT$qP2QZ8BbjtmJE.vwoQ7FX/

!

no aaa new-model

no ip routing

no ip cef

ip domain name bigstonetherapies.local

!

!

!

!

dot11 syslog

!

dot11 ssid BigStone

   vlan 1

   authentication open

   authentication key-management wpa

   guest-mode

   wpa-psk ascii 7 071B245F5A584B5643

!

!

dot11 guest

!

!

!

username Cisco password 7 01300F175804

!

!

bridge irb

!

!

!

interface Dot11Radio0

no ip address

no ip route-cache

!

encryption mode ciphers aes-ccm

!

encryption vlan 1 mode ciphers aes-ccm

!

broadcast-key vlan 1 change 30

!

!

ssid BigStone

!

antenna gain 0

stbc

beamform ofdm

station-role root

!

interface Dot11Radio0.1

encapsulation dot1Q 1 native

no ip route-cache

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 spanning-disabled

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

!

interface Dot11Radio1

no ip address

no ip route-cache

!

encryption mode ciphers aes-ccm

!

encryption vlan 1 mode ciphers aes-ccm

!

broadcast-key vlan 1 change 30

!

!

ssid BigStone

!

antenna gain 0

peakdetect

dfs band 3 block

stbc

beamform ofdm

channel dfs

station-role root

!

interface Dot11Radio1.1

encapsulation dot1Q 1 native

no ip route-cache

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 spanning-disabled

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

!

interface GigabitEthernet0

no ip address

no ip route-cache

duplex auto

speed auto

!

interface GigabitEthernet0.1

encapsulation dot1Q 1 native

no ip route-cache

bridge-group 1

bridge-group 1 spanning-disabled

no bridge-group 1 source-learning

!

interface BVI1

ip address 10.0.0.40 255.255.255.0

no ip route-cache

ipv6 address dhcp

ipv6 address autoconfig

ipv6 enable

!

ip default-gateway 10.0.0.1

ip forward-protocol nd

ip http server

no ip http secure-server

ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag

ip route 0.0.0.0 0.0.0.0 10.0.0.1

!

!

bridge 1 route ip

!

!

!

line con 0

line vty 0 4

login local

transport input all

!

end

New Member

Re: Why am I not getting DHCP addresses?

Was port security on the switch. Thanks everybody for your replies.

Why am I not getting DHCP addresses?

Enable Dot11radio11 and it will work.

291
Views
6
Helpful
12
Replies