Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

WIFI VLANs not communicating

I'm trying to set up 1130 APs connected to a 3750 L3 switch. I set up 3 SSIDs : test,

internal and guest. For some reason, I can't access the APs when the port is configured for trunking. I did the same on a 3560 switch with 2 SSIDs last week, and I'm getting

very different results.

Test: 10.10.10.x Native VLAN 1

Internal: 192.168.10.x VLAN 203

Guest : 192.168.100.x VLAN 202

I connect to the AP fine, but when I connect to 'internal' SSID, I can only communicate

if my IP is on the 192.168.10.x range, even though the 'test'VLAN is set to a different

subnet.

The switch port configs:

interface GigabitEthernet1/0/7 ! ---I can access the AP

switchport access vlan 203

!

interface GigabitEthernet1/0/8 ! ---no communication---

switchport trunk encapsulation dot1q

switchport mode trunk

The AP config:

The AP config should be attached

I'm stuck, I have no idea what I'm doing wrong, PLEASE HELP :)

Chris Serafin

cserafin@rkon.com

chris@chrisserafin.com

10 REPLIES
Bronze

Re: WIFI VLANs not communicating

These sound like autonomous AP's.

All the ports should be trunked and the native vlan needs to be defined.

Int g1/0/7 has a vlan 203 defined which is why you can get to the AP, g1/0/8 has no vlan

try this:

switchport trunk encapsulation dot1q

switchport trunk native vlan 1

switchport trunk allowed vlan 1, 202-203

switchport mode trunk

Try this on one and test it. Then populate the rest of the switch

New Member

Re: WIFI VLANs not communicating

I have tried this and 2 of the commands do not show up in the config. (must be default configs)

after:

no switchport access vlan 203

switchport trunk encap dot1q

switchport trunk native vlan 1

switchport trunk allowed vlan all

switchport mode trunk

this shows in the config:

interface GigabitEthernet1/0/7

description [ Link to AP7 ]

switchport trunk encapsulation dot1q

switchport mode trunk

Thanks for your original response.

Chris Serafin

cserafin@rkon.com

New Member

Re: WIFI VLANs not communicating

Not too sure on your case though.I am using 1130 as Lightweight mode,which let the Wireless controller do the configuring.

But one thing for sure, Your AP-Manager and Management Interfaces is recommended to be on the same vlan.hopes that help.

Bronze

Re: WIFI VLANs not communicating

I would at this point write erase and reload the switch and clear out whatever may be lurking in there.

New Member

Re: WIFI VLANs not communicating

Your getting barked by the switch because you did not set up those vlan's.. I think... Try issuing this statement in config mode

int vlan 202

no shut

int vlan 203

no shut

then go to the interface 1/07 and reissue the statements..

Do a show vlan in global mode to see if your vlan are there..

Hope this works for you..

New Member

Re: WIFI VLANs not communicating

it worked for me.

I don't have (yet) a VTP domain, so I need to configure vlan on each switch.

Adding it (via the "vlan database" command, since it is an L2 device), and it started working.

Re: WIFI VLANs not communicating

I may have missed it, but where is your layer 3 device/config that lets the seperate vlans communicate with each other?

New Member

Re: WIFI VLANs not communicating

can u please change ur native Vlan1 to native vlan203 , u will be accessing then .. no issue .. try it ..

New Member

Re: WIFI VLANs not communicating

Keep in mind that only the link between the WLC and the wired network should be trunked.

The AP's should be plugged into Access ports.

New Member

Re: WIFI VLANs not communicating

Correct - sorta. If H-REAP is to be used, the AP is then connected to a trunk port.

268
Views
0
Helpful
10
Replies