Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Wireless clients cannot connect to other local nets

Hi!

I have a WLC2106 installed on my network, with one WLAN configured. The WLC is connected through a unmanaged switch to a router cisco1921. An inside interface of the router is configured to support a 2 vlans (VLAN 10 relating to WLAN and VLAN 20 relating to desktop computers). That is, a few corresponding subinterfaces have been configured.

NAT is also configured so that wireless clients can surf the Internet. Clients can ping their default router ip address (this is the subinterface configured on the inside interface of 1921) and all Internet resources. The problem in that they cannot ping any computers residing in VLAN 20 and vice versa.

I have a hunch this problem is somehow related to a safety settings for wireless clients but I have no idea where I should search for it. It has nothing to do with p2p blocking because neither enabling nor disabling it helps. Neither can it be related to routing issues since both networks (VLANs 10 and 20) are directly connected to the router.

I'd be very grateful for any ideas.

Regards,

T.

3 REPLIES
Silver

Wireless clients cannot connect to other local nets

P2P blocking would keep wireless clients from talking to wireless clients. But you can't get Vlan 10 to talk to vlan 20?

I can't think of any setitng on the WLC that would cause this.

Perhaps you could provide the running-config of the 1921?

Can you get a wired computer in vlan 10 and see if they can talk to vlan 20?

New Member

Re: Wireless clients cannot connect to other local nets

weterry, thank you for your answer!

I've recalled even more interesting fact - I cannot ping wireless clients (residing in VLAN 10) even from the subinterface of VLAN 10 on 1921. At that, wireless clients can ping this subinterface (that is, the IP address 10.0.10.1, see below the config below). It's really driving me mad... So, it looks like the problem is rooted there - in being unable even to ping wifi clients from the router itself.

Here is the relevant part of the config:

!  - this is inside interface
interface GigabitEthernet0/0
no ip address
ip nat inside
ip virtual-reassembly in
duplex auto
speed auto
!

! - this is subinterface of VLAN 10 (for wifi clients)

!
interface GigabitEthernet0/0.10
encapsulation dot1Q 10
ip address 10.0.10.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
! - I've change VLAN 20 to VLAN 1 (native), but the problem seems to have nothing to do with VLAN 20 or VLAN 1
!
interface GigabitEthernet0/0.20
encapsulation dot1Q 1 native
ip address 10.0.20.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
interface GigabitEthernet0/1
ip address A.B.C.D 255.255.255.248
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto
!
ip forward-protocol nd
!
ip nat inside source list 120 interface GigabitEthernet0/1 overload
ip route 0.0.0.0 0.0.0.0 A.B.C.D
!
access-list 120 permit ip 10.0.10.0 0.0.0.255 any
access-list 120 permit ip 10.0.20.0 0.0.0.255 any

Hall of Fame Super Silver

Re: Wireless clients cannot connect to other local nets

You mentioned that the WLC is connected to an unmanaged switch. So how are defining vlan 10 and vlan 20 on the switch? The only way I can see this work (just thinking out loud) is if you have two unmanaged switches. One for wireless and one for the wired pc's. Then you would connect on switch to one port in the 1921 as access vlan 10 and the other unmanaged switch in the 1921 as access vlan 20. The wlc would be connected to vlan 10 along with the wireless users. I don't know how the unmanaged switch handle vlan tagging so try to set the wlc management interface to untagged and see I that works or else set it to vlan 10.

Sent from Cisco Technical Support iPhone App

-Scott
*** Please rate helpful posts ***
498
Views
0
Helpful
3
Replies
CreatePlease to create content