Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Wireless controller 5508 web authentication not working

Hello,

all of our users do not get the cisco web authentication web page on there browser to connect to our guest ssid. It used to work the weird part they can connect to the access point and get an IP address from the wireless controller. I tried manually entering the IP address of the wireless controller from my browser on my laptop and I don't see anything. I tried the same address from my desktop and it worked?

Any suggestions what things I should look at to solve this issue.

 

 

5 REPLIES
VIP Purple

Check your DNS settting

Check your DNS settting unders DHCP scope and as well as under Virtual interface on WLC.

This is the only issue create problems or block the webauth page.

you can use Google Public DNS ip example: 8.8.8.8 in DHCP scope for guest client.

Also try with different web browsers.

 

Regards

Dont forget to rate helpful posts

Cisco Employee

Hi, You need not to put the

Hi,

 

You need not to put the WLC ip address for testing. It should be the Virtual ip address of the WLC where the web page is located.If it is 1.1.1.1 then  try http://1.1.1.1/login.html to start with. Then try http://2.3.4.5.

If the page comes then that means you have DNS issue while you type some URL and it doesnt get redirects. You can also to nslookup to verify it.

Good luck.

 

Regards

Dhiresh

New Member

You can also make sure that

You can also make sure that https redirect is enabled. If it is not enabled and the homepage is a secure site then the web auth redirect will not work.

New Member

hi,

hi,

I have recently upgraded the wireless controller 5508 to version 8.3.102.0, i now have a web authentication problem, when people connect they redirect to https://1.1.1.1 but when they put/submit username and passwords the page does not respond, it doesn't even send error messages.

what could be the problem?

Cisco Employee

Are you using multicast mac

Are you using multicast mac as gateway?

5508 Web Auth breaks with multicast MAC as gateway
CSCtd34312

Symptom:
Webauth does not work on a 5508 when using a multicast MAC gateway.
Conditions:
5508 WLC
Webauth enabled.
Gateway using a Multicast MAC address.
Workaround:
Disable web auth.
Disable use of a Multicast MAC address for gateway.
Use a 4400.
Further Problem Description:
Problem is not seen on a 4400 with the identical configuration. The 4400 was replaced by the 5508 and webauth has never worked with the mac address as the gateway. If you use a different interface, without the Multicast MAC Address, webauth works.

498
Views
0
Helpful
5
Replies
CreatePlease login to create content