Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Wireless on 877W with single vlan

Hi Guys

I have been struggling for a week now trying to get wireless working on my Cisco 877W. All the other functions are fine, DSL, VPNs, FW, but I cannot get the wireless to work at all.

The configuration is very confusing, and I even resorted to using the SDM, but this messed up other things and still wouldn't work!

I have a vlan1 already, 192.168.1.0/24. I don't want to create a new vlan; I want the wireless network to be part of the existing vlan.

I can't figure out if I need to use a BVI interface. I found what looks like a good document, http://www.cisco.com/univercd/cc/td/doc/product/access/acs_fix/85x87x/857swcg/eng/pt2/wireless.htm, but this doesn't apply to my situation and I cannot figure out how to get things working on one vlan.

Any useful information would be much appreciated :-)

Thanks

Gareth

3 REPLIES

Re: Wireless on 877W with single vlan

Yes you would need to use a BVI interface. move the address from the vlan to the BVI, on the DotRadio0 interface issue the command brdige-group 1, and issue the same command on the Fast Ethernet. Move the nat inside statements from the FE port to the BVI and give it a shot.

The config referenced in the doc, just shows how to do it with multiple vlans. if you only have one, just set the interface to the bridge group, no need to do subinterfaces.

Hope this helps.

HTH, Steve ------------------------------------------------------------------------------------------------ Please remember to rate useful posts, and mark questions as answered
New Member

Re: Wireless on 877W with single vlan

interface Dot11Radio0

no ip address

load-interval 30

!

ssid xxxxxxxxx

authentication open

!

speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0

rts threshold 2312

channel 2437

station-role root

no cdp enable

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 input-address-list 700

bridge-group 1 output-address-list 700

bridge-group 1 spanning-disabled

bridge-group 1 port-protected

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

!

interface Vlan1

no ip address

load-interval 30

bridge-group 1

!

!interface BVI1

ip address x

ipv6 address 2001:888:xxxxxxxx

ipv6 bridge 1 protocol ieee

ipv6 nd prefix 2001:888xxxxxxxx

!

!

bridge 1 route ip

enable

-------

I can't get IPV6 working yet and have no clue yet how to do WPA security on the wireless.....

but BVI/VLAN1 is working.

Re: Wireless on 877W with single vlan

to do WPA with a Pre Shared Key

Int Dot 0

encryption mode ciphers tkip

ssid xxxxxxxxx

authentication open

authentication wpa-psk

wpa key-management 0

as for IPv6, make sure the image you have supports it.

HTH, Steve ------------------------------------------------------------------------------------------------ Please remember to rate useful posts, and mark questions as answered
230
Views
5
Helpful
3
Replies