Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

WLC 5760 with internal DHCP server, clients no get IP address

Hi all,

 

I have  2  Cisco 5760 WLC (active-standby)  IOS-Xe 03.03.03SE  with  one WLAN.

 

 sh wlan summary 

Number of WLANs: 1

WLAN Profile Name                     SSID                           VLAN Status 
--------------------------------------------------------------------------------
1    Invitados_ADSL                   Guest                          905  UP

 

sh vlan         

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Te1/0/3, Te1/0/4, Te1/0/5, Te1/0/6, Te2/0/3
                                                Te2/0/4, Te2/0/5, Te2/0/6
100  VLAN0100                         active    Te1/0/1, Te2/0/1
101  Planta_1                         active    
905  Internet                         active    Te1/0/2, Te2/0/2

 

The DHCP server is internal.

Sometimes the clients no get IP address and the DHCP pool has IP addresses available.

The workaround done by me to solve the issue is “clear  ip dhcp  binding *”.

Some days later the problem appears again.

I see this bug with a similar problem:

 

NGWC blocks DHCP traffic if wireless broadcast disabled
CSCun88928
Symptom:
Some clients set the BROADCAST flag on the DHCP Discover packet. This requires the DHCP server to reply with a broadcast.
In that case and if you are not using DHCP snooping on the 5760/3850, then the controller will block the return traffic unless you enable "wireless broadcast" which enables broadcast globally (and is thus not always desirable)

Conditions:
Seen on 3.3.2 IOS-XE

Workaround:
Use DHCP snooping with the "ip dhcp snooping wireless bootp-broadcast command"
OR
Enable "wireless broadcast" globally

 

My DHCP configuration is:

 

ip dhcp relay information trust-all
ip dhcp snooping vlan 905
ip dhcp snooping
ip dhcp excluded-address 172.16.0.1 172.16.0.19
ip dhcp excluded-address 172.16.1.250 172.16.1.254
!
ip dhcp pool Invitados
 network 172.16.0.0 255.255.254.0
 default-router 172.16.0.1 
 dns-server 212.66.160.2 212.49.128.65 
 lease 0 8
!

I see in Cisco documentation (http://www.cisco.com/en/US/docs/wireless/technology/5760_deploy/CT5760_Centralized_Configuration_eg.html) this configuration:

DHCP Snooping and Trust Configuration on CT5760

ip dhcp snooping vlan 100, 200
ip dhcp snooping wireless bootp-broadcast enable
ip dhcp snooping
interface TenGigabitEthernet1/0/1
description Connection to Core Switch
switchport trunk allowed vlan 100, 200
switchport mode trunk
ip dhcp relay information trusted ip dhcp snooping trust
interface Vlan100
description Client Vlan
ip dhcp relay information trusted

 

My question is,Do I have to add the command "ip dhcp snooping wireless bootp-broadcast enable" to solve the issue?

Thanks in advance.

Regards.

 

 

D

4 REPLIES
VIP Purple

Yes, test it with the command

Yes, test it with the command you mentioned

ip dhcp snooping wireless bootp-broadcast enable

 

HTH

Rasika

**** Pls rate all useful responses *****

New Member

Hi Rasika,I´ll test it and

Hi Rasika,

I´ll test it and tell you if it solve the issue.

 

Thanks.

Kind regards.

New Member

Did you get a chance to test

Did you get a chance to test it? I'm experiencing similar problems and are interested in what the result might be.

New Member

Hi Christian, I don´t test it

Hi Christian,

 

I don´t test it yet.

We hope to do it next week.

If  it solve the issue I´ll inform you.

 

Regards.

 

1073
Views
0
Helpful
4
Replies
CreatePlease login to create content