Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

WLC Code Upgrade

We just got a WLC 4002 with 3.2.150.10 software version. I have followed a procedure to upgrade and I know I need to follow this path 3.2.150.10->4.1->4.2.176.0->5.2

However, I have tried to transfer the 4.1.185 on my controller and I get a

TFTP Failure while storing in flash!

error.

Has anybody experience this?? any adive?

2 REPLIES
Hall of Fame Super Gold

Re: WLC Code Upgrade

1. You could be either using a TFTP server that could not support file transfers greater than 32 MB (if this is the case, go to http://tftpd32.jounin.net/tftpd32_download.html and use TFTP32).

2. Looks like you were upgrading the firmware without upgrading the Bootloader (ER).

Using the same process as the firmware, download and install Bootloader (in the follwoing order)

AIR-WLC4400-K9-4-1-171-0-ER.aes before you install firmware 4.1.185. Then

AIR-WLC4400-K9-4-2-61-0-ER.aes and install AIR-WLC4400-K9-4-2-61-0.aes. Finally, install Bootloader

AIR-WLC4400-K9-5-2-157-0-ER.aes before you install the final 5.x firmware you want.

Sorry, it's a very long process but it's the only way.

Have you seen this documentation:

Wireless LAN Controller (WLC) Software Upgrade

www.cisco.com/en/US/tech/tk722/tk809/technologies_configuration_example09186a00805f381f.shtml

Re: WLC Code Upgrade

Also make sure your tftp server support file sizes larger than 32meg.

354
Views
0
Helpful
2
Replies
CreatePlease to create content